Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-04-21, 03:52:45

Author Topic: issue with SSL  (Read 3114 times)

0 Members and 1 Guest are viewing this topic.

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
issue with SSL
« on: 2016-06-17, 17:46:07 »
I did a fresh install of CentOS 6 x64 (openvz)with the latest version of KloxoMR7.
service httpd failed .
/var/log/httpd/error_log
Init: Unable to read server certificate from file /home/kloxo/ssl/venet0_0___localhost.pem
SSL Library Error: 218529960 error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
SSL Library Error: 218595386 error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #1 on: 2016-06-17, 18:16:22 »
Try 'yum reinstall kloxomr7 -y; sh /script/fixssl; sh /script/restart-web -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #2 on: 2016-06-18, 10:58:03 »
still the same.

It was a fresh install ,and I have another fresh install.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #3 on: 2016-06-18, 14:57:43 »
Inform here 'sh /script/sysinfo'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #4 on: 2016-06-20, 14:01:24 »
A. Control Panel:               
   - Kloxo-MR: 7.0.0.b-2016062002
   - Web: hiawatha-10.3.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: demo.vpscool.com
C. Services:
   1. MySQL: MariaDB-server-10.0.25-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php54-cli-5.4.45-1.ius.el6.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.3.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.39-3.el6.x86_64
     - Nginx: nginx-1.11.1-1.el6.ngx.x86_64
     - Apache: httpd-2.2.31-1.mr.el6.x86_64
       - PHP Type: [unknown]
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.7-1.mr.el6.x86_64
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: none
      - smtp: none
      - spam: bogofilter-1.2.4-1.el6.x86_64
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          2048        438       1609          2          0        219
   -/+ buffers/cache:        218       1829
   Swap:          512          0        512
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs       60G  1.9G   59G   4% /

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #5 on: 2016-06-20, 14:40:20 »
Need website running (can be access sucessfully) before create ssl.

For your setting, select 'php-fpm_event' for 'php type' in 'webserver configure'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #6 on: 2016-06-20, 15:01:17 »
A. Control Panel:               
   - Kloxo-MR: 7.0.0.b-2016062002
   - Web: hiawatha-10.3.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: demo.vpscool.com
C. Services:
   1. MySQL: MariaDB-server-10.0.25-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php54-cli-5.4.45-1.ius.el6.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.3.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.39-3.el6.x86_64
     - Nginx: nginx-1.11.1-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.20-3.ius.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: none
     - Bind: --uninstalled--
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: package none-toaster is not installed
      - smtp: package none-toaster is not installed
      - spam: package none is not installed
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          2048        461       1586          2          0        232
   -/+ buffers/cache:        229       1818
   Swap:          512          0        512
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs       60G  1.8G   59G   3% /



still the same after running
yum reinstall kloxomr7; sh /script/fixssl; sh /script/fixphp; sh /script/fixweb; sh /script/restart-web

It's a issue with http not the php-fpm.
And you can find the same issue in
https://forum.mratwork.com/kloxo-mr-technical-helps/ssl-error-after-upgrade
https://forum.mratwork.com/kloxo-mr-technical-helps/major-issues-with-any-web-server-on-kloxomr7/

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #7 on: 2016-06-20, 15:08:47 »
What's your domain that have a problem?.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #8 on: 2016-06-20, 15:58:11 »
I have sent you a new VPS with no install,
Can you have a test in your side ?

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #9 on: 2016-06-20, 16:02:22 »
Try install acme.sh with 'sh /script/acme.sh-installer' and then try add letsencrypt again.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #10 on: 2016-06-20, 16:23:18 »
cat /var/log/httpd/error_log
AH00016: Configuration Failed

new issue.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #11 on: 2016-06-20, 16:43:24 »
Try using apache 2.4 (with enable 'enable apache 2.4') with trick to change to nginx and then change to apache (with enable 'enable apache 2.4').

To make sure, run 'sh /script/restart-all -y' from ssh.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline zjsz007

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #12 on: 2016-06-20, 17:10:11 »

Stopping php-fpm (PHP Used):                               [  OK  ]
Starting php-fpm (PHP Used):                               [  OK  ]
-------------------------------------------------------------------

Stopping httpd:                                            [FAILED]
Starting httpd:                                            [FAILED]

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: issue with SSL
« Reply #13 on: 2016-06-20, 17:57:02 »
Still trouble with httpd. Try update Kloxo-MR with 'yum clean all; yum update -y; sh /script/cleanup'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: issue with SSL
« Reply #14 on: 2018-03-27, 22:10:16 »
Problem Occurs due to wrong configuration of SSL Files in Apache. Please delete all your SSL Certificates and start apache. Once it starts successfully, you can install ssl again. Hope that works because mine worked for same problem

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.037 seconds with 19 queries.

web stats analysis