Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2021-12-06, 06:30:20

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - barrysmoke

Pages: [1]
1
I'm a linux engineer, so I don't post unless I can't figure things out.
all mail sending is getting this in the /var/log/maillog :
Code: [Select]
Aug 24 03:03:02 srv1 send: delivery 9: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
Aug 24 03:03:02 srv1 send: status: local 0/10 remote 1/60
Aug 24 03:03:02 srv1 send: delivery 10: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/
Aug 24 03:03:02 srv1 send: status: local 0/10 remote 0/60

I couldn't figure out why an smtp connection can't be established, tried to telnet manually to the servers I'm trying to send to, and it works fine, so no firewall issue between the server, and the recipient smtp servers.

then, I figured out, its not even trying.  I ran a packet capture on the firewall between this server, and the internet.  full packet capture. 
here is a summary of what I saw, I can attach the capture if you want to see it.
1)my mail client connects to server, sends email over smtp-ssl
2)qmail receives the mail, and does some name server querying of the ip address the sender is using, but does no querying on the recipients domain/mail server, I saw no query for an mx record, or anything.

with that information I suspected spamdyke, so I used kloxo-mr to whitelist my sending ip, so spamdyke would ignore it.

result is, I see a lot fewer queries for my mail client, 1 actually that I can find in this large dump file
(which on my home network, resolves to x.x.x.x.in-addr.arpa PTR x-x-x-x.fidanet.com)

I see the dns queries for my personal gmail account mx record, and my account on another private server I have access to its smtp log files.
no smtp connection was even attempted to either server.  I think something is broken in implementation, or combination of communication between spamdyke, and qmail smtp, it defers rather than actually attempting to try an smtp connection to send the mail.

I can provide remote access if you would like to login and check it out.

2
I was looking at softlimit, if it was needed to fix an imap problem I was having with outlook.
turned out to be an outlook bug, but in the process, I found setting /var/qmail/control/softlimit triggers these service start failures:
Code: [Select]
Aug 24 01:23:24 srv1 submission: ./run: line 68: exec: 64000000: not found
Aug 24 01:23:24 srv1 smtp: ./run: line 69: exec: 64000000: not found
Aug 24 01:23:24 srv1 pop3: envdir: fatal: unable to run 64000000: file does not exist
Aug 24 01:23:24 srv1 smtp-ssl: ./run: line 69: exec: 64000000: not found
Aug 24 01:23:24 srv1 pop3-ssl: envdir: fatal: unable to run 64000000: file does not exist
Aug 24 01:23:24 srv1 imap4: envdir: fatal: unable to run 64000000: file does not exist
I think /var/bin/softlimit is supposed to preceed your edits, but I'll let you look into it, and test it out.

3
first, I'll say this is the closest to a fully working kloxo-mr I've been in 2 days. 
everything working perfectly except 2 things, a blank mail settings page, with no errors displayed.  I can't even find an error in a log file, telling me what's going on.

here is the link that is generated
Code: [Select]
https://xxx.xxx.xxx.xxx:7777/display.php?frm_action=updateform&frm_subaction=update&frm_o_o[0][class]=pserver&frm_o_o[0][nname]=localhost&frm_o_o[1][class]=servermail
I've re-installed *-toaster, ran cleanup, fix-all, fixmail-all, fixweb-all, done sh /script/upcp many many times, all of this has fixed several issues, but this one.
I just have no idea what to do next.
how much to have you take a look, I would pay consulting, or even just donate a bit.

here is my sysinfo:
Code: [Select]
[root@srv1 script]# sh sysinfo
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017082301
   - Web: hiawatha-10.6.0-f.1.mr.el7.x86_64
   - PHP: php56s - 5.6.31-1.ius.centos7 (fpm mode)
B. Plateform:
   - OS: CentOS Linux release 7.3.1611 (Core) x86_64
   - Hostname: srv1.phatlabz.com
C. Services:
   1. MySQL: MariaDB-server-10.0.32-1.el7.centos.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.31-1.ius.centos7.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el7.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el7.x86_64
     - Nginx: nginx-1.13.4-1.el7.ngx.x86_64
     - Apache: httpd24u-2.4.27-1.ius.centos7.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el7.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el7.x86_64
     - NSD: nsd-4.1.16-1.el7.x86_64
     - PowerDNS: pdns-4.0.3-1.el7.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el7.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el7.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - spam: --uninstalled--
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.42-3.el7.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
              total        used        free      shared  buff/cache   available
Mem:           2505        1020         857           9         627        1408
Swap:          2047           0        2047
E. Disk Space:
Filesystem           Size  Used Avail Use% Mounted on
/dev/mapper/cl-root   50G  2.6G   48G   6% /


*** Process Time: 00:00:00:20.20962 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

Pages: [1]

MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.044 seconds with 16 queries.

web stats analysis