Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-25, 23:51:14

Author Topic: [TIP] How to setup Qmail on Kloxo-MR  (Read 27985 times)

0 Members and 1 Guest are viewing this topic.

Offline rAXv2

  • Valuable Member
  • *
  • Posts: 68
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #15 on: 2013-06-26, 14:22:31 »
getting error after update...

Code: [Select]
 mailaccount_add_failed
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #16 on: 2013-06-26, 15:50:51 »
restart qmail with 'qmailctl stop; qmailctl start' and kloxo with 'sh /script/restart'.

Qmail need 'special treatment' because not using 'standard' service but 'supervise' service. Example, 'qmailctl restart' not the same effect with 'qmailctl stop; qmailctl start'
« Last Edit: 1970-01-01, 01:00:00 by Guest »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,888
  • Karma: +1/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #17 on: 2013-06-26, 16:18:45 »
This is the only solution !

/etc/rc.d/init.d/qmail stop
/etc/rc.d/init.d/qmail start
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #18 on: 2013-06-26, 16:22:00 »
Quote from: "Spacedust"
This is the only solution !

/etc/rc.d/init.d/qmail stop
/etc/rc.d/init.d/qmail start
It's the same way with:
Code: [Select]
qmailctl stop
qmailctl start
« Last Edit: 1970-01-01, 01:00:00 by Guest »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,888
  • Karma: +1/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #19 on: 2013-06-26, 16:24:24 »
Quote from: "MRatWork"
Quote from: "Spacedust"
This is the only solution !

/etc/rc.d/init.d/qmail stop
/etc/rc.d/init.d/qmail start
It's the same way with:
Code: [Select]
qmailctl stop
qmailctl start

I didn't know. Exactly :)
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #20 on: 2013-06-26, 16:28:07 »
Or:
Code: [Select]
service qmail stop
service qmail start
« Last Edit: 1970-01-01, 01:00:00 by Guest »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline WISTFUL

  • Senior Member
  • *
  • Posts: 235
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #21 on: 2013-06-27, 13:24:18 »
Quote from: "MRatWork"
Have you click 'Enable SPF' on 'Mail Auth' and ask to your provider for reverse-dns for your ip?.

Error:
Code: [Select]
Hi. This is the qmail-send program at xxxx.domain.ltd.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.
that mean your email target not exist and or their server not exist/active.

I set my Server Mail according (this instruction).

So I set "server.mydomain.ltd" to below values:

* Server Mail Settings > My name
* Information > FQDN Hostname
* reverse-dns of My server IP

Then I upgrade my kloxo-mr from 6.5.0.f-2013031808 to 6.5.0.f-2013031825 as Final Release.

Also according (this instruction) I change permission of "qmail-dk" to "4755"

Now my issue still not solved and I can only send email to gmail and personal domains (no any yahoo addresses) via webmail.

Also every some times I get 3 emails from lfd firewall with below content for port 25 and 587 and 465:

lfd on vmi775: Suspicious process running under user qmaild
Code: [Select]
Time:    Thu Jun 27 06:14:30 2013 +0000
PID:     4471 (Parent PID:1273)
Account: qmaild
Uptime:  109 seconds


Executable:

/usr/bin/tcpserver


Command Line (often faked in exploits):

/usr/bin/tcpserver -v -R -H -l vmi775 -x /etc/tcprules.d/tcp.smtp.cdb -c 100 -u 7791 -g 2108 0 25 /usr/bin/recordio /var/qmail/bin/qmail-smtpd /home/vpopmail/bin/vchkpw /bin/true


Network connections by the process (if any):

tcp: 0.0.0.0:25 -> 0.0.0.0:0


Files open by the process (if any):



Memory maps by the process (if any):

00400000-0040c000 r-xp 00000000 fc:01 6818281                            /usr/bin/tcpserver
0060c000-0060d000 rw-p 0000c000 fc:01 6818281                            /usr/bin/tcpserver
0060d000-0060e000 rw-p 00000000 00:00 0
01940000-01961000 rw-p 00000000 00:00 0                                  [heap]
393b800000-393b820000 r-xp 00000000 fc:01 7864349                        /lib64/ld-2.12.so
393ba1f000-393ba20000 r--p 0001f000 fc:01 7864349                        /lib64/ld-2.12.so
393ba20000-393ba21000 rw-p 00020000 fc:01 7864349                        /lib64/ld-2.12.so
393ba21000-393ba22000 rw-p 00000000 00:00 0
393bc00000-393bd8a000 r-xp 00000000 fc:01 7864395                        /lib64/libc-2.12.so
393bd8a000-393bf89000 ---p 0018a000 fc:01 7864395                        /lib64/libc-2.12.so
393bf89000-393bf8d000 r--p 00189000 fc:01 7864395                        /lib64/libc-2.12.so
393bf8d000-393bf8e000 rw-p 0018d000 fc:01 7864395                        /lib64/libc-2.12.so
393bf8e000-393bf93000 rw-p 00000000 00:00 0
7f10b8441000-7f10b8444000 rw-p 00000000 00:00 0
7f10b844c000-7f10b844d000 rw-p 00000000 00:00 0
7fff46b5b000-7fff46b70000 rw-p 00000000 00:00 0                          [stack]
7fff46b9a000-7fff46b9b000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
« Last Edit: 1970-01-01, 01:00:00 by Guest »
.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #22 on: 2013-06-27, 13:51:44 »
If only certain accounts not accept your mail that mean nothing wrong with send/smtp.

Command of '/usr/bin/tcpserver -v -R -H -l vmi775 -x /etc/tcprules.d/tcp.smtp.cdb -c 100 -u 7791 -g 2108 0 25 /usr/bin/recordio /var/qmail/bin/qmail-smtpd /home/vpopmail/bin/vchkpw /bin/true' is 'run' supervise for smtp (port 25) by qmail. Nothing wrong with it and you don't need '4755' for 'qmail-dk'.
« Last Edit: 1970-01-01, 01:00:00 by Guest »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline WISTFUL

  • Senior Member
  • *
  • Posts: 235
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #23 on: 2013-06-27, 14:06:29 »
As I said before, I still have not set Qmail on Kloxo-MR according to the first post of this topic.
In your opinion, set Qmail on Kloxo-MR instruction, will solve my issue?
« Last Edit: 1970-01-01, 01:00:00 by Guest »
.

Offline WISTFUL

  • Senior Member
  • *
  • Posts: 235
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #24 on: 2013-06-28, 19:32:59 »
Quote from: "WISTFUL"
Hello,

I still have not acted in accordance with these guidelines.

My current problem is that when I send email via webmail to gmail or emails with personal provider, It works perfectly but when I send email to yahoo provider, I reseive below failure notice
Code: [Select]
Hi. This is the qmail-send program at xxxx.domain.ltd.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<xxx@yahoo.com>:
Connected to 66.196.118.240 but greeting failed.
Remote host said: 421 4.7.1 [TS03] All messages from xxx.xxx.xxx.xx will be permanently deferred; Retrying will NOT succeed. See http://postmaster.yahoo.com/421-ts03.html
I'm not going to try again; this message has been in the queue too long.
Do you offer that I will act in accordance with these guidelines?
(In case of a disruption in the webmail system may lose my clients)

I realized that It is because my server IP goes to yahoo black list for unknown reasons.

I've sent below form and I hope it can help me:
http://help.yahoo.com/l/us/yahoo/mail/p ... ulkv2.html
« Last Edit: 1970-01-01, 01:00:00 by Guest »
.

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #25 on: 2015-01-10, 19:22:35 »
Tried everything. But don't have luck :(

When I give command sh /script/fixmail-all then:

- 'postmaster@domain.org' ('blabla') at 'localhost'
maildirmake: /postmaster/Maildir/.Drafts: File exists
maildirmake: /postmaster/Maildir/.Sent: File exists
maildirmake: /postmaster/Maildir/.Trash: File exists
maildirmake: /postmaster/Maildir/.Spam: File exists
sh: /usr/bin/vpasswd postmaster@domain.org Password 2>&1': No such file or directory
sh: /usr/bin/vmoduser -x postmaster@domain.org 2>&1': No such file or directory
sh: /usr/bin/vsetuserquota postmaster@domain.org NOQUOTA 2>&1': No such file or directory

copied vpasswd to /usr/bin from /home/vpopmail/bin
But it's same.

give this command from shell: /usr/bin/vpasswd postmaster@domain.org Password
then error like this:
Error. Domain selengehudulmur.com was not found in the assign file

Can't find cause. Please help me.
« Last Edit: 2015-01-10, 20:09:54 by Almas »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #26 on: 2015-01-10, 22:19:56 »
@almas,

Inform here 'sh /script/sysinfo'. Did you update from Kloxo official 6.1.x?.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #27 on: 2015-01-10, 22:43:38 »
Yes updated from kloxo official.
But it was worked when after upgrade.

I have quota problem on my OpenVZ VPS and after that I did yum update and problem occured.

Here is sysinfo

[root@server ~]# sh /script/sysinfo

/usr/bin/cat: /etc/*release: No such file or directory
rpmq: no arguments given for query
rpmq: no arguments given for query
rpmq: no arguments given for query
rpmq: no arguments given for query

A. Kloxo-MR: 7.0.0.b-2015010905

B. OS:  x86_64

C. Apps:
   1. MySQL: --uninstalled--
   2. PHP: --uninstalled--
   3. Httpd: httpd-2.2.29-1.mr.el5
   4. Lighttpd: --uninstalled--
   5. Hiawatha: hiawatha-9.10.1-f.1.mr.el5
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: qmail-toaster-1.03-1.3.45.mr.el5
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el5

D. Php-type (for Httpd/proxy):

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          7347       2471       4876          0          0       1636
   -/+ buffers/cache:        834       6513
   Swap:         2048         10       2037




Also I did fix-chownchmod that mentioned before. But this bug occured:
http://forum.mratwork.com/kloxo-mr-bugs-and-requests/fix-chownchmod-error/

Also some info is false here:
   1. MySQL: --uninstalled-- (Installed mysql55)
   2. PHP: --uninstalled-- (Installed php-fpm)
   8. Dns: --uninstalled-- (Insalled nsd)

My System: CentOS 5.11
« Last Edit: 2015-01-10, 22:52:06 by Almas »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,483
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #28 on: 2015-01-10, 22:51:41 »
Look like something wrong with your OS. Try reinstall with 'sh /script/upcp -y; sh /script/convert-to-qmailtoaster'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #29 on: 2015-01-10, 23:16:48 »
Tried reinstall with 'sh /script/upcp -y; sh /script/convert-to-qmailtoaster'
and rebooted
But error still same. Also sh /script/sysinfo info is same as above

My system is CentOS5.11

Any other suggestions?

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.06 seconds with 18 queries.

web stats analysis