Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-28, 02:51:05

Author Topic: [TIP] How to setup Qmail on Kloxo-MR  (Read 28034 times)

0 Members and 1 Guest are viewing this topic.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #30 on: 2015-01-10, 23:22:56 »
Inform here 'yum list installed mysql* php* *-toaster'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #31 on: 2015-01-10, 23:25:00 »
Thank you very much for helping :)

[root@server script]# yum list installed mysql* php* *-toaster
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * addons: mirror.sanctuaryhost.com
 * base: centos.mia.host-engine.com
 * extras: mirror.ash.fastserv.com
 * mratwork-epel: www.gtlib.gatech.edu
 * mratwork-ius-stable: mirror.symnds.com
 * openvz-kernel-rhel5: mirror.steadfast.net
 * openvz-utils: mirror.steadfast.net
 * updates: centos.mirror.nac.net
Excluding Packages from MRatWork - Extra Packages for EL 5 - arch
Finished
Excluding Packages from MRatWork - IUS Community Packages for EL 5 (archive) - arch
Finished
Excluding Packages from MRatWork - IUS Community Packages for EL 5 (stable) - arch
Finished
0 packages excluded due to repository protections
Installed Packages
autorespond-toaster.x86_64                                              2.0.5-1.4.2.mr.el5                                              installed
control-panel-toaster.noarch                                            0.5-1.4.1.mr                                                    installed
courier-authlib-toaster.x86_64                                          0.59.2-1.3.13.mr.el5                                            installed
courier-imap-toaster.x86_64                                             4.1.2-1.3.18.mr.el5                                             installed
daemontools-toaster.x86_64                                              0.76-1.3.7.mr.el5                                               installed
ezmlm-toaster.x86_64                                                    0.53.324-1.3.9.mr.el5                                           installed
libdomainkeys-toaster.x86_64                                            0.68-1.3.7.mr.el5                                               installed
libsrs2-toaster.x86_64                                                  1.0.18-1.3.7.mr.el5                                             installed
maildrop-toaster.x86_64                                                 2.0.3-1.3.9.mr.el5                                              installed
qmail-pop3d-toaster.x86_64                                              1.03-1.3.45.mr.el5                                              installed
qmail-toaster.x86_64                                                    1.03-1.3.45.mr.el5                                              installed
ripmime-toaster.x86_64                                                  1.4.0.6-1.3.8.mr.el5                                            installed
send-emails-toaster.noarch                                              0.5-1.4.1.mr                                                    installed
simscan-toaster.x86_64                                                  1.4.0-1.4.2.mr.el5                                              installed
spamassassin-toaster.x86_64                                             3.4.0-1.4.6.mr.el5                                              installed
squirrelmail-toaster.noarch                                             1.4.20-1.3.18.mr                                                installed
ucspi-tcp-toaster.x86_64                                                0.88-1.3.11.mr.el5                                              installed
vpopmail-toaster.x86_64                                                 5.4.33-1.4.4.mr.el5                                             installed
[root@server script]#

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #32 on: 2015-01-11, 00:25:32 »
Look like mysql55 and php53u not installed in your server. This issue possible happen if you have other repos make conflict with mratwork.repo.

Inform here 'dir -l /etc/yum.repos.d'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #33 on: 2015-01-11, 08:49:12 »
oh. It's allready installed :(

Package mysql55-5.5.41-2.ius.el5.x86_64 already installed and latest version
Package php53u-5.3.29-1.ius.el5.x86_64 already installed and latest version

I made enabled=0 on other repos.

-rw-r--r-- 1 root root 2049 ???  7 23:54 CentOS-Base.repo
-rw-r--r-- 1 root root  645 ??? 19 13:16 CentOS-Debuginfo.repo
-rw-r--r-- 1 root root  277 ??? 19 13:16 CentOS-fasttrack.repo
-rw-r--r-- 1 root root  626 ??? 19 13:16 CentOS-Media.repo
-rw-r--r-- 1 root root 1330 ??? 19 13:16 CentOS-Sources.repo
-rw-r--r-- 1 root root 8315 ??? 19 13:16 CentOS-Vault.repo
-rw-r--r-- 1 root root 1054 ??? 11  2010 epel-testing.repo
-rw-r--r-- 1 root root  191 ???  3  2014 lxlabs.repo.lxsave
-rw-r--r-- 1 root root  739 ??? 12  2010 mirrors-rpmforge
-rw-r--r-- 1 root root  717 ??? 12  2010 mirrors-rpmforge-extras
-rw-r--r-- 1 root root  728 ??? 12  2010 mirrors-rpmforge-testing
-rw-r--r-- 1 root root  123 ??? 10 21:09 mod-pagespeed.repo
-rw-r--r-- 1 root root  667 ??? 19  2013 mod_securty_testing.repo
-rw-r--r-- 1 root root 6596 ??? 10 23:52 mratwork.repo
-rw-r--r-- 1 root root 6596 ??? 18 13:08 mratwork.repo.rpmsave
-rw-r--r-- 1 root root 2120 ??? 25  2013 openvz.repo
-rw-r--r-- 1 root root 2298 ??? 24  2014 remi.repo
-rw-r--r-- 1 root root 1113 ??? 18  2013 rpmforge.repo
-rw-r--r-- 1 root root  166 ??? 28  2013 ruby187.repo
-rw-r--r-- 1 root root  219 ??? 22  2013 vz.repo
-rw-r--r-- 1 root root  829 ??? 10 00:22 webtatic.repo
-rw-r--r-- 1 root root  834 ??? 16  2013 webtatic.repo.rpmnew

mmm... Now it's:

[root@server wp-includes]# yum list installed mysql* php* *-toaster
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * addons: mirror.sanctuaryhost.com
 * base: centos.mia.host-engine.com
 * extras: mirror.ash.fastserv.com
 * mratwork-epel: www.gtlib.gatech.edu
 * mratwork-ius-stable: mirror.symnds.com
 * openvz-kernel-rhel5: mirror.steadfast.net
 * openvz-utils: mirror.steadfast.net
 * updates: centos.mirror.nac.net
Excluding Packages from MRatWork - Extra Packages for EL 5 - arch
Finished
Excluding Packages from MRatWork - IUS Community Packages for EL 5 (archive) - arch
Finished
Excluding Packages from MRatWork - IUS Community Packages for EL 5 (stable) - arch
Finished
0 packages excluded due to repository protections
Installed Packages
autorespond-toaster.x86_64              2.0.5-1.4.2.mr.el5             installed
control-panel-toaster.noarch            0.5-1.4.1.mr                   installed
courier-authlib-toaster.x86_64          0.59.2-1.3.13.mr.el5           installed
courier-imap-toaster.x86_64             4.1.2-1.3.18.mr.el5            installed
daemontools-toaster.x86_64              0.76-1.3.7.mr.el5              installed
ezmlm-toaster.x86_64                    0.53.324-1.3.9.mr.el5          installed
libdomainkeys-toaster.x86_64            0.68-1.3.7.mr.el5              installed
libsrs2-toaster.x86_64                  1.0.18-1.3.7.mr.el5            installed
maildrop-toaster.x86_64                 2.0.3-1.3.9.mr.el5             installed
mysql55.x86_64                          5.5.41-2.ius.el5               installed
mysql55-libs.x86_64                     5.5.41-2.ius.el5               installed
mysql55-server.x86_64                   5.5.41-2.ius.el5               installed
mysqlclient15.x86_64                    5.0.92-3.ius.el5               installed
php53s.x86_64                           5.3.28-4.mr.el5                installed
php53s-cli.x86_64                       5.3.28-4.mr.el5                installed
php53s-common.x86_64                    5.3.28-4.mr.el5                installed
php53u.x86_64                           5.3.29-1.ius.el5               installed
php53u-cli.x86_64                       5.3.29-1.ius.el5               installed
php53u-common.x86_64                    5.3.29-1.ius.el5               installed
php53u-mysql.x86_64                     5.3.29-1.ius.el5               installed
php53u-pdo.x86_64                       5.3.29-1.ius.el5               installed
qmail-pop3d-toaster.x86_64              1.03-1.3.45.mr.el5             installed
qmail-toaster.x86_64                    1.03-1.3.45.mr.el5             installed
ripmime-toaster.x86_64                  1.4.0.6-1.3.8.mr.el5           installed
send-emails-toaster.noarch              0.5-1.4.1.mr                   installed
simscan-toaster.x86_64                  1.4.0-1.4.2.mr.el5             installed
spamassassin-toaster.x86_64             3.4.0-1.4.6.mr.el5             installed
squirrelmail-toaster.noarch             1.4.20-1.3.18.mr               installed
ucspi-tcp-toaster.x86_64                0.88-1.3.11.mr.el5             installed
vpopmail-toaster.x86_64                 5.4.33-1.4.4.mr.el5            installed



« Last Edit: 2015-01-11, 09:33:04 by Almas »

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #34 on: 2015-01-11, 08:57:47 »
Your issue related to so many repos with the same 'functions'.

mratwork.repo is repo for many source (kloxo/mratwork, epel, ius and etcetera). So, delele epel-testing.repo, lxlabs.repo.lxsave, mirrors-rpmforge, mirrors-rpmforge-extras, mirrors-rpmforge-testing, mod-pagespeed.repo, mod_securty_testing.repo, mratwork.repo.rpmsave, remi.repo, rpmforge.repo, webtatic.repo and webtatic.repo.rpmnew
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #35 on: 2015-01-11, 09:32:14 »
Deleted repos. Now:
[root@server ~]# dir -l /etc/yum.repos.d
total 52
-rw-r--r-- 1 root root 2049 ???  7 23:54 CentOS-Base.repo
-rw-r--r-- 1 root root  645 ??? 19 13:16 CentOS-Debuginfo.repo
-rw-r--r-- 1 root root  277 ??? 19 13:16 CentOS-fasttrack.repo
-rw-r--r-- 1 root root  626 ??? 19 13:16 CentOS-Media.repo
-rw-r--r-- 1 root root 1330 ??? 19 13:16 CentOS-Sources.repo
-rw-r--r-- 1 root root 8315 ??? 19 13:16 CentOS-Vault.repo
-rw-r--r-- 1 root root 6596 ??? 11 10:01 mratwork.repo
-rw-r--r-- 1 root root 2120 ??? 25  2013 openvz.repo
-rw-r--r-- 1 root root  166 ??? 28  2013 ruby187.repo
-rw-r--r-- 1 root root  219 ??? 22  2013 vz.repo


Then did 'yum clean all; yum update; sh /script/upcp -y; sh /script/convert-to-qmailtoaster'

Still same.

sh /script/sysinfo
is also doesn't correct. :(

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #36 on: 2015-01-11, 09:41:05 »
Try reinstall with 'sh /script/upcp -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #37 on: 2015-01-11, 09:41:53 »
I did it allready after I removed repos. Can I downgrade to Kloxo-MR 6.5.0.f? And can it fix this issue?

I did :

 'yum clean all; yum update; sh /script/upcp -y; sh /script/convert-to-qmailtoaster'

Offline Almas

  • Junior Member
  • *
  • Posts: 45
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #38 on: 2015-01-11, 21:29:51 »
Downgraded and fixed.

Offline budibudi

  • Junior Member
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #39 on: 2015-03-31, 10:38:10 »
This tips related to Qmail-toaster (mail server) on Kloxo-MR.

Warning: - update Kloxo to Kloxo-MR need running:
Code: [Select]
sh /script/convert-to-qmailtoaster

Prepare server:
1. Choose 1 of domains or subdomains as primary 'domain' (this domain must be access from public; example: 'mydomain.com')

2. Set server hostname as subdomain of primary 'domain' (example: 'subdom.mydomain.com') and add 'subdom' as 'A record' on dns setting

3. Add 'xxx.xxx.xxx.xxx subdom.mydomain.com subdom' on '/etc/host' (change xxx.xxx.xxx.xxx with primary ip)

4. Add/Change to 'HOSTNAME="subdom.mydomain.com"' in '/etc/sysconfig/network'

5. Reboot and then run 'hostname -f' and must be appear 'subdom.mydomain.com'

Setup/Update qmail:
1. For update from Kloxo, need running 'sh /script/convert-to-qmailtoaster'
2. For to make sure, go to 'Mysql password reset' to change mysql root password
2. Running 'sh /script/fix-chownchmod; sh /script/fixmail-all'

Testing:
1. Run '/home/vpopmail/bin/vdominfo' and will be match with '/var/qmail/users/assign' content

2. If login to webmail failed, check the content of:
- '/var/qmail/supervise/imap4/run',
- '/var/qmail/supervise/imap4-ssl/run',
- '/var/qmail/supervise/pop3/run',
- '/var/qmail/supervise/pop3-ssl/run',
- '/var/qmail/supervise/smtp/run',
- '/var/qmail/supervise/submission/run'

and find out something like 'exec /usr/bin/softlimit -m 9000000 '.

Increase the value until 3-4 times but no more than 64000000. Original softlimit have a problem especially on Centos 64bit (version 5 and 6).

3. Run 'telnet localhost 25' for to make sure this port not blocked/inactive. Testing also on port 110, 143, 993, 995, 587 and 465

4. Find error on 'log manager' and 'mail queue'

--------------------
Additional info:

1. Sometimes, after Kloxo-MR update, qmail not work.

You can see in 'Log Manager' for IMAP error or SMTP error like '@400000005187cdc72b428044 tcpserver: fatal: unable to bind: address already used'.

For this situation, need reboot. Or running 'qmailctl stop; qmailctl start' (remember: 'qmailctl restart' not work).

It's ok if appear something like '@40000000518752e21fc74ac4 tcpserver: status: 0/40'

2. Repair qmail:
Code: [Select]
qmailctl stop
yum reinstall *-toaster
sh /script/fixmail-all
qmailctl stop
qmailctl start

3. If still not work, run :
Code: [Select]
chmod 4755 /home/vpopmail/bin/vchkpw
qmailctl stop
qmailctl start

==============

NOTE:
- This information not accurate for latest Kloxo-MR (6.5.0.f-2013031825)
- Only command needed:

Code: [Select]
# fix mail issue
sh /script/fixmail-all

# better stop and start instead restart
qmailctl stop
qmailctl start

==============
NOTE:
- Reinstall Qmail-toaster

Code: [Select]
# uninstall toaster
yum remove *-toaster

# remove bin and config
rm -rf /var/qmail/

# install again (including clamav and spamd) and also other applications as dependencies
yum install *-toaster webalizer cronie cronie-anacron crontabs

# run fix mail config (qmail-toaster config and webmail)
sh /script/fixmail-all

# restart (using stop and start better for this situation rather than restart)
# to make stopped and may appear error message
qmailctl stop
# start
qmailctl start

if still something wrong:
Code: [Select]
sh /script/cleanup
sh /script/fix-all
sh /script/restart-all

and check with 'qmailctl stat' and will be appear:
Code: [Select]
[root@viv ~]# qmailctl stat
authlib: up (pid 802838) 27 seconds
clamd: up (pid 802811) 27 seconds
imap4: up (pid 803967) 0 seconds
imap4-ssl: up (pid 803954) 0 seconds
pop3: up (pid 803931) 1 seconds
pop3-ssl: up (pid 803919) 1 seconds
send: up (pid 803949) 1 seconds
smtp: up (pid 803959) 0 seconds
smtp-ssl: up (pid 803932) 1 seconds
spamd: up (pid 802843) 27 seconds
submission: up (pid 803922) 1 seconds
authlib/log: up (pid 802839) 27 seconds
clamd/log: up (pid 802813) 27 seconds
imap4-ssl/log: up (pid 802833) 27 seconds
imap4/log: up (pid 802828) 27 seconds
pop3-ssl/log: up (pid 802840) 27 seconds
pop3/log: up (pid 802827) 27 seconds
send/log: up (pid 802832) 27 seconds
smtp-ssl/log: up (pid 802834) 27 seconds
smtp/log: up (pid 802837) 27 seconds
spamd/log: up (pid 802822) 27 seconds
submission/log: up (pid 802847) 27 seconds
[root@viv ~]#

==============
NOTE: - for to make sure, receipent (gmail, yahoomail and others) not thinking your email as 'spam'
- Activate 'Enable Domainkey' in 'Server Mail Settings'
- In every domain, active 'Enable SPF' in 'Mail Auth'
- As to provider to setup 'reverse-dns' for your server IP(s)


Saya sdh men-setting sesuai dengan di atas, saya sdh bisa mengirim email dgn baik (masuk inbox), kendalanya tidak bisa menerima email.

Saya menggunakan:
Quote
[root@server2 /]# sh /script/sysinfo

A. Kloxo-MR: 6.5.0.f-2015010801

B. OS: CentOS release 6.6 (Final) x86_64

C. Apps:
   1. MySQL: mysql55-5.5.42-1.ius.el6.x86_64
   2. PHP: php53u-5.3.29-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.29-1.mr.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.48.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
   7. Dns: bind-9.9.5-1.el6.x86_64

D. Php-type (for Httpd/proxy):

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          1024        400        623          3          0        169
   -/+ buffers/cache:        230        793
   Swap:          128          0        128

Setelah saya cek, di mail log terdapat error:
Quote
Mar 31 10:00:00 server2 spamdyke[9013]: DENIED_RDNS_MISSING from: budibudi61@gmail.com to: marketing@smartindo-access.com origin_ip: 209.85.212.176 origin_rdns: (unknown) auth: (unknown) encryption: TLS reason: (empty)

Saya sdh cek disini https://www.2large.co.za/spamdyke , DENIED_RDNS_MISSING artinya ditolak karena reverse DNS blm diisikan. Padahal reverse DNS sdh saya setting sesuai dengan hostname.

Saya cek sdh mengarah ke subdomain hostname (tgl setting: 28 Maret 2015, propagansi biasanya 24-48 jam):
Quote
[root@server2 /]# host 167.114.153.36
36.153.114.167.in-addr.arpa domain name pointer server2.smartindo-access.com.

Saya jg sdh cek di http://www.smtpport.com/about/#check , port 25 tidak diblok oleh ISP

Apakah yg perlu saya setting lgi agar fungsi menerima email dpt berjalan dgn baik?

Mohon bantuannya, terima kasih.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #40 on: 2015-03-31, 10:42:35 »
Rdns harus minta ke provider untuk disetting. Hanya yang mengelola IP subclass-C ke atas (256+) yang bisa melakukan setting rdns.

Sebaiknya anda buat thread baru untuk masalah anda ini. Thread yang terlalu lama bisa terlewatkan.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tomo

  • Junior Member
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #41 on: 2016-08-22, 22:22:32 »
Pak mustafa, kenapa yaa saya coba mengirim email tidak bisa dari mail host saya,,saya cek di log manager tidak ada pesan error.
Terus pada web mail list yang berhasil login hanya roundcube dan squirrelmail saja tapi tidak mengirim email,,kalo lewat rainloop saya tidak bisa login pesan nya "Domain is not allowed"
untuk Afterlogic dan Telaen tidak bisa di akses,,mohon arahannya :D

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: [TIP] How to setup Qmail on Kloxo-MR
« Reply #42 on: 2016-08-23, 01:50:27 »
Pak mustafa, kenapa yaa saya coba mengirim email tidak bisa dari mail host saya,,saya cek di log manager tidak ada pesan error.
Terus pada web mail list yang berhasil login hanya roundcube dan squirrelmail saja tapi tidak mengirim email,,kalo lewat rainloop saya tidak bisa login pesan nya "Domain is not allowed"
untuk Afterlogic dan Telaen tidak bisa di akses,,mohon arahannya :D
Silahkan buat thread baru dengan menginfokan 'sh /script/sysinfo'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.047 seconds with 19 queries.

web stats analysis