Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-06-18, 08:16:00

Author Topic: mailserver again not working  (Read 5389 times)

0 Members and 1 Guest are viewing this topic.

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
mailserver again not working
« on: 2015-12-01, 11:10:32 »
Hello mustafa please help me on this problem. a few days ago i reinstalled server and this mail problem came again.

i am not able to send or receive any mails. this problem is coming in a duration of few days automatically like its scheduled.

please help me fix this problem once and for all. give me a solution so that if it happens again i dont have to reinstall server.

here is sysinfo

Code: [Select]
sh /script/sysinfo

A. Kloxo-MR: 7.0.0.b-2015103001
   - Web: hiawatha-9.15.0-f.6.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (cgi mode)
B. Plateform:
   - OS: CentOS release 6.7 (Final) x86_64
   - Hostname: vpsxxxxx.ovh.net
C. Services:
   1. MySQL: MariaDB-server-10.0.22-1.el6.x86_64
   2. PHP:
      - Branch: php54-cli-5.4.45-1.ius.el6.x86_64
      - Multiple:
        * php55m-5.5.30-1.ius.el6
        * php56m-5.6.14-1.ius.el6
      - Used: php55m
   3. Httpd: httpd-2.2.31-1.mr.el6.x86_64
      - PHP Type: php-fpm_worker
   4. Lighttpd: --uninstalled--
   5. Hiawatha: --used--
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: bind-9.9.7-1.mr.el6.x86_64
   9. Qmail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          3736       3166        570          5        145       1787
   -/+ buffers/cache:       1233       2503
   Swap:            0          0          0
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/vda1        20G  8.0G   11G  44% /

also i tried unistallating and reinstalling qmail toaster. that also didn't work.

I also tried changin hostname.

« Last Edit: 2015-12-01, 11:27:39 by tinu »

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #1 on: 2015-12-01, 11:22:35 »
ok now i noticed that after reinstalling mails are in queue list. how to fix that. i can see all send and received mails there.

also pelase tell me how do i send mails to their respective email ids?
« Last Edit: 2015-12-01, 11:25:39 by tinu »

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #2 on: 2015-12-01, 11:30:47 »
cat /etc/resolv.conf
; generated by /sbin/dhclient-script
search local ovh.net
nameserver 2xx.1xx.3x.9x

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #3 on: 2015-12-01, 11:34:21 »
Add 'nameserver 8.8.8.8' and 'nameserver 8.8.4.4' in resolv.conf.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #4 on: 2015-12-02, 08:59:49 »
i did and rebooted my server server didn't reboot.

booted in rescue mode provided by ovh and restored resolv.conf again. server still not start.

i will inform later what happens . my guess is i have to reinstall server.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #5 on: 2015-12-02, 09:21:00 »
I don't know ovh panel but possible change nameserver via their panel.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #6 on: 2015-12-02, 11:12:30 »
dont know what is issue. i accessed my vps in rescue mode and wont able to find problem.

i am reinstalling vps and after reinstall first thing i am going to do is put google nameserver ip in resolv.conf

this resolv.conf previously stopped my internal network and now since last four installations mailserver is giving problems.

i will chattr+i resolv.conf

am i doing right?

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #7 on: 2015-12-02, 13:57:05 »
I reinstalled server and mail server is running fine now but i am sure in a few days it will stop working again. what should i do??  :(

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #8 on: 2015-12-02, 14:01:02 »
it started now again. mails are neither sending nor receiving.
mails are going to queue again.
i just restarted mail server.
thats what caused problem each time i restarted mailserver. its fresh installation.

now i am pretty sure if i restart server it wont boot. please take a look.

please help me mustafa i am giving you server ssh access.


« Last Edit: 2015-12-02, 14:03:05 by tinu »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #9 on: 2015-12-02, 17:51:05 »
Instead using 'vpsxxxxx.ovh.net'. change hostname to 'mail.oneofyourdomain.com' in /etc/sysconfig/network' and then run 'hostname -v mail.oneofyourdomain.com; sh /script/fixmail-all; sh /script/restart-mail'.

Also make sure permit/open all mail ports in ovh panel (if exists).



..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #10 on: 2015-12-02, 17:56:13 »
If still not work, give me an access to Kloxo-MR panel.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #11 on: 2015-12-03, 03:40:48 »
Thanks mustafa.

Sending mail working again. But receive mail still problem.

Mails are going to queue. In sending pm for kloxo login.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #12 on: 2015-12-03, 03:49:16 »
Thanks mustafa.

Sending mail working again. But receive mail still problem.

Mails are going to queue. In sending pm for kloxo login.
No PM accept.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: mailserver again not working
« Reply #13 on: 2015-12-03, 03:59:09 »
Did you mean you didn't received PM?

If that's what you mean can u plz check i have sent a pm again.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: mailserver again not working
« Reply #14 on: 2015-12-03, 04:51:43 »
Email already send and received but still problem because no enable 'spf' and 'dmarc' (under ''mail auth').

I think your dns setting for cloudflare still incomplete (like missing spf dan dmarc).

Test your domain via intodns.com and mxtoolbox.com.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo

Page created in 0.03 seconds with 17 queries.

web stats analysis