Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-08-14, 16:07:47

Author Topic: Nginx configuration bug  (Read 3924 times)

0 Members and 1 Guest are viewing this topic.

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Nginx configuration bug
« on: 2016-06-27, 11:26:13 »
I did it twice today and a week ago.
I install fresh Kloxo-MR7, after that I switch programm to nginx, and after restart nginx doesn't start with error
"Starting nginx: nginx: [emerg] open() "/opt/configs/nginx/conf/globals/listen_ssl_default.conf" failed (2: No such file or directory) in /opt/configs/nginx/conf/defaults/init.conf:43"
I took thesee two files from another my old VPS and copy them there, and service started well.

Also I tried nginxs+httpd and there was the same error.

I hope this information will be helpful.

I don't Know why but at 6 o'clock everyday php-fpm stops and needs hand restarting.

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: Nginx configuration bug
« Reply #1 on: 2016-06-27, 14:00:30 »
One more thing. There are no mysql DBs in backup. There are only files of zipped user folder and ziped mmail any

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx configuration bug
« Reply #2 on: 2016-06-27, 15:48:50 »
Create db in phpmyadmin directly will not include in backup.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: Nginx configuration bug
« Reply #3 on: 2016-06-27, 20:03:27 »
There is user_mysqldb-any-number.tgz in backup. And it is dump of DBs.
But now there are no mysql DBs in backup

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx configuration bug
« Reply #4 on: 2016-06-27, 20:22:02 »
All my backups files look like ok.

Make sure using latest Kloxo-MR 7.0. The latest is kloxomr7-7.0.0.b-2016062702
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: Nginx configuration bug
« Reply #5 on: 2016-06-27, 21:44:28 »
The problem was in Kloxo-MR 7.0.0.b-2016062202
Now Kloxo-MR 7.0.0.b-2016062502, installed 12 hours ago, I didn't make backup in this version. Actually that is not so huge problem, i can backup everuthing fast myself.

The more serious problem is with cinfiguration files of nginx in both version of Kloxo-MR7:
Kloxo-MR 7.0.0.b-2016062502 and Kloxo-MR 7.0.0.b-2016062202


Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: Nginx configuration bug
« Reply #6 on: 2016-06-28, 06:54:06 »
php-fpm stops at 5-57 in the morning. I have to restart it manually. Restarting with cron tabs doesn't help.

Maybe it is a good idea to move this topic to technical heklps forum?
Well, it is ok with dumps in backup.
« Last Edit: 2016-06-28, 12:09:37 by xamer »

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.056 seconds with 18 queries.

web stats analysis