Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-06-18, 03:30:37

Author Topic: phpMyAdmin table sorting giving 403 error  (Read 9242 times)

0 Members and 1 Guest are viewing this topic.

Offline aphanciale

  • Junior Member
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
phpMyAdmin table sorting giving 403 error
« on: 2014-01-19, 07:14:46 »
To duplicate just open phpmyadmin and go to a database table with more than 1 row. Click on a column header to sort values by that column. You will receive the Kloxo 403 error "Kloxo-MR: error 403 found!"

These are the things I have ruled out already.
File permissions and ownership OK.
Code: [Select]
-rw-r--r--  1 lxlabs lxlabs  59844 Dec  5 01:44 sql.phpTried adjusting haiwatha url length up with no success.
Code: [Select]
MaxUrlLength = 655360Tried adjusting php.ini per hiawatha's recommended settings.
Code: [Select]
cgi.fix_pathinfo = 0
cgi.rfc2616_headers = 1

After switching Kloxo-MR to use nginx it works fine. So it's not php settings or phpMyAdmin issue, but rather something in Hiawatha. Hoping you can help.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: phpMyAdmin table sorting giving 403 error
« Reply #1 on: 2014-01-19, 09:44:18 »
PHPMyAdmin in Kloxo-MR using hiawatha but PHPMyAdmin in cp.domain.com using certain webserver depend on what's we choose in 'Switch program'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: phpMyAdmin table sorting giving 403 error
« Reply #2 on: 2014-01-19, 09:50:09 »
Hiawatha for Kloxo-MR only use 1 config file (see /usr/local/lxlabs/kloxo/init/hiawatha.conf
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline quacos

  • Junior Member
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: phpMyAdmin table sorting giving 403 error
« Reply #3 on: 2014-07-23, 17:48:07 »
I had to disable SecureURL into /usr/local/lxlabs/kloxo/init/hiawatha.conf

Code: [Select]
SecureURL = no
Also a chattr +i is needed before restart because Kloxo MR keeps overwriting that file.

Code: [Select]
chattr +i /usr/local/lxlabs/kloxo/init/hiawatha.conf
service kloxo restart

Offline KloxoLittleFish

  • Valuable Member
  • *
  • Posts: 147
  • Karma: +0/-0
    • View Profile
Re: phpMyAdmin table sorting giving 403 error
« Reply #4 on: 2014-08-05, 17:37:29 »
solve it please  :)

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: phpMyAdmin table sorting giving 403 error
« Reply #5 on: 2014-08-05, 23:41:47 »
Modified hiawatha.conf.base instead hiawatha.conf
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,050
  • Karma: +1/-0
    • View Profile
Re: phpMyAdmin table sorting giving 403 error
« Reply #6 on: 2014-09-05, 19:24:47 »
This error is back again !!!

Offline jforsgren

  • Junior Member
  • *
  • Posts: 15
  • Karma: +0/-0
    • View Profile
Re: phpMyAdmin table sorting giving 403 error
« Reply #7 on: 2014-09-10, 00:20:03 »
I am having the same sort error using apache with phpamyadmin, any ideas on how to fix this?

"Error in Processing Request
Error code: 403
Error text: Forbidden"
« Last Edit: 2014-09-10, 00:21:53 by jforsgren »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: phpMyAdmin table sorting giving 403 error
« Reply #8 on: 2014-09-10, 01:33:41 »
Report to phpmyadmin.net
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,050
  • Karma: +1/-0
    • View Profile
Re: phpMyAdmin table sorting giving 403 error
« Reply #9 on: 2014-09-10, 21:03:46 »
I had to readd SecureURL = no to hiawatha.conf

Offline hiteshpatel007

  • Junior Member
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: i found solution for this error
« Reply #10 on: 2017-07-09, 17:35:06 »
Open Kloxo Control panel > Servers > Localhost > File Manager > Usr > Local > Lxlabs > Kloxo > Httpdocs >  Thirdparty > PhpMyAdmin > Libraries > DisplayResults.class.php

open "DisplayResults.class.php" file in edit mode

find line in file (line number is 2189)

Quote
$draggable_html .= '" data-column="' . htmlspecialchars($fields_meta->name)
            . '">' . $order_link . $comments . '</th>';

and Replace with below line.

Quote
$draggable_html .= '" data-column="' . htmlspecialchars($fields_meta->name)
            . '">' . str_replace("%0A","+",$order_link) . $comments . '</th>';

now Save and login and check in PhpMyAdmin ..... ERROR Gone....


 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.03 seconds with 18 queries.

web stats analysis