Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-25, 16:16:22

Author Topic: php dont apply changes until press f5 or refresh  (Read 325 times)

0 Members and 1 Guest are viewing this topic.

Offline bloomberg

  • Junior Member
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
php dont apply changes until press f5 or refresh
« on: 2017-04-15, 10:44:52 »
hi
my PHP Type is : mpd_php_ruid 2
php version is : php54
my problem is that changes in output of php file don't apply until press refresh or f5.
i mean when i am closing tab and reopen the website and cant see the changes but when i press the refresh button . output changes with new data.
it is something like cache or cache itself i don't know.
can anyone helps me with this issue
thanks.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,479
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: php dont apply changes until press f5 or refresh
« Reply #1 on: 2017-04-15, 11:25:17 »
Inform here 'sh /script/sysinfo'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline bloomberg

  • Junior Member
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: php dont apply changes until press f5 or refresh
« Reply #2 on: 2017-04-15, 11:36:20 »
Thanks for your reply
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017041002
   - Web: hiawatha-10.5.0-f.2.mr.el6.x86_64
   - PHP: php56s-5.6.30-2.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname: ....
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php54-cli-5.4.45-1.ius.centos6.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.5.0-f.2.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.11.13-1.el6.ngx.x86_64
     - Apache: httpd-2.2.31-1.mr.el6.x86_64
       - PHP Type: mod_php_ruid2
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.14-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: --uninstalled--
D. Memory:
             total       used       free     shared    buffers     cached
Mem:           996        919         76          0        102        290

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,479
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: php dont apply changes until press f5 or refresh
« Reply #3 on: 2017-04-15, 11:52:40 »
Try change value to '-1' for 'Static Files Expire (in days; -1 to disabled; 0 to reset)' in 'admin > all > all domains > web features'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline bloomberg

  • Junior Member
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: php dont apply changes until press f5 or refresh
« Reply #4 on: 2017-04-15, 12:05:03 »
Thanks it worked for me

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,888
  • Karma: +1/-0
    • View Profile
Re: php dont apply changes until press f5 or refresh
« Reply #5 on: 2017-04-16, 21:11:00 »
It should be set as default!

Offline fossxplorer

  • Master
  • **
  • Posts: 601
  • Karma: +0/-0
    • View Profile
Re: php dont apply changes until press f5 or refresh
« Reply #6 on: 2017-04-16, 21:33:10 »
Try change value to '-1' for 'Static Files Expire (in days; -1 to disabled; 0 to reset)' in 'admin > all > all domains > web features'

which files change when we set files expire to -1?
This has caused incorrect behaviour of web sites delivering JS files through PHP.

Setting to -1 works again with Nginx reverse proxy.
Kloxo-MR!

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.046 seconds with 18 queries.

web stats analysis