Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-05-26, 22:20:07

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tega

Pages: 1 2 3 [4]
46
Kloxo-MR Technical Helps / Issues with FTP
« on: 2015-09-30, 02:34:17 »
Hello, I'm having issues adding new FTP users, I've found a post from someone with a similar issue, tried everything suggested there with no luck.

When I add a ftp user to a client on kloxo I can't access it, so stuff I tried:

sh /script/upcp
sh /script/cleanup
sh /script/fixftp-all
restart everything multiple times between each command. no luck

Is happening only for new users,  (let's use "dummy" as example I added the ftp user "dummy" on the client "dummy"

when I do sh /script/fixftpuser --client=dummy

I get
Code: [Select]
Fixing FTP User
- 'dummy' ('dummy') at 'localhost'
- 'dummy.com' ('dummy') at 'localhost'
Unable to open the passwd file: No such file or directory

I noticed that after running that command the files pureftpd.passwd and pureftpd.pdb disappear in /etc/pure-ftpd

If I delete the client and do the "fix scripts" everything goes back to normal. So this is only happening on the new clients.

Also I did a little digging and found this on /usr/local/lxlabs/kloxo/log/shell_exec

Code: [Select]
01:28 Sep/30/2015: 32: You must give (non-root) uid and gid [(__system__) 'pure-pw'  'useradd' 'dummy' '-u' '-d' '/home/dummy/www' '-z' '0000-2359']
01:28 Sep/30/2015: 32: You must give (non-root) uid and gid [(__system__) 'pure-pw'  'useradd' 'dummy.com' '-u' '-d' '/home/dummy/www' '-z' '0000-2359']


My /script/sysinfo:
Code: [Select]
A. Kloxo-MR: 7.0.0.b-2015092401
   - Web: hiawatha-9.14.0-f.6.mr.el6.i386
   - PHP: php54s-5.4.44-1.w6 (cgi mode)
B. Plateform:
   - OS: CentOS release 6.7 (Final) i686
   - Hostname: mydomain.com
C. Services:
   1. MySQL: MariaDB-server-10.0.21-1.el6.i686
   2. PHP:
      - Branch: php54-cli-5.4.45-1.ius.el6.i686
      - Multiple:
        * php52m-5.2.17-102.mr.el6
        * php53m-5.3.29-1.ius.el6
        * php54m-5.4.44-1.w6
        * php55m-5.5.28-1.ius.el6
        * php56m-5.6.12-1.ius.el6
      - Used: --Use PHP Branch--
   3. Httpd: httpd24u-2.4.16-2.ius.el6.i686
      - PHP Type: php-fpm_event
   4. Lighttpd: --uninstalled--
   5. Hiawatha: --unused--
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: qmail-toaster-1.03-1.3.55.mr.el6.i386
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.i386
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:           512        340         171         11          0        205
   -/+ buffers/cache:        235        276
   Swap:          512         20        491
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs      100G   18G   83G  18% /
Any idea how to fix this?

EDIT: I continued to investigate the issues with kloxo and found Also another thing (noticed a few times when I was repairing (sh /script/cleanup)) I saw that php-fpm were throwing a few errors and I noticed that when I add a new client there's no <client>.conf on /etc/php-fpm.d/

Code: [Select]
Stopping php-fpm:                                          [FAILED]
Starting php-fpm: [30-Sep-2015 02:08:15] ERROR: [pool dummy] cannot get uid for user 'dummy'
[30-Sep-2015 02:08:15] ERROR: FPM initialization failed
                                                           [FAILED]


Also e-mail accounts doesn't work too for the new users. So what it looks is that kloxo-mr when adding new clients and perform the stuff it needs too, are not working properly, unfortunately as I stated doing the /script/upcp and /script/cleanup are not fixing the issues :(

47
Kloxo-MR Technical Helps / Re: Issues with PHP
« on: 2015-09-01, 08:46:39 »
So disabled repo, did "sh /script/phpm-all-install --force" and all good this time, no errors and looks like the error on php-error.log I reported is gone too.

But as for changing the php branch, when I try to change it from php 5.4 to 5.6 It stays on 5.4 and I checked the php-error.log and this is what happens:

Code: [Select]
[01-Sep-2015 07:51:03 Europe/London] PHP Fatal error:  Call to a member function getThrow() on a non-object in /usr/local/lxlabs/kloxo/httpdocs/lib/html/lib.php on line 5527
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'bz2' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'calendar' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'ctype' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'exif' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'ftp' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'gettext' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'gmp' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'iconv' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'shmop' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'SimpleXML' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'sockets' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'tokenizer' already loaded in Unknown on line 0
[01-Sep-2015 07:51:04 Europe/London] PHP Warning:  Module 'xml' already loaded in Unknown on line 0

48
Kloxo-MR Technical Helps / Issues with PHP
« on: 2015-09-01, 04:58:17 »
Hello, so my php-error.log is full of these errors (literally they happen every minute, the file is already 7MB long):

Code: [Select]
[01-Sep-2015 03:56:43 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54s/usr/lib/php/modules/memcached.so' - libmemcached.so.11: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54s/usr/lib/php/modules/gearman.so' - libgearman.so.8: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54m/usr/lib/php/modules/gearman.so' - libgearman.so.8: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54s/usr/lib/php/modules/memcached.so' - libmemcached.so.11: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54m/usr/lib/php/modules/memcached.so' - libmemcached.so.11: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54s/usr/lib/php/modules/gearman.so' - libgearman.so.8: cannot open shared object file: No such file or directory in Unknown on line 0
[01-Sep-2015 03:57:05 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/php54s/usr/lib/php/modules/memcached.so' - libmemcached.so.11: cannot open shared object file: No such file or directory in Unknown on line 0

This is my sysinfo:
Code: [Select]
A. Kloxo-MR: 7.0.0.b-2015083001
   - Web: hiawatha-9.14.0-f.6.mr.el6.i386
   - PHP: php54s-5.4.44-1.w6 (cgi mode)
B. Plateform:
   - OS: CentOS release 6.7 (Final) i686
   - Hostname: darkside.server1
C. Services:
   1. MySQL: MariaDB-server-10.0.21-1.el6.i686
   2. PHP:
      - Branch: php54-cli-5.4.44-1.ius.el6.i686
      - Multiple:
        * php52m-5.2.17-102.mr.el6
        * php53m-5.3.29-1.ius.el6
        * php54m-5.4.44-1.w6
        * php55m-5.5.28-1.ius.el6
        * php56m-5.6.12-1.ius.el6
      - Used: php54m
   3. Httpd: httpd24u-2.4.16-2.ius.el6.i686
      - PHP Type: php-fpm_event
   4. Lighttpd: --uninstalled--
   5. Hiawatha: --unused--
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: qmail-toaster-1.03-1.3.55.mr.el6.i386
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.i386
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:           512        480         31          6          0        317
   -/+ buffers/cache:        162        349
   Swap:          512        188        323
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs      100G   43G   58G  43% /

So I went on the webserver config and I try to change the php-branch to php5.6 hoping that may help to fix the problem, but I choose php56 and then after update, it gets a message: "Information:
php_branch successfully updated for pserver-localhost"

But nothing happens it stays on php54. It's ok I can stay with php54, just would like to change it if I need in the future.

Anyway back to the php errors, so I went "full commando" and did "sh /script/phpm-all-install" and I noticed this when was installing the versions 5.4, 5.5 and 5.6:

Code: [Select]
Transaction Check Error:
  file /usr/lib/libhashkit.so.2.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.i686 and libmemcached10-1.0.16-1.ius.el6.i686
  file /usr/lib/libmemcached.so.11.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.i686 and libmemcached10-1.0.16-1.ius.el6.i686
  file /usr/lib/libmemcachedutil.so.2.0.0 conflicts between attempted installs of libmemcached-last-libs-1.0.18-2.el6.remi.i686 and libmemcached10-1.0.16-1.ius.el6.i686

So I guess those php extensions are not working correctly because they are conflicting with anything else, how can I fix that?

Thanks in advance

49
Ok thanks.

And just a quick bug report, when you assign httpd when I choose apache, there's a bug on the daemon (2.2 or 2.4 have the same issue).
I discovered when doing: service httpd restart or stop it always shown as "failed" (since sh /script/restart-web uses the same command).

So basically on the file /etc/init.d/httpd where it shows the pid file it has this on the line 45:
Code: [Select]
pidfile=${PIDFILE-/var/run/httpd.pid}
But it should be:
Code: [Select]
pidfile=${PIDFILE-/var/run/httpd/httpd.pid}
I know is not a kloxo-mr issue, but you should make a script to fix that or changing service httpd restart to apachectl restart on the /script/restart-web

50
The thing is on /opt/config/apache/conf/mydomain.conf kloxo-mr keeps assigning the IP address to the virtual hosts
Code: [Select]
Define ipalloc xxx.xxx.xxx.xxx
And the only way I have to make everything working correctly is assigning the wildcard,
Code: [Select]
Define ipalloc *
With that is working perfectly all over the server, but everytime I do sh /script/fixweb or add a new domain to kloxo-mr it reverts to Define ipalloc xxx.xxx.xxx.xxx on the conf file.

I left it working perfectly yesterday and today when I woke up, every domain on kloxo-mr was again redirecting to the same domain

51
That's what I have. tried to replace * for the IP but same thing. No idea why is every domain that I added on kloxo automatically redirecting from http:// to https://

Code: [Select]
<IfVersion < 2.4>
Define global::port 80
Define global::portssl 443
Define global::ip *

Define port ${global::port}
Define portssl ${global::portssl}
Define ip ${global::ip}
</IfVersion>

52
I did a new fresh installation of kloxo-mr yesterday on the new server, is pretty much all default.

I need to use apache 2.4, but I can try other webservers.

I just noticed is not only on subdomains, it's ALL the domains I have added on kloxo-mr, even the ones in different clients that are redirecting from http:// to https://

I went on /opt/configs/apache/conf/domains and in every domain I have this (that use the port 80):

Code: [Select]
<VirtualHost ${ip}:${port} >

SetEnvIf X-Forwarded-Proto https HTTPS=1

is this the thing that is causing the redirect from the port 80 to 443? I've not changed any of the files, I'm an enthusiast not a sysadmin, so I apologize if I said something stupid.

53
Here it goes:

Code: [Select]
A. Kloxo-MR: 7.0.0.b-2015081601
   - Web: hiawatha-9.14.0-f.6.mr.el6.i386
   - PHP: php54s-5.4.44-1.w6 (cgi mode)
B. Plateform:
   - OS: CentOS release 6.7 (Final) i686
   - Hostname: domain.com
C. Services:
   1. MySQL: MariaDB-server-10.0.21-1.el6.i686
   2. PHP:
      - Branch: php54-cli-5.4.44-1.ius.el6.i686
      - Used: --Use PHP Branch--
   3. Httpd: httpd24u-2.4.16-2.ius.el6.i686
      - PHP Type: php-fpm_event
   4. Lighttpd: --uninstalled--
   5. Hiawatha: --unused--
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: qmail-toaster-1.03-1.3.55.mr.el6.i386
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.i386
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:           2048        470        1577          6          0        180
   -/+ buffers/cache:        248        1799
   Swap:          1024          0        1024
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs      100G   42G   59G  42% /

54
Hello,

I'm having an issue and I have no idea how to fix it let's call the domain: mydomain.com

So basically I have a SSL cert for mydomain.com and is NOT a wildcard cert so I just want to use it on mydomain.com and not on subdomain.domain.com. I added the cert for my main domain on Domains -> mydomain.com -> ssl certificates. It works as it should. But then I added a few other subdomains.mydomain.com and when I try to open on my browser it automatically redirects from http://subdomain.mydomain.com to https://subdomain.mydomain.com

When I added the subdomains I disabled the option "enable ssl" so no idea why is redirecting http:// to https://

I also have the SSL cert on the kloxo-mr panel.

55
Kloxo-MR Bugs and Requests / Re: Error after a fresh install
« on: 2014-02-01, 19:07:00 »
Thanks, sorry I edited the post at the same you're replying with new issues, not sure if I need to create a new post. I couldn't find the answer for the username/password issue. admin as username and password doesn't work for me.

Thanks again for your fast reply and your dedication to this project.

56
Kloxo-MR Bugs and Requests / Error after a fresh install
« on: 2014-02-01, 18:18:41 »
Hello,

I strickly followed the instructions provided in https://github.com/mustafaramadhan/kloxo/blob/dev/how-to-install.txt. (Installed the final release the B.2 in the .txt file) and in the end when I perform sh /script/restart-all I get this error:

Code: [Select]
[root@tegarte /]# sh /script/restart-all
Already stopped.
Starting qmail-toaster: svscan.
Stopping xinetd:                                           [  OK  ]
Starting xinetd:                                           [  OK  ]
Stopping kloxo-phpcgi:                                     [  OK  ]
Starting kloxo-phpcgi:                                     [  OK  ]
Stopping kloxo-hiawatha:                                   [FAILED]
Starting kloxo-hiawatha: Error loading RSA private key (-0x2E00): PK - Read/write of file failed
                                                           [FAILED]
[root@tegarte /]#

This is my info that I took by doing /script/sysinfo

Code: [Select]
[root@tegarte /]# sh /script/sysinfo

A. Kloxo-MR: 6.5.0.f-2014013101

B. OS: CentOS release 6.5 (Final) i686

C. Apps:
   1. MySQL: mysql-5.5.34-1.el6.i686
   2. PHP: php53u-5.3.28-1.ius.el6.i686
   3. Httpd: httpd-2.2.26-1.el6.i686
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.35.mr.el6.i386
      - with: courier-imap-toaster-4.1.2-1.3.14.mr.el6.i686
   7. Dns: bind-9.9.5-1.el6.i686

D. Php-type (for Httpd/proxy):

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          3072       1522       1549          0          0       1321
   -/+ buffers/cache:        200       2871
   Swap:            0          0          0

[root@tegarte /]#

EDIT: After doing a /script/update is fixed, it still gives an error with php-fpm but looks like is working

Starting php-fpm: [01-Feb-2014 20:29:07] NOTICE: PHP message: PHP Deprecated:  Comments starting with '#' are deprecated in Unknown on line 1 in Unknown on line 0
                                                           [  OK  ]
*** Restart services - END ***


But now I have another issue, does the username and password shouldn't be "admin" ? always get a "login unsuccessful" message.

This is a completely fresh install, I just installed Centos 6 32bit in a openvz environment

Pages: 1 2 3 [4]

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.042 seconds with 16 queries.

web stats analysis