Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-07-15, 10:07:26

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kloxo-fan

Pages: 1 [2] 3
16
Kloxo-MR Technical Helps / Auto update
« on: 2014-10-17, 12:15:30 »
Hello,
every 2-3 days in my ssh client manually run command "yum clean all; yum update -y; sh /script/cleanup"
but i want to ask is it possible to make a option for auto execution of this command?
In Kloxo-MR I see Cron Task but I'm not sure if it works or not if you put this command cuz it's required root permission and cron in kloxo runs as admin.

17
Kloxo-MR Bugs and Requests / Re: bind update
« on: 2014-09-07, 19:45:43 »
I'm still got 404 error, what to do?
CentOS-6 64bit.

yum clean all; yum update
Code: [Select]
Total download size: 13 M
Is this ok [y/N]: y
Downloading Packages:
(1/10): avahi-libs-0.6.25-12.el6_5.3.x86_64.rpm                                                                                                                                                                                                        |  55 kB     00:00
https://github.com/mustafaramadhan/kloxo/raw/rpms/release/centos6/x86_64/bind-9.9.5-1.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
https://github.com/mustafaramadhan/kloxo/raw/rpms/release/centos6/x86_64/bind-libs-9.9.5-1.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
https://github.com/mustafaramadhan/kloxo/raw/rpms/release/centos6/x86_64/bind-utils-9.9.5-1.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
(5/10): cpio-2.10-12.el6_5.x86_64.rpm                                                                                                                                                                                                                  | 192 kB     00:00
(6/10): hiawatha-9.7.p1-1.mr.el6.x86_64.rpm                                                                                                                                                                                                            | 210 kB     00:00
(7/10): initscripts-9.03.40-2.el6.centos.4.x86_64.rpm                                                                                                                                                                                                  | 941 kB     00:00
(8/10): kloxomr7-7.0.0.b-2014090503.mr.noarch.rpm                                                                                                                                                                                                      | 6.3 MB     00:00
(9/10): mod_define-2.2-3.mr.el6.x86_64.rpm                                                                                                                                                                                                             |  22 kB     00:00
(10/10): polarssl-1.3.8-1.mr.el6.x86_64.rpm                                                                                                                                                                                                            | 820 kB     00:00
Error Downloading Packages:
  40:bind-9.9.5-1.el6.x86_64: failure: bind-9.9.5-1.el6.x86_64.rpm from mratwork-release-version-arch: [Errno 256] No more mirrors to try.
  40:bind-libs-9.9.5-1.el6.x86_64: failure: bind-libs-9.9.5-1.el6.x86_64.rpm from mratwork-release-version-arch: [Errno 256] No more mirrors to try.
  40:bind-utils-9.9.5-1.el6.x86_64: failure: bind-utils-9.9.5-1.el6.x86_64.rpm from mratwork-release-version-arch: [Errno 256] No more mirrors to try.

18
Hi,
after update to 7.0.0.b-2014082301 I can't start apache web server.
I got the error:

sh /script/restart-web
Stopping lighttpd:                                         [FAILED]
Starting lighttpd: /bin/bash: /usr/sbin/lighttpd: No such file or directory
                                                           [FAILED]
Stopping httpd:                                            [FAILED]
Starting httpd: /bin/bash: /usr/sbin/httpd.event: No such file or directory
                                                           [FAILED]
Stopping php55m-fpm:                                       [  OK  ]
Starting php55m-fpm:                                       [  OK  ]

See - No such file or directory ?!?
lighttpd ?!? What's going on with that kloxomr 7, I've never used lighttpd !!!

I have the same problem on the second vps, httpd again doesn't works.
But there does constantly Varnish and Squid works but I've never used any cache servers.

How to fix this.

Sry mr. Mustafa but  KloxoMR 7 is not good, only problems and bugs!!!

The third server php-fpm doesn't works, only suphp works, but this server is use 7.0.0.b-2014082104

19
Kloxo-MR Bugs and Requests / Re: php-fpm problem
« on: 2014-06-20, 23:42:39 »
yes, after "sh /script/cleanup" I get this error.
change to php54m no problem, change to php55m or php55u and again I get this error.

20
Kloxo-MR Bugs and Requests / php-fpm problem
« on: 2014-06-19, 21:13:44 »
Hello, I used php55m but after today's update (6.5.1.b-2014061903) something strange began to happen on my server. When I use php55m or php55u server is overloaded ram memory used everything, every KB memory and all server blocks.
Via SSH client I get this:
Code: [Select]
*** glibc detected *** /opt/php55m/usr/sbin/php-fpm: free(): invalid pointer: 0x00007fe1678a0b00 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x76166)[0x7fe19c5d3166]
/opt/php55m/usr/sbin/php-fpm(php_module_shutdown+0x2a)[0x55449a]
/opt/php55m/usr/sbin/php-fpm[0x66efc9]
/opt/php55m/usr/sbin/php-fpm[0x6663b2]
/opt/php55m/usr/sbin/php-fpm[0x674e59]
/opt/php55m/usr/sbin/php-fpm[0x665773]
/opt/php55m/usr/sbin/php-fpm[0x66d1d0]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7fe19c57bd1d]
/opt/php55m/usr/sbin/php-fpm[0x420f79]
======= Memory map: ========
00400000-00723000 r-xp 00000000 09:03 52300073                           /opt/php55m/usr/sbin/php-fpm
00922000-009ad000 rw-p 00322000 09:03 52300073                           /opt/php55m/usr/sbin/php-fpm
009ad000-009c8000 rw-p 00000000 00:00 0
01d7a000-0221a000 rw-p 00000000 00:00 0                                  [heap]
7fe167733000-7fe16f733000 rw-s 00000000 90:04 109020147                   (deleted)/dev/zero
7fe16f733000-7fe16f73f000 r-xp 00000000 09:03 49941904                   /lib64/libnss_files-2.12.so
7fe16f73f000-7fe16f93f000 ---p 0000c000 09:03 49941904                   /lib64/libnss_files-2.12.so
7fe16f93f000-7fe16f940000 r--p 0000c000 09:03 49941904                   /lib64/libnss_files-2.12.so
7fe16f940000-7fe16f941000 rw-p 0000d000 09:03 49941904                   /lib64/libnss_files-2.12.so
7fe172d9f000-7fe172db5000 r-xp 00000000 09:03 49946250                   /lib64/libgcc_s-4.4.7-20120601.so.1
7fe172db5000-7fe172fb4000 ---p 00016000 09:03 49946250                   /lib64/libgcc_s-4.4.7-20120601.so.1
7fe172fb4000-7fe172fb5000 rw-p 00015000 09:03 49946250                   /lib64/libgcc_s-4.4.7-20120601.so.1
7fe172fb5000-7fe17309d000 r-xp 00000000 09:03 50070623                   /usr/lib64/libstdc++.so.6.0.13
7fe17309d000-7fe17329d000 ---p 000e8000 09:03 50070623                   /usr/lib64/libstdc++.so.6.0.13
7fe17329d000-7fe1732a4000 r--p 000e8000 09:03 50070623                   /usr/lib64/libstdc++.so.6.0.13
7fe1732a4000-7fe1732a6000 rw-p 000ef000 09:03 50070623                   /usr/lib64/libstdc++.so.6.0.13
7fe1732a6000-7fe1732bb000 rw-p 00000000 00:00 0
7fe19b661000-7fe19b67e000 r-xp 00000000 09:03 49944622                   /lib64/libselinux.so.1
7fe19b67e000-7fe19b87d000 ---p 0001d000 09:03 49944622                   /lib64/libselinux.so.1
7fe19b87d000-7fe19b87e000 r--p 0001c000 09:03 49944622                   /lib64/libselinux.so.1
7fe19b87e000-7fe19b87f000 rw-p 0001d000 09:03 49944622                   /lib64/libselinux.so.1
7fe19b87f000-7fe19b880000 rw-p 00000000 00:00 0
7fe19b880000-7fe19b882000 r-xp 00000000 09:03 49944676                   /lib64/libkeyutils.so.1.3
7fe19b882000-7fe19ba81000 ---p 00002000 09:03 49944676                   /lib64/libkeyutils.so.1.3
7fe19ba81000-7fe19ba82000 r--p 00001000 09:03 49944676                   /lib64/libkeyutils.so.1.3
7fe19ba82000-7fe19ba83000 rw-p 00002000 09:03 49944676                   /lib64/libkeyutils.so.1.3
7fe19ba83000-7fe19ba8d000 r-xp 00000000 09:03 49939091                   /lib64/libkrb5support.so.0.1
7fe19ba8d000-7fe19bc8c000 ---p 0000a000 09:03 49939091                   /lib64/libkrb5support.so.0.1
7fe19bc8c000-7fe19bc8d000 r--p 00009000 09:03 49939091                   /lib64/libkrb5support.so.0.1
7fe19bc8d000-7fe19bc8e000 rw-p 0000a000 09:03 49939091                   /lib64/libkrb5support.so.0.1
7fe19bc8e000-7fe19bcae000 r-xp 00000000 09:03 50072803                   /usr/lib64/liblzma.so.0.0.0
7fe19bcae000-7fe19beae000 ---p 00020000 09:03 50072803                   /usr/lib64/liblzma.so.0.0.0
7fe19beae000-7fe19beaf000 rw-p 00020000 09:03 50072803                   /usr/lib64/liblzma.so.0.0.0
7fe19beaf000-7fe19bec6000 r-xp 00000000 09:03 49941923                   /lib64/libpthread-2.12.so
7fe19bec6000-7fe19c0c6000 ---p 00017000 09:03 49941923                   /lib64/libpthread-2.12.so
7fe19c0c6000-7fe19c0c7000 r--p 00017000 09:03 49941923                   /lib64/libpthread-2.12.so
7fe19c0c7000-7fe19c0c8000 rw-p 00018000 09:03 49941923                   /lib64/libpthread-2.12.so
7fe19c0c8000-7fe19c0cc000 rw-p 00000000 00:00 0
7fe19c0cc000-7fe19c13d000 r-xp 00000000 09:03 49939153                   /lib64/libfreebl3.so
7fe19c13d000-7fe19c33c000 ---p 00071000 09:03 49939153                   /lib64/libfreebl3.so
7fe19c33c000-7fe19c33e000 r--p 00070000 09:03 49939153                   /lib64/libfreebl3.so
7fe19c33e000-7fe19c33f000 rw-p 00072000 09:03 49939153                   /lib64/libfreebl3.so
7fe19c33f000-7fe19c343000 rw-p 00000000 00:00 0
7fe19c343000-7fe19c359000 r-xp 00000000 09:03 49941925                   /lib64/libresolv-2.12.so
7fe19c359000-7fe19c559000 ---p 00016000 09:03 49941925                   /lib64/libresolv-2.12.so
7fe19c559000-7fe19c55a000 r--p 00016000 09:03 49941925                   /lib64/libresolv-2.12.so
7fe19c55a000-7fe19c55b000 rw-p 00017000 09:03 49941925                   /lib64/libresolv-2.12.so
7fe19c55b000-7fe19c55d000 rw-p 00000000 00:00 0
7fe19c55d000-7fe19c6e8000 r-xp 00000000 09:03 49941836                   /lib64/libc-2.12.so
7fe19c6e8000-7fe19c8e7000 ---p 0018b000 09:03 49941836                   /lib64/libc-2.12.so
7fe19c8e7000-7fe19c8eb000 r--p 0018a000 09:03 49941836                   /lib64/libc-2.12.so
7fe19c8eb000-7fe19c8ec000 rw-p 0018e000 09:03 49941836                   /lib64/libc-2.12.so
7fe19c8ec000-7fe19c8f1000 rw-p 00000000 00:00 0
7fe19c8f1000-7fe19caa6000 r-xp 00000000 09:03 50072708                   /usr/lib64/libcrypto.so.1.0.1e
7fe19caa6000-7fe19cca6000 ---p 001b5000 09:03 50072708                   /usr/lib64/libcrypto.so.1.0.1e
7fe19cca6000-7fe19ccc1000 r--p 001b5000 09:03 50072708                   /usr/lib64/libcrypto.so.1.0.1e
7fe19ccc1000-7fe19cccd000 rw-p 001d0000 09:03 50072708                   /usr/lib64/libcrypto.so.1.0.1e
7fe19cccd000-7fe19ccd1000 rw-p 00000000 00:00 0
7fe19ccd1000-7fe19cd32000 r-xp 00000000 09:03 50078008                   /usr/lib64/libssl.so.1.0.1e
7fe19cd32000-7fe19cf32000 ---p 00061000 09:03 50078008                   /usr/lib64/libssl.so.1.0.1e
7fe19cf32000-7fe19cf36000 r--p 00061000 09:03 50078008                   /usr/lib64/libssl.so.1.0.1e
7fe19cf36000-7fe19cf3d000 rw-p 00065000 09:03 50078008                   /usr/lib64/libssl.so.1.0.1e
7fe19cf3d000-7fe19cf40000 r-xp 00000000 09:03 49944605                   /lib64/libcom_err.so.2.1
7fe19cf40000-7fe19d13f000 ---p 00003000 09:03 49944605                   /lib64/libcom_err.so.2.1
7fe19d13f000-7fe19d140000 r--p 00002000 09:03 49944605                   /lib64/libcom_err.so.2.1/bin/bash: line 1: 18234 Aborted                 php55m-fpm --fpm-config /opt/php55m/custom/php-fpm.conf
Something in php-fpm is wrong.

21
Kloxo-MR Technical Helps / Problems after updates
« on: 2014-05-26, 13:39:35 »
I have a problems after updates 2014052103 and 2014052401.
When I type the command "sh /script/restart-web" for some reason kloxomr tries to run nginx, but I don't use nginx.
Code: [Select]
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
Stopping nginx:                                            [FAILED]
Starting nginx: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)
nginx: [emerg] bind() to 0.0.0.0:443 failed (98: Address already in use)
nginx: [emerg] still could not bind()
                                                           [FAILED]
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
Stopping php54m-fpm:                                       [  OK  ]
Starting php54m-fpm:                                       [  OK  ]

Web: Apache or sometimes Hiawathaproxy (but not Nginx)
PHP used: PHP54m
PHP Type: php-fpm_event

I saw that I got a weird result with "sh /script/sysinfo"

Code: [Select]
A. Kloxo-MR: 6.5.1.b-2014052401
B. OS: CentOS release 6.5 (Final) x86_64
C. Apps:
   1. MySQL: --uninstalled--
   2. PHP: --uninstalled--
   3. Httpd: --uninstalled--
   4. Lighttpd: --uninstalled--
   5. Hiawatha: hiawatha-9.5-2.mr.el6.x86_64
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: --uninstalled--
      - with: courier-imap-toaster-4.1.2-1.3.16.mr.el6.x86_64
D. Php-type (for Httpd/proxy): php-fpm_event
E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          2048       1051        996          0          0          0
   -/+ buffers/cache:       1051        996
   Swap:            0          0          0
:o

also after "yum clean all" and "yum update"

Code: [Select]
Loaded plugins: fastestmirror, priorities, protectbase, replace
Determining fastest mirrors
mratwork-epel/metalink                                                                                                                                                  |  12 kB     00:00
 * base: mirror.hmc.edu
 * extras: centos.mirror.freedomvoice.com
 * mratwork-epel: mirrors.solfo.com
 * mratwork-ius-stable: dl.iuscommunity.org
 * updates: mirrors.tummy.com
base                                                                                                                                                                    | 3.7 kB     00:00
base/primary_db                                                                                                                                                         | 4.4 MB     00:00
extras                                                                                                                                                                  | 3.4 kB     00:00
extras/primary_db                                                                                                                                                       |  19 kB     00:00
http://centos.alt.ru/repository/centos/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: mratwork-centalt. Please verify its path and try again
:o

22
Is it a good idea for an updat? Apache HTTP Server from 2.2 to latest 2.4?
Can you tell me how it updated httpd-2.2.27 to httpd-2.4.9 because I can not.
I looked at the documentation in apache website for manual install but I got error with command './configure'.
...
checking for APR... no
configure: error: APR not found.  Please read the documentation.

And that's all  ;D
Can not continue.

In fact, httpd-2.4.9 will be compatible with KloxoMR and all websites?
Why all the components in KloxoMR are latest version but Apache is not?
Is there a problem with httpd-2.4.9?

23
Bulgarian Users / Re: ????? ???? ?? ????
« on: 2014-05-08, 20:20:43 »
??? ??? ??????? ? ?????????;D ;D ;D ;D

24
Have you tried to update your php54s and php54m from 5.4.27 to 5.4.28 or php55s and php55m from 5.5.11 to 5.5.12?
Do you have problems like me?
I tried on 2 VPS with kloxomr
In both cases, after the update to 5.4.28 or 5.5.12 all sites get 500 error and kloxomr get 503 error.
With version php 5.4.27 and 5.5.11 have no problems, this is only with 5.4.28 and 5.5.12.

25
Try 'sh /script/cleanup'.
I tried, but it doesn't help.

As I said in the last post:
Quote
I think something in versions 5.4.28 and 5.5.12 is not compatible with kloxomr and causing bug in the panel.

when you type:
sh /script/fixlxphpexe php53s
sh /script/restart
Kloxomr is fixed.

"sh /script/fixlxphpexe php54s" causes bug

26
Did you run 'sh /script/cleanup' after update?.
Yes, but all versions of 5.4 and 5.5 stopped working.
Every time I got 500 error in websites.
with "sh /script/upcp -y" I fixed kloxomr.
But I don't know how to fix bugs with php54m/s and php55m/s.

Ok. I'll try this and tell you what happened
service kloxo stop
sh /script/php54s-installer
sh /script/fixlxphpexe php54s
sh /script/restart

-----

After this:
Code: [Select]
service kloxo stop
sh /script/php54s-installer
sh /script/fixlxphpexe php54s
sh /script/restart
KloxoMR again got "Kloxo-MR: error 503 found!"  :o
php54 and php55 still doesn't works

I think something in versions 5.4.28 and 5.5.12 is not compatible with kloxomr and causing bug in the panel.

27
Now become even worse.
After "sh /script/php54m-installer" and "sh /script/php55m-installer" all type of php 5.4 and 5.5 doesn't works.
Even php54m and 55m stopped working, all websites got 500 Internal Server Error.
KloxoMR also stopped working, everything became a mess.
Kloxo panel says: "Kloxo-MR: error 503 found!"
How to fix this bugs?

With "sh /script/switch-php-fpm php53m" sites works but only with php53
I want to use php54.

BTW how to fix KloxoMR? I reinstalled but again got error 503?!?
What to do?

---

"sh/script/upcp -y"
repair KloxoMR.

but all versions of 5.4 and 5.5 doesn't work.

28
Today through "yum update" I update php54 from 5.4.27 to 5.4.28 and 5.5.10 to 5.5.12 but then I only get "500 Internal Server Error".
I tried everything but I can not use 5.4.28

PHP Used: --Use PHP Branch--
PHP Branch: php54_(as_5.4.28) or php55_(as_5.5.12)

Every time 500 Internal Server Error

----------

PHP Used: php54m (but version 5.4.26) or php55m (version 5.5.10)

no problems

---------

How to fix 5.4.28 and 5.5.12?
In these versions has important fixes including security fixes.
19 bugs were fixed including CVE-2014-0185.

29
Go to Advanced -> Port Configure and write whatever ports you want.
Then you need to restart KloxoMR to be applied new ports.

I saw these two answers:

At this moment. Kloxo-MR only use port 7777/7778. Change to other port not work.
Still want change port?.

Open '/usr/local/lxlabs/kloxo/init/hiawatha.conf' and change 'Port = 7778' to 'Port = 17778' and 'Port = 17777' to 'Port = 17777'. Now you can access Kloxo-MR panel with 17778/17777 port.

30
Kloxo-MR Bugs and Requests / Re: php in Kloxo 6.5.1b
« on: 2014-04-25, 20:25:12 »
Web: nginxproxy

Multiple PHP Already Installed: php52m php53m php54m php55m

PHP Type: php-fpm_event

PHP Used: php53m

I have no problem  :)

But If I choose PHP Used: php54m or php55m then again I have a problem with user sessions.
For me is not a problem to use php 5.3.28 but I wanted to see if php 5.4 or 5.5 is better or not.  :)

Can you tell me how in php53m to install xcache.
I tried "yum install php53u-xcache" and "php -v" says:

PHP 5.3.28 (cli) (built: Mar  5 2014 17:33:49)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies
    with XCache v3.1.0, Copyright (c) 2005-2013, by mOo
    with XCache Optimizer v3.1.0, Copyright (c) 2005-2013, by mOo
    with XCache Cacher v3.1.0, Copyright (c) 2005-2013, by mOo
    with XCache Coverager v3.1.0, Copyright (c) 2005-2013, by mOo

But with "phpinfo();" I don't see any installed xcache packages.

Pages: 1 [2] 3

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.045 seconds with 17 queries.

web stats analysis