Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-25, 16:07:39

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - fossxplorer

Pages: [1] 2 3 ... 41
1
The following command returns nothing meaning you don't have  glue records set for ns1 and ns2 for your domain at your registrar (//registrar.1und1.de?)
[root@thinkpadx230 ~]# dig ns1.epixelar.org @8.8.8.8 +short A

Also, your Kloxo-MR server doesn't have any other service open other than SSH, at least publicly.



2
Kloxo-MR Development / Letsencrypt not working with slave
« on: 2017-05-12, 19:00:48 »
Trying to create en LE TLS cert for a client on the slave, it's not wokring since the master is putting the ACME verificaiton on the master instead of the slave in master's /var/run/letsencrypt/.well-known/acme-challenge/

Is it possible to fix this @mustafa?

3
Kloxo-MR Development / Re: Unable to change php version
« on: 2017-05-10, 19:26:49 »
Running sh /script/fixweb  --server=server2_IP --client=clientname
seems to work AFTER choosing "PHP selected" in "web features" by the client.

EDIT: the problem seems to be 'set $var_phpselected 'php56m';' is not set correctly when changing php version from web feature for the "Slave" and a reload of the Nginx after change of the config.




4
Kloxo-MR Development / Unable to change php version
« on: 2017-05-10, 18:40:31 »
I'm changing subdomains => web features => "PHP Selected" from php70 to PHP56m, but nothing happens.
I'm doing this from "master" and the client is on server2 controlled by "master".

How can i force it to php56m on server2 for that client? Is it possible to use different php versions for different sub domains too?
Also, server2 ONLY runs Nginx (NOT reverse proxy). Could that be the problem?

5
My guess is: i don't think you can do it directly. You have to follow XML syntax so you will probably need XML parser at some point to extract <? phpinfo();?> and then run it?

is it possible to put PHP code inside a XML document to be later executed? For example, can I say "<? phpinfo();?> in .xml

6
Kloxo-MR Technical Helps / Re: Ipv6
« on: 2017-05-09, 20:41:01 »
Can you please pastebin the output of the command 'ifconfig' of your server?


Thnx.
But in
 ?
 admin —
 IP Addresses —
 {IP Address}


i see only the ip4. Why?

7
Kloxo-MR Technical Helps / Re: PHP scripts, error 500
« on: 2017-05-09, 09:47:07 »
 @scristi, is the domain changing with new Kloxo-MR server? Are you using exactly same database password etc?  If so did you change the config files of opencart accordingly?   

Check the logs of that domain in Kloxo-MR, it inside /home/httpd/domain.com/stats/ to get a clue.

EDIT: ok  i found some doc! Take a look at http://docs.opencart.com/administration/moving-server/ and pay attention to the following:
 Edit config.php and admin/config.php. These files contain the filesystem paths to OpenCart folders, URLs to OpenCart frontend and admin, and database access details. The paths and database details will most likely need to be updated, and the URLs will need to be changed only if the OpenCart store's domain has changed.


BTW, it's really great to see another c-panel user migrating to Kloxo-MR. AWESOME!
If you have any another questions, let us know!

8
Yeah, a master Kloxo-MR server with master DNS zones should not have "secondary DNS" right?
Anyway i'm very much interested to help you test/support/discuss to get this supported :)

I will try change 'secondary dns' based on server (it's make possible change target server).

9
Ok found the issue:
[root@mail configs]# tail -f /var/installatron/logs/error_log
#5 /usr/local/installatron/lib/boot.php(29848): itron::init()
#6 {main}
2017-05-07T13:21:58+02:00 Linux PHP 5.6.30 /usr/local/installatron/lib/boot.php(21770): Warning: fileowner(): stat failed for /home/client11

Since client11 now has web server in server2, it's not possible to use Installatron anymore.
There is no link between Kloxo-MR servers seen from Installatron...

Installatron has discontiued the support for Kloxo  :-[

We need to contact Installatron devs to convince them to add support for Kloxo-MR. They might not be aware of Kloxo-MR is actively developed!







10
Kloxo-MR Technical Helps / Installatron no session exists.
« on: 2017-05-07, 13:12:13 »
After deleting and re-adding the client11, i get the following error from Installatron:

Error: No session exists. Please re-start your session. Technical error: Unable to create session for `client11'.

It used to work fine before! Any idea why it complains about session and where it's storing session files?
Maybe it's the php70m causing problem?

EDIT: Instasllatron uses /usr/local/installatron/bin/php which is PHP 5.6.30. So it should work..

11
Ok. Now i went back to using server2 as DNS master with rsync of zone files from server1.
It works ok for now.




I am not testing 'secondary dns' on master-slave but master-master. I am not sure what's happen for master-slave for 'secondary dns'.

12
@mustafa, now i also tried to use the "DNS Servers" Under Servers for a client, by adding localhost and server2 (IP addr) as the DNS servers.
In the DNS template in server1, i have A record for ns1 and  server1 IP and another A record for  ns2  and server2 IP.

When i create a client using this setup, Kloxo-MR is behaving totally strange when it comes to handling DNS servers. First, when a domain in creating under this client, it's DNS record is only created in server2.  Then when i create a subdomain, it gets added to server1 and server2. So now, server1 ONLY has DNS records for this sub domain, while server2 has for both main domain and subdomain! Very strange.
I want to have all on both servers.

And when i delete the domain, the DNS records in server2 is NOT DELETED, only in server1. What a TOTAL MESS this is.

Do you have any plans to fix this @mustafa, please? DNS is so critical when dealing with a control panel IMO.

I'm willing to contribute and donate to solving this issue and to create a fully working DNS master -master or master-slave setup.










13
I see. But when you have 2 servers, say server1 (main Kloxo-MR server and DNS master) and server2 (Kloxo-MR server, but added to server1 in "Servers"), all clients are created ONLY at server1, but we can choose to have web, MySQL, mail and DNS at server2. 
Now i add a client in server1 with web, MySQL and mail choosen at server2, but DNS will be local (server1).
When clients are added this way, they are NOT visible under clients in server2.
So i wonder how we can deal with "Secondary DNS" for this client in server2?




 

 




'Secondary DNS' available for all client. So, if we want domain in master also have 'secondary dns', select one of client where in slave server and click 'secondary dns'.

14
Based on the log, it's obvious that there is a mismatch between PHP and the modules it's trying to load.
I'm not familar with Kloxo-MR 6.5 at all, but what does lxphp -v now show you? And how did you install php52?




PHP52s now turns but I get white screen in panel. Please look php52 error log.

15
Have you got "secondary dns" to work as slave DNS server with Kloxo-MR?

Pages: [1] 2 3 ... 41

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine

Page created in 0.041 seconds with 18 queries.

web stats analysis