Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2021-10-20, 15:23:36

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - djscooby

Pages: [1] 2 3 ... 8
1
Hi MR

I know that, i mean to add more times per client..

For example if you have 50 clients and want to backup all at night hours to avoid loading the server when server is already busy then  you need to put 8 clients at 01:00 another 8 at 02:00 etc etc..

But if you add more time choices there for example 01:15 - 01:30 - 01:45 you wont load the server the same as if you have  simultaneously 8 clients at once.

Thats what i meant.

Also its not a bad idea to setup more choices regarding the scheme.. Now its is : daily-weekly-monthly.
You can add for example every 2 days - every 5 days etc etc.

These are just suggestions of course.

2
Hi MR

Is it possible to setup more selections for backup time ?
For example put 01:00 - 01:30 etc ?

Its better to have more choices there in order not to do simultaneous backups if many clients on server.

Also can you fix inside the clients drop down list in backups page to show all clients there ?

Thanks

3
Kloxo-MR Bugs and Requests / fixdns errors
« on: 2017-04-02, 19:01:01 »
- Fix dns services
sh: line 0: cd: /home/djbdns/tinydns/root: No such file or directory
cat: master: No such file or directory
cat: slave: No such file or directory
cat: reverse: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
sh: line 0: cd: /home/djbdns/tinydns/root: No such file or directory
cat: master: No such file or directory
cat: slave: No such file or directory
cat: reverse: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
sh: line 0: cd: /home/djbdns/tinydns/root: No such file or directory
cat: master: No such file or directory
cat: slave: No such file or directory
cat: reverse: No such file or directory
make: *** No targets specified and no makefile found.  Stop.


i terminated the script because of high load on server...

any idea on how to fix this ?


happened after latest update ..


A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017040203
   - Web: hiawatha-10.5.0-f.2.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: xxx.sugaxxxxx.com
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php71u-cli-7.1.3-1.ius.centos6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.30-2.ius.centos6
          * php70m-7.0.17-1.ius.centos6
          * php71m-7.1.3-1.ius.centos6
      - Used: php71m-fpm
      - Multiple: enable
   3. Web Used: nginx
     - Hiawatha: hiawatha-10.5.0-f.2.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.11.12-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.25-3.ius.centos6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: nsd
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.14-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: --uninstalled--
   7. Stats: awstats
D. Memory:
             total       used       free     shared    buffers     cached
Mem:         20480      11798       8681        701          0      10934
-/+ buffers/cache:        863      19616
Swap:        21504        202      21301


4
Hi MR did u fix this?

5
Hi MR I don't mean that I mean files rotation don't work!  after backup it doesn't remove the previous files..

Let's say I set backup per client 1 everyday.  If you check after 3 days it will have 3 files instead of 1 file..

6
Kloxo-MR Bugs and Requests / Old backup files not removed
« on: 2016-08-26, 09:45:08 »
Hi Mr after the upgrade where you change the name of the backup starting with kloxomr70 the old backup files don't get removed.

For example I have set backup on a client to keep 1 only file and every 3 days I check he has 3 files..

This happens for all clients!  Even for a client that I have disabled backup for! 

Any idea fix?


7
Kloxo-MR Technical Helps / Re: wordpress 4.6
« on: 2016-08-20, 23:52:56 »
WordPress 4.6 is working fine with php 7.. Using it on over 20 wp sites with no problems so far.
The most problems you might get with php 7 is from plugins most of the time and not WordPress itself.

8
@MR @SPACEDUST
I already wrote that this nginx  Config is wrong..  see here: https://forum.mratwork.com/kloxo-mr-bugs-and-requests/nginx-configuration-problem/msg52574/ for correct settings for WordPress sites I tested..

9
Hi MR

After upgrade server to php7 roundcube dont work.. It neeeds newer version of roundcube 1.2 as they fix the problem ..

Installed Packages
kloxomr-webmail-roundcube.noarch      1.1.2-1.mr        @mratwork-release-neutral-noarch

10
Kloxo-MR Bugs and Requests / Nginx Configuration Problem
« on: 2016-07-25, 14:47:31 »
Hi MR after latest update i found a problem with nginx conf..

The problem is this line  : limit_req zone=req_limit_per_ip burst=25 nodelay;

on most wordpress sites with lot of external & internal sources it gives 503 error.. Changing this to :         limit_req zone=req_limit_per_ip burst=155 nodelay; it works fine..


System Info :

A. Control Panel:
   - Kloxo-MR: 7.0.0.b-2016072301
   - Web: hiawatha-10.3.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: server2.sugarweb.gr
C. Services:
   1. MySQL: MariaDB-server-10.0.26-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php70w-cli-7.0.8-1.w6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.37-1.ius.el6
          * php56m-5.6.23-1.ius.el6
          * php70m-7.0.8-1.w6
      - Used: php70m-fpm
      - Multiple: enable
   3. Web Used: nginx
     - Hiawatha: hiawatha-10.3.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.39-3.el6.x86_64
     - Nginx: nginx-1.11.2-1.el6.ngx.x86_64
     - Apache: httpd-2.2.31-1.mr.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: nsd
     - Bind: --uninstalled--
     - DJBDns: --uninstalled--
     - NSD: nsd-4.1.10-1.mr.el6.x86_64
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: package spamassassin is not installed

11
Kloxo-MR Bugs and Requests / Re: 502 error with nginx
« on: 2016-05-15, 12:38:48 »
MR i tried switch to everything.. then on every switch did cleanup and reboot
 server but still this is inside every domains conf : '/opt/configs/nginx/conf/globals/switch_standard_ssl.conf'

any other idea ?

Any file to look ???

12
Kloxo-MR Bugs and Requests / Re: 502 error with nginx
« on: 2016-05-14, 18:47:26 »
Hi MR i did it , also try after sh/script/fix-all but still same conf with include '/opt/configs/nginx/conf/globals/switch_standard_ssl.conf'; inside domains.



13
Kloxo-MR Bugs and Requests / 502 error with nginx
« on: 2016-05-14, 00:18:15 »
Hi MR

i had error 502  with HTTPS only with nginx and php55m on some only domains..
after investigate further , i found this:

Working with https Domain conf file :
Code: [Select]
## web for 'XXXXXX.COM'
server {
#disable_symlinks if_not_owner;

## MR -- 'enable-cgi' not implementing yet

include '/opt/configs/nginx/conf/globals/listen_ssl.conf';

include '/opt/configs/nginx/conf/globals/gzip.conf';

ssl on;
ssl_certificate /home/kloxo/ssl/venet0_0___localhost.pem;
ssl_certificate_key /home/kloxo/ssl/venet0_0___localhost.key;

include '/opt/configs/nginx/conf/globals/ssl_base.conf';

server_name XXXX.cOM www.XXXXX.COM;

include '/opt/configs/nginx/conf/globals/acme-challenge.conf';

index index.php index.html index.shtml index.htm index.pl index.py index.cgi index.rb default.htm Default.aspx Default.asp;

set $var_domain XXXX.COM;

set $var_rootdir '/home/XXX/XXXX.COM';

root $var_rootdir;

set $var_user 'XXX';
set $var_fpmport '57820';
set $var_phpselected 'php';

include '/opt/configs/nginx/conf/globals/stats.conf';

include '/opt/configs/nginx/conf/globals/dirprotect_stats.conf';

include '/opt/configs/nginx/conf/globals/XXXX.COM.conf';

set $var_kloxoportssl '7777';
set $var_kloxoportnonssl '7778';

include '/opt/configs/nginx/conf/globals/generic.conf';
}


A 502 error domain has this in conf file :

Code: [Select]
## web for 'YYYYY.COM'
server {
#disable_symlinks if_not_owner;

## MR -- 'enable-cgi' not implementing yet

include '/opt/configs/nginx/conf/globals/listen_ssl.conf';

include '/opt/configs/nginx/conf/globals/gzip.conf';

ssl on;
ssl_certificate /home/kloxo/ssl/venet0_0___localhost.pem;
ssl_certificate_key /home/kloxo/ssl/venet0_0___localhost.key;

include '/opt/configs/nginx/conf/globals/ssl_base.conf';

server_name YYYYYY.COM www.YYYY.COM

include '/opt/configs/nginx/conf/globals/acme-challenge.conf';

index index.php index.html index.shtml index.htm index.pl index.py index.cgi index.rb default.htm Default.aspx Default.asp;

set $var_domain YYYYY.COM;

set $var_rootdir '/home/YYY/YYYYY.COM';

root $var_rootdir;

set $var_user 'YYYYY';
set $var_fpmport '57816';
set $var_phpselected 'php';

include '/opt/configs/nginx/conf/globals/stats.conf';

include '/opt/configs/nginx/conf/globals/dirprotect_stats.conf';

include '/opt/configs/nginx/conf/globals/switch_standard_ssl.conf';

set $var_kloxoportssl '7777';
set $var_kloxoportnonssl '7778';

include '/opt/configs/nginx/conf/globals/generic.conf';
}

So only diference here was the line
Code: [Select]
include '/opt/configs/nginx/conf/globals/switch_standard_ssl.conf';


The file  switch_standard_ssl.conf content was :
Code: [Select]
    proxy_ignore_headers Expires Cache-Control;
    proxy_cache_bypass $cookie_session;
    proxy_no_cache $cookie_session;

    ## MR - increasing upload size to 64M (declare inside 'location /' not work
    client_max_body_size 64M;
    client_body_buffer_size 128k;

    proxy_connect_timeout 600s;
    proxy_send_timeout 300s;
    proxy_read_timeout 300s;


    #proxy_buffers 32 4k;
    proxy_buffers 8 128k;
    proxy_buffer_size 128k;

    proxy_request_buffering off;

    ### MR -- must be using nginx-special (including ngx_purge_cache)

    location ~ /purge(/.*) {
        ### MR -- just enough remove # below for enable
        #proxy_cache_purge pcache "$scheme://$host$1$request_method";
        allow 127.0.0.1;
        deny all;
    }










    #location ~* \.(php|pl|py|rb|cgi)$ {
    location / {
        ## MR -- move to ~lxcenter.conf
        #limit_conn addr 25;


        ## MR - no need try_files because permalink handle by apache
        #try_files $uri $uri/ /index.php;


        proxy_pass https://127.0.0.1:30443/;




        proxy_redirect off;



        proxy_set_header Host $host;
        proxy_set_header X-Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        #proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header X-Forwarded-SSL on;
        proxy_set_header X-Forwarded-Proto $scheme;
























        proxy_pass_header Set-Cookie;




        proxy_headers_hash_max_size 512;




        ### MR -- just enough remove # below for enable cache
        proxy_cache pcache;
        #proxy_cache_valid 10m;
        #proxy_cache_valid 404 1m;
        ## for microcache
        proxy_cache_valid 200 10s;
        proxy_cache_use_stale updating;
        proxy_max_temp_file_size 1M;



        proxy_cache_key "$scheme$request_method$host$request_uri";
        add_header X-Micro-Cache $upstream_cache_status;



        #proxy_cache_use_stale error timeout invalid_header http_500 http_502 http_504 http_404;


        open_file_cache max=1024 inactive=600s;
        open_file_cache_valid 2000s;
        open_file_cache_min_uses 1;
        open_file_cache_errors on;
    }


    ### MR -- Enable this if not using nginx cache and not for wordpress
#    location ~* ^.+\.(jpe?g|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js|swf|avi|mp3)$ {
#        expires 2d;
#        access_log off;
#        root $var_rootdir;
#    }


    location ~ /\.ht {
        deny all;
    }






    if (-f $request_filename) {
        break;
    }
 
    if (-d $request_filename) {
        break;
    }




I then copy file php-fpm_standard_ssl.conf inside switch_standard_ssl.conf and all works fine now...




Some extra info :

of course i run all the usual commands after upgrade and removed all custom-php53 conf files inside /opt/php-fpm/tpl and run sh /script/fix-all; fixweb etc etc...

 sh /script/sysinfo -y
A. Control Panel:
   - Kloxo-MR: 7.0.0.b-2016051305
   - Web: hiawatha-10.2.0-f.6.mr.el6.x86_64
   - PHP: php54s-5.4.40-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.7 (Final) x86_64
   - Hostname: server2.sugarweb.gr
C. Services:
   1. MySQL: MariaDB-server-10.0.25-1.el6.x86_64
   2. PHP:
      - Branch: php55u-cli-5.5.35-1.ius.el6.x86_64
      - Multiple:
        * php53m-5.3.29-1.ius.el6
        * php54m-5.4.40-1.ius.el6
        * php55m-5.5.24-1.ius.el6
        * php56m-5.6.8-1.ius.el6
      - Used: php55m
   3. Web Used: nginx
     - Hiawatha: --unused--
     - Lighttpd: --uninstalled--
     - Nginx: nginx-1.10.0-1.el6.ngx.x86_64
     - Httpd: --uninstalled--
       - PHP Type: php-fpm_event
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: nsd
     - Bind: --uninstalled--
     - DJBDns: --uninstalled--
     - NSD: nsd-4.1.9-1.mr.el6.x86_64
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
      - spam: spamassassin
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:         20480      10719       9760       1111          0       7849
   -/+ buffers/cache:       2869      17610
   Swap:         1024          0       1024
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/simfs       80G   37G   44G  46% /


So is there a bug ?? Was the file switch_standard_ssl.conf corect ????

14
and the other for php5.4 and up ?

thank very much for helping me..

15
MR you are right custom.php53 conf file caused the problem

I Removed all custom files and it worked.. now to create again custom php conf i copy : php53-fpm-pool.conf.tpl OR php-fpm.conf.tpf file ???

Pages: [1] 2 3 ... 8

Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.047 seconds with 17 queries.

web stats analysis