Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2022-09-30, 09:28:03

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Viking

Pages: [1] 2 3 ... 20
1
Unfortunately does not work that way. How to fix this error?
Code: [Select]
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libgd.so.2()(64bit) is needed by glibc-utils-2.12-1.132.el6_5.1.x86_64
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-utils-2.12-1.132.el6.x86_64 has missing requires of libgd.so.2()(64bit)
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2014-05-14-15-05j9SnLm.yumtx

2
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 18:40:54 »
And how do the conversion from MySQL to MariaDB?
Is that so?
Code: [Select]
sh /script/mariadb-to-mysql

3
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 18:01:15 »
OK. Thank you.
If you find any errors I will write it here.

4
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 17:41:22 »
If you choose mariadb from mariadb, run 'sh /script/mysql-to-mariadb' and you will see instruction if mariadb not ready.

OK
phpMyAdmin inaction. How to fix?
Code: [Select]
phpMyAdmin PHP 5.3+ is required

5
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 17:32:50 »
Kloxo-MR possible using 2 branch of mariadb. One from centalt and other from mariadb.

Mariadb from centalt automatically from mysql to mariadb with 'yum replace mysql55 --replace-with=mariadb'. For mariadb from mariadb, need running 'sh /script/mysql-to-mariadb'.

Before switch to mariadb, need modified mratwork.repo because by default set as disable.
OK. How do I modify it?

6
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 16:51:10 »
Need modified /etc/yum.repos.d/mratwork.repo to enable/disable MariaDB.

Horde already remove because last version of 2.x version have security issue but higher version hard to make to rpm format.

Code: [Select]
yum list mariadb*
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.ircam.fr
 * mratwork-ius: mirrors.ircam.fr
 * updates: mirror-pl.kielcetechnologypark.net
0 packages excluded due to repository protections
Error: No matching Packages to list

7
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 15:41:20 »
No issue like this in Kloxo-MR 6.5.1 because different approach for installing php52s/php53s.

After your php52s already fixed, no problem convert back your mysql55 to MariaDB with 'sh /script/mysql-to-mariadb'.

I am using the stable version of Kloxo-MR: 6.5.0.f-2014040701
Version 6.5.1 is a beta.

Code: [Select]
yum list mariadb*
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.coreix.net
 * mratwork-ius: mirrors.ircam.fr
 * updates: mirror-pl.kielcetechnologypark.net
0 packages excluded due to repository protections
Available Packages
MariaDB-cassandra-engine.i686                    10.0.10-1.el6                    mratwork-mariadb
MariaDB-client.i686                              10.0.10-1.el6                    mratwork-mariadb
MariaDB-common.i686                              10.0.10-1.el6                    mratwork-mariadb
MariaDB-compat.i686                              10.0.10-1.el6                    mratwork-mariadb
MariaDB-connect-engine.i686                      10.0.10-1.el6                    mratwork-mariadb
MariaDB-devel.i686                               10.0.10-1.el6                    mratwork-mariadb
MariaDB-oqgraph-engine.i686                      10.0.10-1.el6                    mratwork-mariadb
MariaDB-server.i686                              10.0.10-1.el6                    mratwork-mariadb
MariaDB-shared.i686                              10.0.10-1.el6                    mratwork-mariadb
MariaDB-test.i686                                10.0.10-1.el6                    mratwork-mariadb

And where is the x86_64?
Is webmail horde has been removed?

8
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 14:00:24 »
This problem is because using MariaDB. Install latest php52s with dependencies to mysql55 (after CentAlt repo remove their mysql 5.5 in Centos 6).

Compile php need dependencies to mysql because php-mysql module need it.

For MariaDB (from MariaDB repo), the problem is not 'emulate' mysql perfectly (mariadb from CentAlt able 'emulate' perfectly.

Try, 'yum install php52s --skip-broken'. Alternatively, run 'sh /script/upcp -y' ('-y' mean force reinstall Kloxo-MR) where Kloxo-MR try to re-install like 'fresh install' without touch data (like kloxo database).


Code: [Select]
yum install php52s --skip-broken
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.ircam.fr
 * mratwork-ius: mirrors.ircam.fr
 * updates: sunsite.icm.edu.pl
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php52s.x86_64 0:5.2.17-12.mr.el5 will be installed
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16.1)(64bit) for package: php52s-5.2.17-12.mr.el5.x86_64
--> Running transaction check
---> Package mysql55-libs.x86_64 0:5.5.36-1.ius.el6 will be installed
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5

Packages skipped because of dependency problems:
    mysql55-libs-5.5.36-1.ius.el6.x86_64 from mratwork-ius
    php52s-5.2.17-12.mr.el5.x86_64 from mratwork-release-version-arch

Code: [Select]
sh /script/upcp -y

sh /script/restart-all
Zatrzymywanie mysqld:                                      [  OK  ]
Uruchamianie mysqld:                                       [  OK  ]
Zatrzymywanie httpd:                                       [NIEUDANE]
Uruchamianie httpd: httpd: Syntax error on line 63 of /etc/httpd/conf/httpd.conf: Syntax error on line 3 of /etc/httpd/conf.d/rpaf.conf: Cannot load /etc/httpd/modules/mod_rpaf-2.0.so into server: /etc/httpd/modules/mod_rpaf-2.0.so: cannot open shared object file: No such file or directory
                                                           [NIEUDANE]
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
Zatrzymywanie n.inx:                                       [  OK  ]
Uruchamianie nginx:                                        [  OK  ]
Stopping qmail-toaster: svscan qmail logging.
Starting qmail-toaster: svscan.
Zatrzymywanie xinetd:                                      [  OK  ]
Uruchamianie xinetd:                                       [  OK  ]
Stopping kloxo-phpcgi:                                     [  OK  ]
Starting kloxo-phpcgi:                                     [  OK  ]
Stopping kloxo-hiawatha:                                   [  OK  ]
Starting kloxo-hiawatha:                                   [  OK  ]
Zatrzymywanie php-fpm:                                     [  OK  ]
Uruchamianie php-fpm:                                      [  OK  ]

Code: [Select]
sh /script/sysinfo

A. Kloxo-MR: 6.5.0.f-2014040701

B. OS: CentOS release 6.5 (Final) x86_64

C. Apps:
   1. MySQL: mysql55-5.5.36-1.ius.el6.x86_64
   2. PHP: php53u-5.3.28-2.ius.el6.x86_64
   3. Httpd: httpd-2.2.27-1.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: nginx-1.5.13-1.el6.x86_64
   6. Qmail: qmail-toaster-1.03-1.3.38.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.16.mr.el6.x86_64
   7. Dns: --uninstalled--

D. Php-type (for Httpd/proxy): mod_php_ruid2

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          2048        559       1488          0          0         43
   -/+ buffers/cache:        515       1532
   Swap:         2048          0       2048

Is it possible to change and use MariaDB?

9
Kloxo-MR Bugs and Requests / Re: Update Error
« on: 2014-04-14, 05:17:51 »
Try:
Code: [Select]
yum-complete-transaction
yum replace mysql --replace-with=mysql55
Code: [Select]
yum replace mysql --replace-with=mysql55
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.ircam.fr
 * mratwork-ius: mirrors.ircam.fr
 * updates: sunsite.icm.edu.pl
0 packages excluded due to repository protections
Replacing packages takes time, please be patient...
Error: Package 'mysql' is not installed.

I have installed:
Code: [Select]
mysql -V
mysql  Ver 15.1 Distrib 10.0.3-MariaDB, for Linux (x86_64) using readline 5.1

Now I have this error:
Code: [Select]
sh /script/sysinfo
/script/sysinfo: line 6: lxphp.exe: command not found

I have uninstalled php52s.
Code: [Select]
https://ip:7777/
Kloxo-MR: error 503 found!

Code: [Select]
sh /script/restart-all
Shutting down MySQL. SUCCESS!
Starting MySQL. SUCCESS!
Zatrzymywanie named: .                                     [  OK  ]
Uruchamianie named:                                        [  OK  ]
Zatrzymywanie httpd:                                       [  OK  ]
Uruchamianie httpd:                                        [  OK  ]
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
Zatrzymywanie n.inx:                                       [  OK  ]
Uruchamianie nginx:                                        [  OK  ]
Stopping qmail-toaster: svscan qmail logging.
qmail-send: nie zabito ?adnego procesu
Starting qmail-toaster: svscan.
Zatrzymywanie xinetd:                                      [  OK  ]
Uruchamianie xinetd:                                       [  OK  ]
/etc/init.d/kloxo: line 43: lxphp.exe: command not found
Stopping kloxo-phpcgi:                                     [FAILED]
Starting kloxo-phpcgi:                                     [FAILED]
Stopping kloxo-hiawatha:                                   [  OK  ]
Starting kloxo-hiawatha:                                   [  OK  ]
Zatrzymywanie php-fpm:                                     [  OK  ]
Uruchamianie php-fpm:                                      [  OK  ]

Code: [Select]
yum install php52s
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.ircam.fr
 * mratwork-ius: mirrors.ircam.fr
 * updates: sunsite.icm.edu.pl
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package php52s.x86_64 0:5.2.17-12.mr.el5 will be installed
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16.1)(64bit) for package: php52s-5.2.17-12.mr.el5.x86_64
--> Running transaction check
---> Package mysql55-libs.x86_64 0:5.5.36-1.ius.el6 will be installed
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5
--> Finished Dependency Resolution
Error: mysql55-libs conflicts with MariaDB-shared-10.0.3-1.x86_64
Error: mysql55-libs conflicts with MariaDB-compat-10.0.3-1.x86_64
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-utils-2.12-1.132.el6.x86_64 has missing requires of libgd.so.2()(64bit)

How to install lxphp.exe?

10
Kloxo-MR Bugs and Requests / Update Error
« on: 2014-04-13, 22:22:26 »
I can not do updates. It is this error:
Code: [Select]
yum update
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: sunsite.icm.edu.pl
 * extras: sunsite.icm.edu.pl
 * mratwork-epel: mirrors.ircam.fr
 * mratwork-ius: mirrors.ircam.fr
 * updates: sunsite.icm.edu.pl
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package httpd.x86_64 0:2.2.26-2.el6 will be updated
---> Package httpd.x86_64 0:2.2.27-1.el6 will be an update
---> Package httpd-devel.x86_64 0:2.2.26-2.el6 will be updated
---> Package httpd-devel.x86_64 0:2.2.27-1.el6 will be an update
---> Package httpd-tools.x86_64 0:2.2.26-2.el6 will be updated
---> Package httpd-tools.x86_64 0:2.2.27-1.el6 will be an update
---> Package kloxomr.noarch 0:6.5.0.f-2014020301.mr will be updated
---> Package kloxomr.noarch 0:6.5.0.f-2014040701.mr will be an update
---> Package kloxomr-thirdparty-phpmyadmin.noarch 0:4.0.10-1.mr will be updated
---> Package kloxomr-thirdparty-phpmyadmin.noarch 0:4.1.12-1.mr will be an update
---> Package mc.x86_64 2:4.8.11-1.el6 will be updated
---> Package mc.x86_64 2:4.8.12-1.el6 will be an update
---> Package mod_ssl.x86_64 1:2.2.26-2.el6 will be updated
---> Package mod_ssl.x86_64 1:2.2.27-1.el6 will be an update
---> Package mratwork-release.noarch 0:0.0.2-2 will be updated
---> Package mratwork-release.noarch 0:0.0.2-5 will be an update
---> Package nginx.x86_64 0:1.5.12-1.el6 will be updated
---> Package nginx.x86_64 0:1.5.13-1.el6 will be an update
---> Package openssl.x86_64 0:1.0.1e-16.el6_5.4 will be updated
---> Package openssl.x86_64 0:1.0.1e-16.el6_5.7 will be an update
---> Package openssl-devel.x86_64 0:1.0.1e-16.el6_5.4 will be updated
---> Package openssl-devel.x86_64 0:1.0.1e-16.el6_5.7 will be an update
---> Package php52s.x86_64 0:5.2.17-11.mr.el6 will be updated
---> Package php52s.x86_64 0:5.2.17-12.mr.el5 will be an update
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16.1)(64bit) for package: php52s-5.2.17-12.mr.el5.x86_64
---> Package spawn-fcgi.x86_64 0:1.6.3-1.el6 will be updated
---> Package spawn-fcgi.x86_64 0:1.6.3-2.mr.el6 will be an update
--> Running transaction check
---> Package mysql55-libs.x86_64 0:5.5.36-1.ius.el6 will be installed
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5
--> Processing Conflict: mysql55-libs-5.5.36-1.ius.el6.x86_64 conflicts mysql-libs < 5.5
--> Finished Dependency Resolution
Error: mysql55-libs conflicts with MariaDB-shared-10.0.3-1.x86_64
Error: mysql55-libs conflicts with MariaDB-compat-10.0.3-1.x86_64
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-utils-2.12-1.132.el6.x86_64 has missing requires of libgd.so.2()(64bit)
Mustafa how to make updates?

11
Kloxo-MR Technical Helps / Re: STMP Error after update
« on: 2014-03-11, 02:20:59 »
Update your qmail with:
Code: [Select]
cd /
yum clean all
yum update
sh /script/fixmail-all
sh /script/restart-mail
It works OK.
Thank you.

12
Kloxo-MR Technical Helps / Re: STMP Error after update
« on: 2014-03-10, 17:36:39 »

13
Kloxo-MR Technical Helps / Re: STMP Error after update
« on: 2014-03-10, 16:51:46 »
Check your IP in spamhuas because maybe your IP is blocked.
http://www.spamhaus.org/lookup/
I checked.
IP is not blocked.

For old or so is OK.
/var/qmail/supervise/smtp/run:
Code: [Select]
#!/bin/sh

QMAILDUID=$(id -u qmaild)
NOFILESGID=$(id -g qmaild)
MAXSMTPD=$(cat /var/qmail/control/concurrencyincoming)
SMTPD="/var/qmail/bin/qmail-smtpd"
TCP_CDB="/etc/tcprules.d/tcp.smtp.cdb"
HOSTNAME=$(hostname)
VCHKPW="/home/vpopmail/bin/vchkpw"

if [ -f /var/qmail/control/norecordio ] ; then
RECORDIO=""
else
RECORDIO="/usr/bin/recordio"
fi

#BLACKLIST=`cat /var/qmail/control/blacklists`
#RBLSMTPD="/usr/bin/rblsmtpd"

if [ -f /var/qmail/control/spamdyke ] ; then
### MR -- content of SPAMDYKE is '/usr/bin/spamdyke -f /etc/spamdyke.conf'
SPAMDYKE=$(cat /var/qmail/control/spamdyke)
else
SPAMDYKE=""

if [ -f /var/qmail/control/rblsmtpd ] ; then
### MR -- content of RBLSMTPD is '/usr/bin/rblsmtpd'
RBLSMTPD=$(cat /var/qmail/control/rblsmtpd)
BLACKLIST=$(cat /var/qmail/control/blacklists)
else
RBLSMTPD=""
BLACKLIST=""
fi
fi

### MR -- incresing SOFTLIMITVAR if not enough (example: because 'login fail')
if [ `uname -m` = 'x86_64' ] ; then
SOFTLIMITVAR="72000000"
else
SOFTLIMITVAR="18000000"
fi

IP=0
PORT=25

### MR -- SSL must using SMTPS=1 and SSL=1 but non-SSL only SSL=0 (without SMTPS=0)
export SMTPAUTH="!" \
SSL=0 \
REQUIRE_AUTH=0 \
FORCE_TLS=0 \
DENY_TLS=0 \
AUTH=1 \
REQUIRE_AUTH=0 \
ALLOW_INSECURE_AUTH=1

### MR -- spamhaus.org recommended for not using $RBLSMTPD $BLACKLIST entry before $SMTPD
exec /usr/bin/softlimit -m $SOFTLIMITVAR \
/usr/bin/tcpserver -v -R -H -l $HOSTNAME -x $TCP_CDB -c "$MAXSMTPD" \
-u "$QMAILDUID" -g "$NOFILESGID" $IP $PORT $RECORDIO \
$SPAMDYKE $RBLSMTPD $SMTPD $VCHKPW /bin/true 2>&1


Quote
In the new config, possible your smtp always filtering by spamdyke and or rblsmtpd. You can disabled it with delete /qmail/control/spamdyke and or /qmail/rblsmtpd
Can you explain that? Please write what to do.

14
Kloxo-MR Technical Helps / Re: STMP Error after update
« on: 2014-03-10, 16:24:42 »
Try 'sh /script/fixmail-all; sh /script/restart-mail'.
Yes I've done it already, and reboot. Still inaction. Before the upgrade was OK.
There can also send mail to the server. Gmail returns:
Code: [Select]
Delivery to the following recipient failed permanently:

     name@domain.com

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain domain.com by mail.domain.com. [188.xx.xx.xx].

The error that the other server returned was:
553 sorry, your envelope sender has been denied (#5.7.1)

15
Kloxo-MR Technical Helps / STMP Error after update
« on: 2014-03-10, 15:33:53 »
After the update:
Code: [Select]
Updating:
 courier-imap-toaster     x86_64     4.1.2-1.3.15.mr.el6       mratwork-release-version-arch     839 k
 qmail-pop3d-toaster      x86_64     1.03-1.3.37.mr.el6        mratwork-release-version-arch      37 k
 qmail-toaster            x86_64     1.03-1.3.37.mr.el6        mratwork-release-version-arch     691 k
You can not send emails.
It is this error:
Code: [Select]
SMTP< 553 sorry, your envelope sender has been denied (#5.7.1)

Pages: [1] 2 3 ... 20

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.048 seconds with 16 queries.

web stats analysis