Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2021-10-25, 21:27:15

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - dfreddie

Pages: [1]
1
Kloxo-MR Technical Helps / Letsencrypt error
« on: 2019-11-15, 14:24:32 »
For some users and some domains I can add Letsencrypt SSL.
But for many cases I get:
Fatal error: Call to a member function isOn() on null in /usr/local/lxlabs/kloxo/httpdocs/lib/domain/domainlib.php on line 1367

2
I've observed to some domeins this record into DNS setings ...
Any clue?

3
I think it will be helpfull.
Thanks.

4
Kloxo-MR Technical Helps / Another Letsencrypt problem
« on: 2017-05-17, 08:11:43 »
sh /script/sysinfo -y
A. Control Panel:               
   - Kloxo-MR: 7.0.0.c-2017051601
   - Web: hiawatha-10.6.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname:
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.30-2.ius.centos6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.30-2.ius.centos6
          * php70m-7.0.18-1.ius.centos6
          * php71m-7.1.4-1.ius.centos6
      - Used: php71m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.13.0-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.25-3.ius.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.16-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.56.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.56.mr.el6.x86_64
      - spam: --uninstalled--
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
             total       used       free     shared    buffers     cached
Mem:          5980       5113        867         21        508       2583
-/+ buffers/cache:       2020       3960
Swap:         3967        271       3696
E. Disk Space:
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_web-lv_root
                       50G  6.5G   41G  14% /


I had installed letsencrypt and is enabled only for admin's and onother user's domains.An is working for this domains.
But how can I enable letsencrypt for all clients domains?

Thank you!

P.S. Why in sysinfo is showing PHP 5.4 for panel? How can I change PHP for panel?

5
After every "sh /script/cleanup" kloxo-mr replace index.html with default one in domains that are using that.

sh /script/sysinfo
A. Control Panel:               
   - Kloxo-MR: 7.0.0.b-2016070304
   - Web: hiawatha-10.3.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: web.proquality.ro
C. Services:
   1. MySQL: MariaDB-server-10.0.27-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.27-1.ius.el6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.27-1.ius.el6
          * php70m-7.0.11-1.w6
      - Used: php56m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.3.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.41-2.el6.x86_64
     - Nginx: nginx-1.11.5-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.23-2.ius.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.7-1.mr.el6.x86_64
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: package courier-toaster is not installed
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: package none is not installed
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          5851       2112       3739          3         68        558
   -/+ buffers/cache:       1485       4366
   Swap:         3967          0       3967
E. Disk Space:
   Filesystem            Size  Used Avail Use% Mounted on
   /dev/mapper/vg_web-lv_root
                          50G  5.2G   42G  12% /


*** Process Time: 00:00:00:19.19385 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

Please help me!!

6
Kloxo-MR Technical Helps / Can't install letsencrypt
« on: 2016-10-20, 20:44:57 »
After install "sh /script/letsencrypt-installer.sh there is no "ssl configure" tab in any of my domains.

Please help me!!!

"sh /script/sysinfo"
A. Control Panel:               
   - Kloxo-MR: 7.0.0.b-2016070304
   - Web: hiawatha-10.3.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: web.proquality.ro
C. Services:
   1. MySQL: MariaDB-server-10.0.27-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.27-1.ius.el6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.27-1.ius.el6
          * php70m-7.0.11-1.w6
      - Used: php56m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.3.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.41-2.el6.x86_64
     - Nginx: nginx-1.11.5-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.23-2.ius.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.7-1.mr.el6.x86_64
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: package courier-toaster is not installed
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: package none is not installed
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          5851       1897       3953          3         58        522
   -/+ buffers/cache:       1317       4534
   Swap:         3967          0       3967
E. Disk Space:
   Filesystem            Size  Used Avail Use% Mounted on
   /dev/mapper/vg_web-lv_root
                          50G  5.2G   42G  12% /


*** Process Time: 00:00:00:19.19350 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

"sh /script/acme.sh-installer"
https://github.com/Neilpang/acme.sh
v2.6.0

*** 'acme.sh' installed (need run 'exec bash' or 'reboot') ***
"cat /home/kloxo/ssl/*_acme.sh"
cat: /home/kloxo/ssl/*_acme.sh: No such file or directory

"yum list|grep openssl"
Repository mratwork-release-neutral-noarch is listed more than once in the configuration
Repository mratwork-release-version-arch is listed more than once in the configuration
Repository mratwork-testing-neutral-noarch is listed more than once in the configuration
Repository mratwork-testing-version-arch is listed more than once in the configuration
Repository mratwork-srpms is listed more than once in the configuration
Repository mratwork-ius-stable is listed more than once in the configuration
Repository mratwork-ius-archive is listed more than once in the configuration
Repository mratwork-remi is listed more than once in the configuration
Repository mratwork-remi-php55 is listed more than once in the configuration
Repository mratwork-remi-php56 is listed more than once in the configuration
Repository mratwork-epel is listed more than once in the configuration
Repository mratwork-varnish-3.0 is listed more than once in the configuration
Repository mratwork-centosec is listed more than once in the configuration
Repository mratwork-nginx is listed more than once in the configuration
Repository mratwork-nginx-stable is listed more than once in the configuration
Repository mratwork-atrpms is listed more than once in the configuration
Repository mratwork-litespeed is listed more than once in the configuration
Repository mratwork-litespeed-update is listed more than once in the configuration
Repository mratwork-google-mod-pagespeed is listed more than once in the configuration
openssl.x86_64                        1.0.1e-48.el6_8.3     @updates           
openssl-devel.x86_64                  1.0.1e-48.el6_8.3     @updates           
apr15u-util-openssl.x86_64            1.5.4-3.ius.el6       mratwork-ius-stable
globus-gsi-openssl-error.i686         3.6-1.el6             mratwork-epel       
globus-gsi-openssl-error.x86_64       3.6-1.el6             mratwork-epel       
globus-gsi-openssl-error-devel.i686   3.6-1.el6             mratwork-epel       
globus-gsi-openssl-error-devel.x86_64 3.6-1.el6             mratwork-epel       
globus-gsi-openssl-error-doc.noarch   3.6-1.el6             mratwork-epel       
globus-openssl-module.i686            4.7-1.el6             mratwork-epel       
globus-openssl-module.x86_64          4.7-1.el6             mratwork-epel       
globus-openssl-module-devel.i686      4.7-1.el6             mratwork-epel       
globus-openssl-module-devel.x86_64    4.7-1.el6             mratwork-epel       
globus-openssl-module-doc.noarch      4.7-1.el6             mratwork-epel       
krb5-pkinit-openssl.x86_64            1.10.3-57.el6         base               
openssl.i686                          1.0.1e-48.el6_8.3     updates             
openssl-devel.i686                    1.0.1e-48.el6_8.3     updates             
openssl-perl.x86_64                   1.0.1e-48.el6_8.3     updates             
openssl-static.x86_64                 1.0.1e-48.el6_8.3     updates             
openssl098e.i686                      0.9.8e-20.el6.centos.1
openssl098e.x86_64                    0.9.8e-20.el6.centos.1
openssl10.x86_64                      1.0.1e-2.ius.el6      mratwork-ius-archive
openssl10-debuginfo.x86_64            1.0.1e-2.ius.el6      mratwork-ius-archive
openssl10-devel.x86_64                1.0.1e-2.ius.el6      mratwork-ius-archive
openssl10-libs.x86_64                 1.0.1e-2.ius.el6      mratwork-ius-archive
openssl10-perl.x86_64                 1.0.1e-2.ius.el6      mratwork-ius-archive
openssl10-static.x86_64               1.0.1e-2.ius.el6      mratwork-ius-archive
xmlsec1-openssl.i686                  1.2.20-4.el6          base               
xmlsec1-openssl.x86_64                1.2.20-4.el6          base               
xmlsec1-openssl-devel.i686            1.2.20-4.el6          base               
xmlsec1-openssl-devel.x86_64          1.2.20-4.el6          base 

"letsencrypt-auto --verbose"
Root logging level set at 10
Saving debug log to /var/log/letsencrypt/letsencrypt.log
certbot version: 0.9.3
Arguments: ['--verbose']
Discovered plugins: PluginsRegistry(PluginEntryPoint#nginx,PluginEntryPoint#standalone,PluginEntryPoint#manual,PluginEntryPoint#webroot,PluginEntryPoint#apache,PluginEntryPoint#null)
Requested authenticator None and installer None
Single candidate plugin: * apache
Description: Apache Web Server plugin - Beta
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = certbot_apache.configurator:ApacheConfigurator
Initialized: <certbot_apache.configurator.ApacheConfigurator object at 0x7f3cc3685790>
Prep: True
Selected authenticator <certbot_apache.configurator.ApacheConfigurator object at 0x7f3cc3685790> and installer <certbot_apache.configurator.ApacheConfigurator object at 0x7f3cc3685790>
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated)  (Enter 'c' to cancel):

Thank you for your time!

7
Kloxo-MR Technical Helps / yum update
« on: 2013-10-03, 17:24:51 »
A. Kloxo-MR: 6.5.0.f-2013091901

B. OS: CentOS release 6.4 (Final) x86_64

C. Apps:
   1. MySQL: mariadb-5.5.33a-1.el6.x86_64
   2. PHP: php54-5.4.19-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.25-1.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.27.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.14.mr.el6.x86_64
   7. Dns: bind-9.9.3-4.P2.el6.x86_64

D. Php-type (for Httpd/proxy): php-fpm_event

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          5282       2365       2917          0        340        924

After "yum update" I have this warnings:

Skipped (dependency problems):
 libconfig       x86_64     1.4.9-1.1.el6           kloxo-mr-centosec      54 k
 lldpad          x86_64     0.9.45-7.el6            base                  200 k
 lldpad-libs     x86_64     0.9.45-7.el6            base                   28 k

How can I ride off it?
Thanks.

8
Kloxo-MR Technical Helps / No records in DNS (bind)
« on: 2013-09-06, 22:16:23 »
A. Kloxo-MR: 6.5.0.f-2013090201

B. OS: CentOS release 6.4 (Final) x86_64

C. Apps:
   1. MySQL: mariadb-5.5.32-2.el6.x86_64
   2. PHP: php54-5.4.19-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.25-1.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.27.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.14.mr.el6.x86_64
   7. Dns: bind-9.9.3-4.P2.el6.x86_64

D. Php-type (for Httpd/proxy): php-fpm_event

Adding a new domain is ok. You can see DNS configuration from panel. But in /var/named ... the domain is not add. How can add manually?

9
Kloxo-MR Technical Helps / Afterlogic 0.7.0 can't login
« on: 2013-06-23, 20:59:20 »
This happend after upgrade to 6.5.0.f-1013031823.
Error is "The user name or password you entered is incorect".
All others are working.

10
Kloxo-MR Technical Helps / Cron job!!
« on: 2013-05-16, 22:15:15 »
I have to recall this subject ... because my last post referring this subject ... has evaporated!!!
Is or not crob job working?

Thanks for ur attention!

11
Kloxo-MR Technical Helps / Webmail login
« on: 2013-04-30, 22:29:30 »
After yum update I can't login into webmail.
I've allready ran /script/fixmail and fixwebmail.

A. Kloxo-MR: 6.5.0.f-2013031811

B. OS: CentOS release 6.4 (Final) x86_64

C. Apps:
   1. MySQL: mysql-5.5.29-1.el6.x86_64
   2. PHP: php53u-5.3.24-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.24-1.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.22.mr.el6.x86_64
   7. Dns: bind-9.9.2-3.P2.el6.x86_64

D. Php-type (for Httpd/proxy): php-fpm_worker

12
Kloxo-MR Releases / Kloxo-Mr 6.5.0 f
« on: 2013-03-19, 02:11:09 »
There is a real "How To" for install this final version?
Thanks.

13
After a fresh install I could not add domain.
Please help!!

14
I've started a topic in romanian section but seems there a few that could help.
I had for more than a year and a half a kloxo 6.1.12 working w/o no problems. Somehow a need to install owncloud that needs PHP > 5.3. I thought that's time to upgrade to kloxo-mr and I ran the upgrade scripts.
Finally ... after I upgraded manually to php54 and install mcrypt for it all webpages worked but I had no access to kloxo login page (my-ip:7778 returns blank page w/o no errors). I had disabled firewall ... nothing changed.
Last thing I've done was ti run once again "sh kloxo-installer.sh --type=master" and after reboot I still have no access to login page and more I screwed web pages with php and maybe mysql.

Can be something done to get it back?

Thanks a lot!

15
Romanian Users / kloxo 6.1.12 si kloxo-mr
« on: 2013-02-25, 22:13:18 »
Salut,

Desi nu-mi este straina limba engleza vreau sa profit sa scriu in limba materna. Astfel salut pe toti cei de pe acest forum!
Problema: am instalat un kloxo 6.1.12 de ceva mai mult de un an de zile. In acest weekend ar fi trebuit sa instalez ceva ce probabil foloseste PHP > 5.3 (owncloud).
Astfel am incercat sa instalez kloxo-mr 6.5.X.X peste kloxo 6.1.12. Finalitatea a fost ca n-am reusit sa fac upgrade-ul ... insa am reusit sa-mi "fac praf" serverul, in sensul ca aplicatiile ce foloseau php dau eroarea: Fatal error: Call to undefined function mcrypt_create_iv() in /home/xxx/yyy/system/library/encryption.php on line 8 si nici pagina de log-in de la kloxo nu mai functioneaza (blank page).

Intrebare: exista vreo metoda eficienta de a face upgrade-ul la 6.5.x.x (am citit ce s-a postat si niciuna din metodele de upgrade nu sunt functionale ... cel putin la mine) sau ... cum aduc 6.1.12 "back as it was"?

Multumesc frumos!

Pages: [1]

MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.055 seconds with 15 queries.

web stats analysis