Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2019-08-24, 23:51:15

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - lenawaii

Pages: [1] 2
1
Hey,

My VPS provider changed of IP for my VPS. I changed everything: dns template, all A record in dns settings for domains.

The website are online but i  have trouble with Qmail, when I read IP addresses in kloxo panel, I have the following:
venet0-0___localhost   5.230.x.x (Not USED grey button) venet0:0 (NEW IP)
venet0-1___localhost   82.211.x.x  (USED green button) venet0:1 (OLD IP)

I tried cleanup, fixmail, fix-all etc, the new IP is still not green

Can you please help me, thanks

2
Kloxo-MR Technical Helps / Trouble with hostname in Qmail
« on: 2018-10-15, 09:53:36 »
Hey there,

I have some trouble with hostname with Kloxo MR 7.

I defined my hostname with command: #hostnamectl set-hostname server3.mydomain.com
If i do: hostnamectl status, my static hostname is: server3.mydomain.com

But when I receive a mail from my server with email root@server3.server3, it shoud be root@server3.mydomain.com, so what's wrong?

Plus, when I send an email to mail-tester.com, my hostname is detected as only "server3" and not "server3.mydomain.com"

Can you please help me resolve this? Thanks a lot.

3
Hey there,

After install of kloxo mr7, i could not access kloxo panel and i found that because apache wasn't working, here is the bug:

Sep 10 01:05:07 serverx.domain.com systemd[1]: Starting The Apache HTTP Server...
Sep 10 01:05:07 serverx.domain.com httpd[17635]: AH00526: Syntax error on line 21 of /opt/configs/apache/conf/defaults/init.conf:
Sep 10 01:05:07 serverx.domain.com httpd[17635]: Cannot define multiple Listeners on the same IP:port
Sep 10 01:05:07 serverx.domain.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Sep 10 01:05:07 serverx.domain.com systemd[1]: Failed to start The Apache HTTP Server.
Sep 10 01:05:07 serverx.domain.com systemd[1]: Unit httpd.service entered failed state.
Sep 10 01:05:07 serverx.domain.com systemd[1]: httpd.service failed.

After commented line 21 in the init.conf, I have a bug with Bind:

Sep 10 01:29:38 serverx.domain.com named[19358]: the working directory is not writable
Sep 10 01:29:38 serverx.domain.com named[19358]: isc_stdio_open '/var/log/named/database.log' failed: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: configuring logging: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: loading configuration: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: exiting (due to fatal error)
Sep 10 01:29:38 serverx.domain.com named[19347]: Starting named: [FAILED]
Sep 10 01:29:38 serverx.domain.com systemd[1]: named.service: control process exited, code=exited status=7
Sep 10 01:29:38 serverx.domain.com systemd[1]: Failed to start LSB: start|stop|status|restart|try-restart|reload|force-reload DNS server.
Sep 10 01:29:38 serverx.domain.com systemd[1]: Unit named.service entered failed state.
Sep 10 01:29:38 serverx.domain.com systemd[1]: named.service failed

Can you please help, thanks.


4
Hi mustapha,

I just updated my Kloxo MR 6.5 and I had this error:

- List for 'dns' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'dovecot' branch
- List for 'httpd' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'lighttpd' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'mysql' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'nginx' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'php' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
- List for 'qmail' branch
http://qtp.qmailtoaster.com/repos/nodist/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
Checking for rpm packages
- For autorespond-toaster package
- For courier-authlib-toaster package
- For courier-imap-toaster package
...

I could update my VPS any way but it is for your info.

Have a good day!

5
Kloxo-MR Bugs and Requests / Fresh install Kloxo MR 7 bug
« on: 2017-11-03, 12:14:51 »
Hi,

Got this error after this command line : #yum update mratwork-* -y

http://repo.varnish-cache.org/redhat/varnish-3.0/el6/x86_64/repodata/repomd.xml:             [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 410 repo"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: mratwork            -varnish-3.0. Please verify its path and try again

6
Kloxo-MR Technical Helps / Bind conf files path?
« on: 2017-05-16, 23:46:40 »
Hi,

In Kloxo MR 6.5, path to bind conf files for domains was /home/bind/conf/master/domain.com.conf

Will please let me know were are located bind conf files in Kloxo MR 7.0?

Thank you.

7
Hi,

I just did an update of kloxo and when I tried to do # sh /script/cleanup-simple I had this error:

sh: /script/cleanup-simple: No such file or directory

So I checked the /script folder and and all commun functions like 'restart', 'restart-all', 'restart-dns' etc are missing in the folder.

Can you tell me please what's wrong? Thanks

8
Hi mustapha,

I was wondering how to duplicate a server with Kloxo MR 7.0 to another VPS?

I know that you can rsync the VPS with this this line of code:
# rsync -arv --delete root@xx.xxx.xx.xxx:/ -e "ssh -p xxx" /

but after that, it's necessary to update some files, what do you suggest?

THanks for your help ;-)

9
Kloxo-MR Technical Helps / Roundcube autoreply
« on: 2016-09-07, 11:31:00 »
Hi Mustapha,

1/ I tried to install vacation module in Roundcube but I didn't managed to make it work https://sourceforge.net/projects/rcubevacation/ Do you know if it's possible de make it work with Kloxo MR 7.0?

2/ In case I need to modify Roundcube by myself, can you please give information:
- autoreply stored in database kloxo > table autoresponder ok
- set autoreply stored where?
- enable/disable autoreply stored where?
- any idea to help modify autoreply to HTML Format?

Thanks for help  :)

10
Kloxo-MR Technical Helps / X-Frame-Options Kloxo MR 7
« on: 2016-08-22, 12:07:10 »
Hi Mustapha,

I'm discovering Kloxo MR 7 and I have several questions, can you please inform me:

1/ Where to set/unset X-Frame-Options? I would like to allow iframes for a domain.

2/ What is the difference between PHP Used and PHP Branch in Configure for pserver-localhost?

3/ Is it possible to set a PHP version only for a client or is it apparently set for all clients?

4/ Which lxcenter conf is used by kloxo MR 7?
- /etc/httpd/conf.d/~lxcenter.conf ?
- /opt/configs/apache/conf.d/~lxcenter.conf ?

5/ It's impossible to modify hostmaster email in DNS templates > mytemplate.dnst > General Settings > Hostmaster Email. There is a bug to fix, I guess.

Thanks for your help.

11
Kloxo-MR Technical Helps / Qmail issues and tips
« on: 2016-07-24, 16:27:26 »
Hi everyone,

I have two questions, thank you for your help:

1/ Can we bind several IP address to Qmail Toaster in Kloxo MR 7? I would like to protect some Ip from being blacklisted. As you know, only one bad client acting as a spammer can destroy your IP reputation. In this way, I could isolate customers with dedicated IPs on the VPS.

2/ Can we force send outgoing mails to domains that are currently in the VPS (listed in rcpthosts)? For example, i have domain.com on server A but emails of domain.com are on server B. If i send an email from server A to postmaster@domain.com, the email don't reach Server B but get stuck on server A. What is the solution ? My goal would be to have one VPS for domains and another VPS for emails.

Best regards, Lenawaii

12
Hi Mustapha,

I've some trouble with Spamdyke since I've installed Let's Encrypt on my VPS and and SSL certificate to secure Qmail Toaster.

Let's Encrypt works perfectly, so no worry for this. Here's what I've done:

1/ Remplacement of /var/qmail/control/servercert.pem file with my ssl cert + intermediate cert + privatekey
Works fine with 465 port and 993 port

2/ Modification of /var/qmail/supervise/smtp-ssl/run file with:

export SMTPAUTH="!" \
   SMTPS=1 \
   SSL=1 \
   REQUIRE_AUTH=0 \
   FORCE_TLS=0 \
   DENY_TLS=0 \
   AUTH=1 \
   REQUIRE_AUTH=0 \
   ALLOW_INSECURE_AUTH=0

3/ Modification of /etc/spamdyke.conf file and added
tls-level=smtps
just before
tls-certificate-file=/var/qmail/control/servercert.pem

4/ Restart of Qmail

RESULT :
I can send emails but emails sent from outside the server are not delivered to my VPS, they are blocked. If I desactivate Spamdyke, i will receive emails so the problem is from Spamdyke.

Plus, tls-level=smtps line in spamdyke.conf file disappear when I desactivate Spamdyke. I'm sure I do something wrong.

Can you please give me some help, thanks

Lenawaii




13
Hi everyone,

I had a VPS breakdown for an hour and after restart, my VPS has trouble to start named (bind DNS Server). Here is the error I have :

Error in named configuration:
/home/bind/conf/defaults/named.acl.conf:5: undefined ACL 'mydomain.com'

Here is the file:
acl allow-transfer {
localhost;
xxx.xxx.xx.xx1;
xxx.xxx.xx.xx2;
mydomain.com;
};

All worked perfectly before the breakdown, have you an idea to resolve this issue? Thanks a lot.

14
Hi everyone,

I had to upgrade PHP from php53 to php54 and now PHP is not working anymore.

I did the upgrade from Kloxo > Web - Mail -Database > Webserver Config > Php Branch choosed php54 in the select menu and then click on "update"

After that I did:
# yum update
# sh /script/cleanup

Even after update and cleanup, php is not working, any idea ?

Here is below my system info:

A. Kloxo-MR: 6.5.0.f-2015083001

B. OS: CentOS release 6.7 (Final) x86_64

C. Apps:
   1. MySQL: mysql55-5.5.45-1.ius.el6.x86_64
   2. PHP: php54-5.4.45-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.31-1.mr.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Nginx: --uninstalled--
   6. Qmail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
   7. Dns: bind-9.9.7-1.mr.el6.x86_64

D. Php-type (for Httpd/proxy): mod_php_ruid2

E. Memory:
                total       used       free     shared    buffers     cached
   Mem:          4096        924       3171          8          0        717
   -/+ buffers/cache:        206       3889
   Swap:            0          0          0


15
Hi,

I saw on Spamdyke documentation that this is possibly to customize rejection message. So I tried to add lines in my /etc/spamdyke.conf file following this way!

#REJECTION MESSAGES
rejection-text-ip-blacklist=my personal message 1
rejection-text-unresolvable-rdns=my personal message 2

But Qmail does not work proprely after restart. Any idea to resolve this?

Thanks for your help.


Pages: [1] 2

Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.051 seconds with 18 queries.

web stats analysis