Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-28, 02:46:58

Author Topic: PHP Accelerator  (Read 1286 times)

0 Members and 1 Guest are viewing this topic.

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
PHP Accelerator
« on: 2016-09-24, 10:22:21 »
Hello
What kind of PHP Accelerator i can install in Kloxo-MR and how?

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #1 on: 2016-09-24, 10:53:41 »
Go to 'admin > php modules status' and then click 'enable' apcu (if not exists select apc). And then click 'restart'. Better enable for every 'php target'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #2 on: 2016-09-24, 11:10:48 »
Hm.
But there is no apc in PHP Module Status. No xcache and etc

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #3 on: 2016-09-24, 11:38:24 »
Add 'apc' in 'seach' of 'php module status' and then you will see apc/apcu.

Remember, it's only exists in Kloxo-MR 7.0
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #4 on: 2016-09-24, 12:09:54 »
Using Kloxo-MR 7.0.0.b-2016092301
Added 'apc' in 'seach' of 'php module status' and nothing

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #5 on: 2016-09-24, 12:17:37 »
Using Kloxo-MR 7.0.0.b-2016092301
Added 'apc' in 'seach' of 'php module status' and nothing
Click 'showall' first and then add 'apc' and click 'looking glass' icon.

Remember, only 'multiple php' already installing all modules. You need install separately for 'php branch' (aka 'php' in 'target' at 'php module status').
« Last Edit: 2016-09-24, 12:19:38 by MRatWork »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #6 on: 2016-09-24, 12:26:55 »
Done, but  there is no apc in PHP Module Status.

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #7 on: 2016-09-24, 13:03:23 »
I installed several phps in Multiple php and now apc is in PHP Module Status. Also there are xcache, memcached, can i use them?

Can I use different types of php for different users? Or I have to choose only one as PHP Used?
« Last Edit: 2016-09-24, 13:17:07 by xamer »

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #8 on: 2016-09-24, 13:39:34 »
In Kloxo-MR 7.0 terms, 'php branch' is php installed using 'yum install' (only possible 1 version at the same times).

'multiple php' (need enable 'Multiple PHP Enable (for 'php-fpm') ' in 'admin > servers > localhost > php configure') are php installed using 'special treatment' (possible multiple php at the same times).

'php used' is 'default php version' if not selected other version for certain domain.

In Kloxo-MR 7.0, possible using different version for every domain via 'admin > all > all domains > (select one) > web features'.

Apc/apcu are the same functions (target to php opcode) with xcache and opcache  where memcached/redis are cache different functions (target to database).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #9 on: 2016-09-24, 14:19:11 »
OMG. It is so GREAT! I'll try everything.
Thank you very much

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #10 on: 2016-09-24, 15:06:05 »
Apc/apcu are the same functions (target to php opcode) with xcache and opcache  where memcached/redis are cache different functions (target to database).
I understand these differences. I enabled apc as php Accelerator.

But also i need a memecached server. I enabled php modules for this, but how can i install a memecached server safety?

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #11 on: 2016-09-24, 15:13:04 »
Run 'yum install memcached -y' if enable memcached module for php.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #12 on: 2016-09-24, 15:33:45 »
Everything is fine.
Completely done.

Offline xamer

  • Valuable Member
  • *
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Re: PHP Accelerator
« Reply #13 on: 2016-09-26, 01:38:11 »
Well, i have one more question.
I've got php 5.5.38 as PHP Branch. I use multiple php for domains and memcached enabled and everithing works fine. But if i run php script with cron tasks it doesn't work, because memcached extension is not instaled for php branch.
How can i solve the problem?
I tried to install it by
yum install php-pecl-memcache php-pecl-memcached -y
they didn't install giving conflits errors.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP Accelerator
« Reply #14 on: 2016-09-26, 02:44:42 »
If using php 5.5 as 'php branch', try 'yum install php55u-pecl-memcached -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo

Page created in 0.051 seconds with 19 queries.

web stats analysis