Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-11-18, 01:08:53

Author Topic: Add Handler fixes PHP errors?  (Read 1708 times)

0 Members and 1 Guest are viewing this topic.

Offline Sniffer

  • Junior Member
  • *
  • Posts: 30
  • Karma: +1/-0
    • View Profile
Add Handler fixes PHP errors?
« on: 2015-12-05, 21:32:12 »
I'm running PHP 5.4 & 5.5 but have 5.5 set as used in Kloxo but PHP script throws errors unless I add

<FilesMatch \.php$>
SetHandler x-httpd-php55
</FilesMatch>

Why is this as PHP version is still the same?
Kloxo-MR best cPanel Replacement!

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Add Handler fixes PHP errors?
« Reply #1 on: 2015-12-06, 03:57:01 »
Use 'SetHandler' work if apache/proxy with 'secondary php' enabled. Secondary php use 'suphp'  mode.

If normal php not work, possible  'admin > php configure', 'admin >servers >  (select one)  > php confugure' and 'admin > clients >  (select one) >  configure' not   set.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Sniffer

  • Junior Member
  • *
  • Posts: 30
  • Karma: +1/-0
    • View Profile
Re: Add Handler fixes PHP errors?
« Reply #2 on: 2015-12-06, 09:27:35 »
Thanks will check these. Also how do I remove php 5.3 & 5.6?

In phptype I only have
php-fpm_event
php-fpm_worker

Why has all others gone?
« Last Edit: 2015-12-06, 09:37:25 by Sniffer »
Kloxo-MR best cPanel Replacement!

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Add Handler fixes PHP errors?
« Reply #3 on: 2015-12-06, 10:21:07 »
Thanks will check these. Also how do I remove php 5.3 & 5.6?

In phptype I only have
php-fpm_event
php-fpm_worker

Why has all others gone?
Secondary php only work under php-fpm_event and _worker.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo

Page created in 0.059 seconds with 23 queries.

web stats analysis