Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2020-03-30, 12:02:51

Author Topic: Upgrade MariaDB to 10.4  (Read 1303 times)

0 Members and 1 Guest are viewing this topic.

Offline rsakhale

  • Valuable Member
  • *
  • Posts: 102
  • Karma: +0/-0
  • Gender: Male
  • Rohan Sakhale
    • View Profile
    • Rohan Rajan Sangita Sakhale
Upgrade MariaDB to 10.4
« on: 2020-03-09, 12:51:35 »
I tried doing

Code: [Select]
sh /script/mariadb-upgrade 10.4
However, this failed at the end

Code: [Select]
=====================================================================================================================================================
 Package                           Arch                      Version                                       Repository                           Size
=====================================================================================================================================================
Installing:
 MariaDB-server                    x86_64                    10.4.12-1.el7.centos                          mratwork-mariadb                     26 M
Installing for dependencies:
 galera-4                          x86_64                    26.4.3-1.rhel7.el7.centos                     mratwork-mariadb                    9.3 M

Transaction Summary
=====================================================================================================================================================
Install  1 Package (+1 Dependent package)

Total size: 35 M
Installed size: 135 M
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/bin/garbd from install of galera-4-26.4.3-1.rhel7.el7.centos.x86_64 conflicts with file from package galera-25.3.28-1.rhel7.el7.centos.x86_64

Error Summary
-------------


- For help, type '/script/restart-mysql [--help|-h]'
/script/mariadb-upgrade: line 35: mysql_upgrade: command not found

- For help, type '/script/restart-mysql [--help|-h]'
- End process...

* Note:
  - Format: /script/mariadb-upgrade [target-version]
    where [target-version] = 10.2 (by default)

Now, after this mysql doesn't seem to work normally.

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.027 seconds with 21 queries.

web stats analysis