Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-09-21, 17:13:23

Author Topic: Unable to edit php.ini after update to Kloxo-MR 7.0  (Read 1139 times)

0 Members and 1 Guest are viewing this topic.

Offline Vikalp_C

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Hello everyone, yesterday I updated Kloxo-MR from 6.5 to 7.0, everything went fine, except one.
I need to increase the memory_limit as alloted to php, I have done this many times before but since the update after editing the /etc/php.ini/ and restarting webserver, the changes are not taking effect.
I have confirmed many times that I am editing the right php.ini file, but still no effect.
I would be very thankful if someone would be able to help me.
Here are various details of my server, if anything else is needed please tell me.


Sysinfo: -
Code: [Select]
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017091202
   - Web: hiawatha-10.6.0-f.1.mr.el6.x86_64
   - PHP: php56s - 5.6.36-1.ius.centos6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname: server.vikalp.pro
C. Services:
   1. MySQL: MariaDB-server-10.0.35-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.36-1.ius.centos6.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.47-1.el6.x86_64
     - Nginx: nginx-1.14.0-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.33-3.ius.centos6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.20-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
             total       used       free     shared    buffers     cached
Mem:          4024       1547       2476          8          0       1000
-/+ buffers/cache:        547       3476
Swap:         4060          7       4052
E. Disk Space:
Filesystem      Size  Used Avail Use% Mounted on
/dev/simfs       50G   34G   17G  68% /


*** Process Time: 00:00:00:19.19901 (dd:hh:mm:ss:xxxxxx) ***

php -v
Code: [Select]
[root@server ~]# php -v
PHP 5.6.36 (cli) (built: Apr 27 2018 10:26:07)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, Copyright (c) 2002-2018, by ionCube Ltd.

Current webserver configuration in panel: -
Please find attached.

Many thanks in advance.

Offline alex_fear

  • Valuable Member
  • *
  • Posts: 52
  • Karma: +1/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #1 on: 2018-05-08, 09:52:12 »
 admin — Servers — localhost — {Advanced PHP Configure

Offline Vikalp_C

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #2 on: 2018-05-09, 08:09:42 »
admin — Servers — localhost — {Advanced PHP Configure

Doesn't work. I ran phpinfo(); and got to know that the server is using a php.ini file located inside one of my client domains. Don't know how that happened.(Please see attached screenshot)
How can I change the path to the php.ini which I want to load?

Thanks you.

Offline Vikalp_C

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #3 on: 2018-05-09, 10:18:10 »
Also, there has been a new more bigger problem I just noticed.
The files for the websites which existed before I updated to kloxo-MR 7 are working fine, but if I upload or create a new file, I am always getting error 404. I have double and triple checked the path and locations of the file but still getting 404 everytime. This is very strange. Even changed file permissions of all files and folders to 777 still no help.
If someone knows about this please reply.

Many thanks.

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #4 on: 2018-05-09, 15:03:55 »
Looks like file ownership problems. When you upload files you must check for right ownership of the new files. If you don't allready have Webmin installed I reccomend you do so. It works well with Kloxo-MR, and from its File Manager it is easy to correct file ownership of folders and files.

But before installing Webmin you can first try to fix your problem by selecting from Kloxo-MR Home the Webserver Configure icon, and then in Fix 'ownership' And 'permissions' (Select To Execute) select fix-ALL and hit update.

Hope it works out for you.

AJ

Offline Vikalp_C

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #5 on: 2018-05-09, 15:24:25 »
Looks like file ownership problems. When you upload files you must check for right ownership of the new files. If you don't allready have Webmin installed I reccomend you do so. It works well with Kloxo-MR, and from its File Manager it is easy to correct file ownership of folders and files.

But before installing Webmin you can first try to fix your problem by selecting from Kloxo-MR Home the Webserver Configure icon, and then in Fix 'ownership' And 'permissions' (Select To Execute) select fix-ALL and hit update.

Hope it works out for you.

AJ

I have already tried this Fix 'ownership' And 'permissions' from within the Kloxo-MR panel, but to no avail.
I will try webmin but can you please tell me what should be the correct ownership and permissions for the files? I have two websites on the server, with path to the public_html folder in this format: -
Code: [Select]
/home/domain/public_html/
and
/home/domain2/public_html/

Many thanks.

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #6 on: 2018-05-09, 22:44:36 »
I have setup my VPS server with clients, and my own client is admin. And it is easy to create several other clients. The path to my domain is /home/admin/mydomain/.
All folders below mydomain will be owned by admin/admin (admin/apache also work). For permissions general rule is that all folders be set to 755 and all files to 644.

I am by no means an expert. I am self thaught and spent noumerous hours to search this forum and other internet sites. I have several times run into problems with the setup, been frustrated from time to time but also realized that most of the problems was due to my own misstakes. So I recorded the steps for a successful installation and I have created a 35 page Kloxo-MR Server Configuration Guide for Linux Beginners which also include installing Webmin, firewall etc.
I will not publish it here, but I can share it to you. Or better, if you register to my newly created website at https://www.lundeco.com then we can discuss further there. It has a video conferencing capability and email and chat functionality, and we can use this to discuss. That way you can also help me test my website, which is actually a learning portal for online courses.

AJ

Offline Vikalp_C

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #7 on: 2018-05-10, 08:53:40 »
I have setup my VPS server with clients, and my own client is admin. And it is easy to create several other clients. The path to my domain is /home/admin/mydomain/.
All folders below mydomain will be owned by admin/admin (admin/apache also work). For permissions general rule is that all folders be set to 755 and all files to 644.

I am by no means an expert. I am self thaught and spent noumerous hours to search this forum and other internet sites. I have several times run into problems with the setup, been frustrated from time to time but also realized that most of the problems was due to my own misstakes. So I recorded the steps for a successful installation and I have created a 35 page Kloxo-MR Server Configuration Guide for Linux Beginners which also include installing Webmin, firewall etc.
I will not publish it here, but I can share it to you. Or better, if you register to my newly created website at https://www.lundeco.com then we can discuss further there. It has a video conferencing capability and email and chat functionality, and we can use this to discuss. That way you can also help me test my website, which is actually a learning portal for online courses.

AJ

OK, thanks. I will register there. Also, the Kloxo-MR server configuration guide will be of much help.
Thank you.

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Unable to edit php.ini after update to Kloxo-MR 7.0
« Reply #8 on: 2018-06-17, 22:05:26 »
you can edit it by php setting

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.063 seconds with 22 queries.

web stats analysis