Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2019-09-22, 05:32:59

Author Topic: Swich to apache  (Read 1050 times)

0 Members and 1 Guest are viewing this topic.

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Swich to apache
« on: 2019-07-22, 09:01:35 »
Hello folks switching from Hiawatha to Apache should be something like
sh /script/hiawatha-to-httpd

Am I correct if not please tell me how to do so from hiawatha

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #1 on: 2019-07-23, 20:05:07 »
In 'Admin > switch program'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #2 on: 2019-07-24, 09:48:02 »
Hello its Server/Switch Program
Then I choosed apache stays close but then I cant remove the arrow that signals apache 2.4

So I try to be very very carefull

rpm -q httpd
Server version: Apache/2.2.31 (Unix)
Server built:   Jul 23 2015 05:50:27
Server's Module Magic Number: 20051115:40
Server loaded:  APR 1.5.2, APR-Util 1.5.4
Compiled using: APR 1.5.2, APR-Util 1.5.4
Architecture:   64-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/etc/httpd"
 -D SUEXEC_BIN="/usr/sbin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

So then I choosed for my good sake on server configuration php 5.2.17 as it recognizes from my previous config and installs it so it goes with multi php on the back enabled

I go check and type my domain on browser

If you
are seeing this page, it means that the Domain has been successfully
            configured on the machine, but the files has not been uploaded yet.

So things are running smooth since I gues bind is working for me as setted on apache so the only thing for me is why restarting kloxo brings still

Stopping kloxo-hiawatha:                                   [  OK  ]
Starting kloxo-hiawatha:                                   [  OK  ]
-------------------------------------------------------------------

Stopping kloxo-phpcgi:                                     [  OK  ]
Starting kloxo-phpcgi ('php56s' in 'fpm' mode):            [  OK  ]
-------------------------------------------------------------------

Kloxo Wrapper -> STOP
Kloxo Wrapper -> START
------------------------------------------------

It is apache runs port 80 it aint that


Please tell me where my files should be after restore backup
I look here home/admin/user
Somehow kloxo file manager gives
(Client: admin) / myuser/ mydomain.com / public_html (Client: admin) / myuser/ mydomain.com / public_html

I dont see my files after restored so I should have configuration issue ,I had files also on a testing path I used to test apache and I guess kloxo is powerfull and makes them hide from my eyes like it did with back up just restored I need to fix this issue or I will empty my disc space shiverin
please do help

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #3 on: 2019-07-27, 13:01:34 »
In Kloxo-MR design, all web/webcache/dns/qmail already installed. If we choose certain web server (for example httpd) and then Kloxo-MR disable this service (not uninstalled).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #4 on: 2019-07-30, 05:12:49 »
i cant tell about this path,you mean maybe that kloxo disables apache because of qmail maybe but the fact here is that maybe I got mixed paths from the fact of me having a user named admin before installing kloxo just to test apache on home .This made cross paths that when restoring backup makes kloxo hide files.

Can you please tell me where should I find my files on kloxo?
What is the path for html area?


Thank you much thanks

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #5 on: 2019-07-30, 12:47:05 »
Website in '/home/<user>/<domain>' directory.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #6 on: 2019-08-02, 06:08:50 »

I guess that what happened is that kloxo installation used the user admin I had for testing apache and deleted the stuff previously
uploaded ,yes the user admin did not have privilleges but when kloxo took this same user then added privillege of ownner but then
again deleted the files from backup as well,maybe is firewall dunno

Look MR what kloxo left via sftp is this path
home/admin/my user/my domain/then html area dir

............and over kloxo what I have is
under client admin -always-/my user/my domain/html area     

So is pretty much the same you missed admin that works as client on kloxo and as user or wheel user via ftp

Pretty much Mustafa your ignoring admin on your path its like first is admin as cl:ient or wheel user then is a sub user then is domain then is html area
so..................What should I do in order to see files from backup restoration?.Should I restore backup file again?,should I delete directory Indexes or
Should I reconfigure back again everything inside kloxo admin?     Should I stay or should I go?

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #7 on: 2019-08-02, 06:37:38 »
By design directory for domain always '/home/<user>/<domain>/'. Yes, we can change this path like '/home/<user>/<whatever>/'. Special path is '/home/<user>/public_html' were symlink for latest domain create or default domain (if set it).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #8 on: 2019-08-03, 05:51:13 »
I guess my server is well configured in kloxo thru admin since my domain resolves well on apache bringing kloxo error pages so the question why files dont appear from restoration of backup might be permissions

for admin I got 7797 permission with apache 48 as group

What permissions should admin have ?

Thank you

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #9 on: 2019-08-03, 09:01:22 »
The same.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #10 on: 2019-08-05, 04:07:31 »
Thank you very much if I upload my files again via ftp my databases wont work because they will  change owner as root .The best idea would be restoring backup again from kloxo admin ,is this correct?

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #11 on: 2019-08-05, 08:46:40 »
I deleted the backup file uploaded via client sftp since it had owner root and uploaded a new one via kloxo ,restored it and still there is no files just index.html on html area it looks  empty backup,Maybe it is httpd configuration file that has on document root var/www .Its something I cant tell now but uploading backup file via root or via kloxo still dont work for restoration

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #12 on: 2019-08-07, 03:14:46 »
It's maybe not related to upload process but backup process itself. Maybe backup process may broked.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline South

  • Valuable Member
  • *
  • Posts: 104
  • Karma: +0/-0
    • View Profile
Re: Swich to apache
« Reply #13 on: 2019-08-07, 13:47:01 »
No men it was that I needed to restore the whole thang  -the whole admin

Voila now my files are restored succesfully on home/admin/myuser
thank god
it was just 2 more gigas to my disc it wasnt that much

Im stuck on kloxo error 500

<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>
removed processed logs cant read index.php CANT READ home/admin/user/index.php
error 500 kloxo error 500
the server made BOO BOO BOO BOO
I have modules php52m on green in msql and msqli then why index.php is not readth
must uncomment please
ServerRoot "/etc/httpd"

# MR -- must be disable here because can not overrite! -- importance for proxy-to-apache
# Listen 80
on web basics allow directory index still appear error 500


part of my config

erverTokens OS

ServerRoot "/etc/httpd"

# MR -- must be disable here because can not overrite! -- importance for proxy-to-apache
 Listen 80

Include conf.modules.d/*.conf

User apache
Group apache

ServerAdmin root@localhost

<Directory />
    AllowOverride none
    Require all denied
</Directory>

DocumentRoot "/home/admin/myuser/"

<Directory "/home/admin/myuser/">
    AllowOverride None
    # Allow open access:
    Require all granted
</Directory>

# Further relax access to the default document root:
<Directory "/home/admin/my user/">
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>


Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,709
  • Karma: +119/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Swich to apache
« Reply #14 on: 2019-08-07, 14:32:57 »
Try 'sh /script/cleanup'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine

Page created in 0.04 seconds with 21 queries.

web stats analysis