Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-02-23, 06:46:25

Author Topic: Some Services not installed and some can not start.  (Read 748 times)

0 Members and 1 Guest are viewing this topic.

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Hi
I have installed kloxo 7 on centos 7.
some services could not start.
Some services has gray icon and has not installed.
I attached screenshot.
for exam i want start Apache or Lighttpd but only Nginx can start.
Please help:

1-Whay apache can not start?
2-Can i start apache and nginx and lighttpd together?
3-Why Services with gray icon has not installed? they are not a default services of kloxo or i installed kloxo badly?

Thanks

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,381
  • Karma: +113/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some Services not installed and some can not start.
« Reply #1 on: 2017-09-12, 17:14:35 »
Inform here 'sh /script/sysinfo'. Did you already add 'domain' in Kloxo-MR panel?.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #2 on: 2017-09-12, 17:24:32 »
Hi
After this help request i did this in ssh
Code: [Select]
yum reinstall kloxomr7 -y
sh /script/cleanup
« Last Edit: 2017-09-12, 19:28:08 by SanOS »

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #3 on: 2017-09-12, 17:26:01 »
Please wait, i did that and not ended, afterward i report sh /script/sysinfo.
Thanks
« Last Edit: 2017-09-12, 19:28:55 by SanOS »

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #4 on: 2017-09-12, 18:31:43 »
Problems is still exist.

i did sh /script/sysinfo
Code: [Select]
[root@server ~]# sh /script/sysinfo
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017091001
   - Web: hiawatha-10.6.0-f.1.mr.el7.x86_64
   - PHP: php56s - 5.6.31-1.ius.centos7 (fpm mode)
B. Plateform:
   - OS: CentOS Linux release 7.3.1611 (Core) x86_64
   - Hostname: server.fansalaran.com
C. Services:
   1. MySQL: MariaDB-server-10.0.32-1.el7.centos.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.31-1.ius.centos7.x86_64
        - Multiple:
          * php56m - 5.6.31-1.ius.centos7
          * php70m - 7.0.22-2.ius.centos7
          * php71m - 7.1.8-2.ius.centos7
      - Used: --PHP Branch--
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el7.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el7.x86_64
     - Nginx: nginx-1.13.5-1.el7.ngx.x86_64
     - Apache: httpd24u-2.4.27-1.ius.centos7.x86_64
       - PHP Type: suphp_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el7.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el7.x86_64
     - NSD: nsd-4.1.16-1.el7.x86_64
     - PowerDNS: pdns-4.0.3-1.el7.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el7.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el7.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - spam: bogofilter-1.2.3-6.el7.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.42-3.el7.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
              total        used        free      shared  buff/cache   available
Mem:            992         307         346           6         338         531
Swap:          2047           0        2047
E. Disk Space:
Filesystem               Size  Used Avail Use% Mounted on
/dev/mapper/centos-root  4.8G  2.3G  2.3G  51% /


*** Process Time: 00:00:01:58.118125 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

[root@server ~]#


Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #5 on: 2017-09-12, 19:15:37 »
Quote
Did you already add 'domain' in Kloxo-MR panel?
No

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #6 on: 2017-09-12, 19:26:17 »
I have rent a vps for testing and exercise centos 6 and 7 and other OS.
Also exercise kloxo and other web panels.
I had installed kloxo7 on centos6.9 and now i test on centos 7
« Last Edit: 2017-09-12, 19:29:22 by SanOS »

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #7 on: 2017-09-13, 11:40:38 »
maybe PHP settings cause httpd and lighttpd can not work?

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,381
  • Karma: +113/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some Services not installed and some can not start.
« Reply #8 on: 2017-09-13, 12:04:54 »
Better add 'domain' in panel because without it sometimes certain webserver not work.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline SanOS

  • Junior Member
  • *
  • Posts: 16
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Some Services not installed and some can not start.
« Reply #9 on: 2017-09-13, 12:21:18 »
Thanks
I added one domain and now apache and nginx and lighttpd work well.

Is there any documentation for
 admin — Servers — localhost — {Webserver Configure} ?

There is several option for php and others.

for example i want to know what is diference between php worker and php event.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,381
  • Karma: +113/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some Services not installed and some can not start.
« Reply #10 on: 2017-09-13, 12:27:21 »
In 'webserver configure', select all phps in 'multiple php install' and then click their 'update'. After all php installed, set 'php56m' in 'php used'. Select 'php-fpm_event' for 'php type'. And select 'medium' (if using webserver proxy like nginx-proxy) or 'high' (if using pure apache).

And then go to 'switch programs' and select 'use apache 2.4' and 'use pagespeed'.
« Last Edit: 2017-09-13, 12:38:51 by MRatWork »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,381
  • Karma: +113/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some Services not installed and some can not start.
« Reply #11 on: 2017-09-13, 12:37:28 »
Not, because limited RAM in your servre and not as 'shared hosting', don't select '   Multiple PHP Enable (for 'php-fpm')' (but just install 'multiple php').
« Last Edit: 2017-09-13, 12:40:03 by MRatWork »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.049 seconds with 19 queries.

web stats analysis