Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2021-03-05, 10:48:51

Author Topic: PHP ERROR  (Read 2209 times)

0 Members and 1 Guest are viewing this topic.

Offline kolovoip

  • Valuable Member
  • *
  • Posts: 52
  • Karma: +0/-0
    • View Profile
PHP ERROR
« on: 2017-07-25, 16:51:15 »
 I Ran sh /script/restart all  and got this error below
also my website is blank

Stopping php-fpm (PHP Used):                               [  OK  ]
Starting php-fpm (PHP Used):                               [  OK  ]
-------------------------------------------------------------------

Stopping php52m-fpm (Multiple Php):                        [  OK  ]
Starting php52m-fpm (Multiple Php): Failed loading /opt/php52m/usr/lib/php/modules/ioncube_loader_lin_5.2.so:  /opt/php52m/usr/lib/php/modules/ioncube_loader_lin_5.2.so: wrong ELF class: ELFCLASS64
                                                           [  OK  ]
-------------------------------------------------------------------

Stopping php53m-fpm (Multiple Php):                        [FAILED]
Starting php53m-fpm (Multiple Php):                        [FAILED]
-------------------------------------------------------------------

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP ERROR
« Reply #1 on: 2017-07-25, 18:28:58 »
Try 'sh /script/phpm-updater -y; sh /script/ioncube-installer'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline kolovoip

  • Valuable Member
  • *
  • Posts: 52
  • Karma: +0/-0
    • View Profile
Re: PHP ERROR
« Reply #2 on: 2017-07-25, 19:19:12 »
ok thanks fixed

but am still having the Below issues
Hello Mustafa
 am having problems with my kloxomr install missing lot of packages that a script I use need to work   kindly see below require php modules and others needed


please compare to see which is missing  in kloxomr

Apache 2.4

config
config-runtime
devel
mod_bwlimited
mod_cgi
mod_cloudflare
mod_deflate
mod_env
mod_expires
mod_headers
mod_mpm_prefork
mod_proxy
mod_proxy_fcgi
mod_proxy_http
mod_ruid2
mod_security2
mod_ssl
mod_unique_id

PHP 5.6
libc-client
pear
php
php-bcmath
php-calendar
php-cli
php-common
php-curl
php-devel
php-fpm
php-ftp
php-gd
php-imap
php-ioncube6
php-litespeed
php-mbstring
php-mcrypt
php-mysqlnd
php-pdo
php-posix
php-soap
php-sockets
php-xml
php-zendguard
php-zip
runtime

Offline kolovoip

  • Valuable Member
  • *
  • Posts: 52
  • Karma: +0/-0
    • View Profile
Re: PHP ERROR
« Reply #3 on: 2017-07-25, 20:56:09 »
lI tried to instal some of the missing modules and got this

[root@server ~]# yum install php-gd
Loaded plugins: fastestmirror, presto, priorities, protectbase, replace
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.osuosl.org
 * extras: mirror.keystealth.org
 * mratwork-epel: mirrors.cat.pdx.edu
 * mratwork-ius-archive: mirrors.kernel.org
 * mratwork-ius-stable: mirrors.kernel.org
 * mratwork-release-neutral-noarch: rpms.printographic.com
 * mratwork-release-version-arch: rpms.printographic.com
 * mratwork-webtatic: us-east.repo.webtatic.com
 * updates: mirror.keystealth.org
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package php-gd.i686 0:5.3.3-49.el6 will be installed
--> Processing Dependency: php-common(x86-32) = 5.3.3-49.el6 for package: php-gd-5.3.3-49.el6.i686
--> Running transaction check
---> Package php-common.i686 0:5.3.3-49.el6 will be installed
--> Processing Conflict: php56u-common-5.6.31-1.ius.centos6.i686 conflicts php-common < 5.6
--> Processing Conflict: php56u-gd-5.6.31-1.ius.centos6.i686 conflicts php-gd < 5.6
--> Processing Conflict: php56u-gmp-5.6.31-1.ius.centos6.i686 conflicts php-gmp < 5.6
--> Finished Dependency Resolution
Error: php56u-gmp conflicts with php-common-5.3.3-49.el6.i686
Error: php56u-common conflicts with php-common-5.3.3-49.el6.i686
Error: php56u-gd conflicts with php-gd-5.3.3-49.el6.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@server ~]#

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: PHP ERROR
« Reply #4 on: 2017-07-26, 03:07:51 »
Use 'yum install php56u-gd -y' instead 'yum install php-gd -y'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.044 seconds with 22 queries.

web stats analysis