Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2021-10-23, 23:13:18

Author Topic: KloxoMR Let's Encrypt / Letsencrypt: "Alert: Create Certificate failed  (Read 1707 times)

0 Members and 1 Guest are viewing this topic.

Offline postcd

  • Junior Member
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Hello,
when trying to setup LetsEncrypt SSL on KloxoMR 7.0.0.c-2017050104, it says "Alert: Create Certificate failed"

The log file: cat /var/log/acme.sh/acme.sh.log
Quote
Register account Error: {"type":"urn:acme:error:unauthorized","detail":"Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430 for details.","status": 403}
Please add '--debug' or '--log' to check more details.
See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh
Using CA: https://acme-v02.api.letsencrypt.org/directory

Then i have tried to get latest acme.sh:

mv /root/.acme.sh/acme.sh /root/.acme.sh/acmeold.sh;cd /root/.acme.sh/;wget https://raw.githubusercontent.com/acmesh-official/acme.sh/master/acme.sh;cd -;

Then the log shows:
Quote
Using CA: https://acme-v02.api.letsencrypt.org/directory
Registering account: https://acme-v02.api.letsencrypt.org/directory
Registered
ACCOUNT_THUMBPRINT='stringhere'
Creating domain key
The domain key is here: /root/.acme.sh/mydomainhere.tld/mydomainhere.tld.key
Multi domain='DNS:mydomainhere.tld,DNS:www.mydomainhere.tld,DNS:cp.mydomainhere.tld,DNS:webmail.mydomainhere.tld'
Getting domain auth token for each domain
Getting webroot for domain='mydomainhere.tld'
Getting webroot for domain='www.mydomainhere.tld'
Getting webroot for domain='cp.mydomainhere.tld'
Getting webroot for domain='webmail.mydomainhere.tld'
Verifying: mydomainhere.tld
mydomainhere.tld:Verify error:Fetching http://mydomainhere.tld/.well-known/acme-challenge/stringhere: Connection refused
Please add '--debug' or '--log' to check more details.
See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh

https://www.ecosia.org/search?q=verify+error%3A+fetching+Connection+refused

"apachectl configtest" and "sh /script/restart-web"
shown syntax errors:
Starting httpd: Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Invalid command 'ErrorLogFormat', perhaps misspelled or defined by a module not included in the server configuration
but when i check that .conf file and comment out the line like that, it complains about more and more lines. And end up reporting no log file set.

there are also script that suggests fixing web:
-rw-r--r-- 1 lxlabs lxlabs   452 May  1  2017 fixweb
-rw-r--r-- 1 lxlabs lxlabs    47 May  1  2017 fixweb-all
-rw-r--r-- 1 lxlabs lxlabs   175 May  1  2017 fixweb-defaults
but i do not know if that is safe to run these scripts

Please any idea how to fix it?
UPDATE: it may help to switch to nginx? Somehow web works now.

UPDATE2:
i ended up replacing /root/.acme.sh/acme.sh by https://raw.githubusercontent.com/acmesh-official/acme.sh/master/acme.sh
and then somehow it started working.

QUESTION: can this be somehow fixed for future usage, or what is the proper fix? Mine may not be good fix.
i may replace the old one by this new one, but i do not know if this is the problem cause

Offline azzureal

  • Master
  • **
  • Posts: 420
  • Karma: +1/-0
    • View Profile
how about this?

sh /script/letsencrypt-installer

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine

Page created in 0.04 seconds with 17 queries.

web stats analysis