Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-12-15, 07:59:12

Author Topic: Kloxo-MR, WP-API and NGINX : query parameters not working or ignored  (Read 2526 times)

0 Members and 1 Guest are viewing this topic.

Offline indomovi

  • Junior Member
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Hi Kloxo-MR Members,

I use wordpress with NGINX and php70m but i have a problem regarding $_GET params in WP-Api, i have searched in google and found that i have to change try_files in nginx conf "/opt/configs/nginx/conf/globals/example.com.conf" from:

try_files $uri $uri/ /index.php

to

try_files $uri $uri/ /index.php$is_args$args;

but this solution is not working, when i try to go to this page https://www.example.com/user-answer/?u=18 the server redirect me to homepage https://www.example.com (302)

i have also tried this type of try_files but no one is working

try_files $uri $uri/ /index.php$is_args$query_string;
try_files $uri $uri/ /index.php?$args;
try_files $uri $uri/ /index.php?$query_string;
try_files $uri $uri/ /index.php?q=$request_uri;
try_files $uri $uri/ /index.php$is_args$args;

info from google:
https://serverfault.com/questions/231578/nginx-php-fpm-where-are-my-get-params
http://v2.wp-api.org/guide/problems/#query-parameters-are-ignored
https://github.com/WP-API/WP-API/issues/540


My Kloxo-MR

[root@server01 ~]# sh /script/sysinfo
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017082302
   - Web: hiawatha-10.6.0-f.1.mr.el6.x86_64
   - PHP: php56s - 5.6.31-1.ius.centos6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname: server01.example.com
C. Services:
   1. MySQL: MariaDB-server-10.0.32-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.31-1.ius.centos6.x86_64
        - Multiple:
          * php52m - 5.2.17-102.mr.el6
          * php53m - 5.3.29-1.ius.centos6
          * php54m - 5.4.45-1.ius.centos6
          * php55m - 5.5.38-1.ius.centos6
          * php56m - 5.6.31-1.ius.centos6
          * php70m - 7.0.21-1.ius.centos6
          * php71m - 7.1.8-2.ius.centos6
      - Used: php56m-fpm
      - Multiple: enable
   3. Web Used: nginxproxy
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: ulyaoth-nginx-pagespeed-1.11.33.0-1.el6.x86_64
     - Apache: httpd24u-2.4.27-1.ius.centos6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.16-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
You are using NgnixProxy not Ngnix.

In ngnixProxy , Apache works in backend and on frontend ngnix.

I will refer you to use Apache. Or you can DM and provide the Teamviewer Details, I will be happy to assist you.

Offline indomovi

  • Junior Member
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Hi,

as you know in Kloxo-MR even if we use nginxproxy but we can choose between pure nginx or nginxproxy by selected front-end (pure nginx) or back-end (nginxproxy) in Web Features -> Web Selected

if we use back-end everything works well but when we get a high traffic than the website becoming slow.


Offline LotsOfQ

  • Master
  • **
  • Posts: 462
  • Karma: +1/-0
    • View Profile
I stop using nginx-proxy and went back to apache because nginx-proxy is not config right. WP cache plugins are not cache properly.

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.034 seconds with 19 queries.

web stats analysis