Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-06-19, 08:05:47

Author Topic: Kloxo-MR Fresh Install Problems  (Read 12273 times)

0 Members and 1 Guest are viewing this topic.

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Kloxo-MR Fresh Install Problems
« on: 2014-11-21, 04:34:26 »
Hello. I was using  LXAdmin kloxo and read about kloxo-MR and decided to move to it. Features are good on reading but when i fresh install it on a centos server i faced several difficulties which i want admins to notice.

1) DNS Not working (We have to manually switch program in order for it to work)

2) Apache Webserver Not working (We have to manually switch to other webserver and switch back to apache in  order for it to work)

3) Webmail not working (Couldnt make it to work yet)

4) if we switch to other php version from phpbrance option webserver stops working god knows how to make it work it again. whats the use of multiple php if we cant make it work

5) when adding domain we cannot set our own password . it gives error. after generating password it use it in the password field but display last message that password no accepted.

6) somehow yum stopped installing programmes after 20-30mins. It couldnt find the repository and download mirror sites. i reinstalled again and again for this problem.

Can you tell me to fix these problems. is there a set of settings like using what php brance with what php-type.
unless a new user make kloxo to work for first time, installation of kloxo-mr is useless. Like I am going nuts over googling and serching your forum to fix these problems. I formatted my vps 6-7 times for settings to work.

what I mean to say there should be some basic settings already set so everything works for first time.

still need  answers to those problems though. reply please.
« Last Edit: 2014-11-21, 04:36:09 by tinu »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #1 on: 2014-11-21, 05:20:47 »
Instead using 'php branch', better using 'phpXYm' (let say 'php53m') in 'php used'. Before this step, installing 'multiple php' via 'webserver configure'.

Switch between 'php branch' something doesn't work in certain server(s).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #2 on: 2014-11-21, 06:33:42 »
i reformatted server, reinstalled kloxo-mr and enabled multiple php.

after that i tried to change php branch but i am having same error. there are no changes saved there.

and i am getting Error 404 - Not Found

The requested page could not be found but may be available again in the future

on all pages, both webmail and domain pages.

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #3 on: 2014-11-21, 06:39:22 »
i switched to light tpd, and changed php type to mod-php-ruid2 and webmail page is working but domain pages stopped working.

Forbidden

You don't have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.29 (CentOS) Server at tinu.tk Port 80

UPDATE :: login not working for webmail. and Telaen giving files error on start
« Last Edit: 2014-11-21, 06:53:08 by tinu »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #4 on: 2014-11-21, 07:00:34 »
Try 'sh /script/fixskeleton; sh /script/fixweb; sh /script/fix-dns sh /script/restart-all -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #5 on: 2014-11-21, 07:05:50 »
I think i know whats the problem. why php version is not changing and why yum is not installing apps. i also noticed this earlier when i restart my ethernet adaptor disconnects. but i am using server and i am successfully connected and using vnc to reach server. somehow kloxo modified my net adaptor.

i can connect and use server but i cannot use, browser, install something etc. chaning php is using yum so i figured thats the problem. So how do i reenable my ethernet adaptor again?

 I already used those scripts sh /script/fixskeleton, sh /script/fixweb, sh /script/fixdns, sh /script/restart-all, sh /script/cleanup

I also reconfigured networking from vps control panel. i can use server, i can login and use vnc but i cant use internet on server.
« Last Edit: 2014-11-21, 07:18:05 by tinu »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #6 on: 2014-11-21, 07:26:12 »
1. For IP --> use 'IP re-read' in 'admin > servers > localhost > IP Address'
2. For switch php branch --> run 'yum replace php53u --replace-with=php54u' (example from php 5.3 to php 5.4)
3. Read http://forum.mratwork.com/kloxo-mr-tips-and-tricks/(tip)-how-to-set-dns/ and http://forum.mratwork.com/kloxo-mr-tips-and-tricks/(tip)-how-to-setup-qmail-on-kloxo-mr/ related to 'hostname'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #7 on: 2014-11-21, 07:45:58 »
I changed php type to php-fpm_event. that started kloxo webserver connection again and domain started working as they should but it messed up my internal networking and i cannot access internet on my vps. reread ip is of no use as there is no ip problem and ip is already in the kloxo list and adaptor list. but how do i restart my internal network??

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #8 on: 2014-11-21, 07:58:31 »
You can restart network with 'service network restart' or reboot.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #9 on: 2014-11-22, 03:12:43 »
Yeah been there. Done that a 1000 times. I am gonna stick to original kloxo. Kloxo mr is useless with this much problems.

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #10 on: 2014-11-22, 03:17:05 »
I was using kloxomr so that i can use 5.4 or 5.5 and use other webmail software. But i am gonna use original kloxo which supports php5.3 and mysql5 and roundcube webmail. Atleast its stable.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #11 on: 2014-11-22, 03:24:41 »
Good luck.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #12 on: 2014-11-22, 04:07:58 »
luck has got nothing to do with it sir. There is a good kloxo team behind it.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Kloxo-MR Fresh Install Problems
« Reply #13 on: 2014-11-22, 06:02:47 »
You said Kloxo official was stable and then I said 'good luck' for using Kloxo official.

In certain condition, may trouble using Kloxo-MR especially after installed. Usually, 'old trick' like switch web/dns and change php-type may fix certain issues. But, make sure, also running 'sh /script/fix-all; sh /script/restart-all -y' after using 'old trick'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tinu

  • Valuable Member
  • *
  • Posts: 76
  • Karma: +0/-0
    • View Profile
Re: Kloxo-MR Fresh Install Problems
« Reply #14 on: 2014-11-24, 05:57:04 »
ok will do what you adviced and update here. thanks for your time.

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.088 seconds with 18 queries.

web stats analysis