Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-06-20, 07:06:28

Author Topic: ioncube not working  (Read 2271 times)

0 Members and 1 Guest are viewing this topic.

Offline shaunrico

  • Junior Member
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: ioncube not working
« Reply #15 on: 2017-09-04, 12:39:46 »
Please look at the attached screenshot of my previous post.

I just showed to you that in 'php module status' the ioncube loader is enable already.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: ioncube not working
« Reply #16 on: 2017-09-04, 13:17:57 »
Check agaib for ioncube module for php71m.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline shaunrico

  • Junior Member
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: ioncube not working
« Reply #17 on: 2017-09-04, 18:31:13 »
when I do php -m, it's not there
Code: [Select]
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
gmp
hash
iconv
igbinary
imap
intl
json
ldap
libxml
mbstring
mcrypt
mongodb
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
pspell
readline
recode
Reflection
session
shmop
SimpleXML
snmp
soap
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tidy
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib

[Zend Modules]


when I do php -v, it's not there either

Code: [Select]
PHP 7.1.8 (cli) (built: Aug  7 2017 13:45:55) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies


Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: ioncube not working
« Reply #18 on: 2017-09-04, 20:26:11 »
Select 'php71m' for 'php used' in 'webserver configure'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline shaunrico

  • Junior Member
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: ioncube not working
« Reply #19 on: 2017-09-04, 20:33:47 »
OK I did what you said.
But still not working, ioncube not loaded.

here is the info:
Code: [Select]
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017083001
   - Web: hiawatha-10.6.0-f.1.mr.el6.x86_64
   - PHP: php56s - 5.6.31-1.ius.centos6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname: discountnow.club
C. Services:
   1. MySQL: MariaDB-server-10.0.32-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php71u-cli-7.1.8-2.ius.centos6.x86_64
        - Multiple:
          * php71m - 7.1.8-2.ius.centos6
      - Used: php71m-fpm
      - Multiple: disable
   3. Web Used: hiawathaproxy
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.13.4-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.27-1.ius.centos6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.16-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch

« Last Edit: 2017-09-04, 20:39:45 by shaunrico »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: ioncube not working
« Reply #20 on: 2017-09-04, 20:54:15 »
Remember, run 'php -v' mean execute php-branch and run 'php71m-cli -v' mean execute php71m.

Select 'php71m' for 'php used' mean default php for website is php71m.

Yoy can install all phpXYm for 'multiple php'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline shaunrico

  • Junior Member
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: ioncube not working
« Reply #21 on: 2017-09-05, 08:04:46 »
OK, it worked but after switching to php71m, my server was really unstable. I was getting high load for no reason. Website was going down.
Had to switch back.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: ioncube not working
« Reply #22 on: 2017-09-05, 08:15:44 »
I think php 7.1 still early to used. Better php 5.6 or 7.0.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.033 seconds with 17 queries.

web stats analysis