Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2020-10-19, 17:31:21

Author Topic: Install PHP 7.2 and PHP 7.3  (Read 7440 times)

0 Members and 1 Guest are viewing this topic.

Offline zokkie

  • Junior Member
  • *
  • Posts: 34
  • Karma: +0/-0
    • View Profile
Install PHP 7.2 and PHP 7.3
« on: 2020-01-05, 23:14:49 »
Hi There,

I want to install PHP 7.2 and PHP 7.3, how to install it. My Sysinfo:

A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2019070501
   - Web: hiawatha-10.9.0-f.2.mr.el6.x86_64
   - PHP: php56s - 5.6.30-2.ius.centos6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.10 (Final) x86_64
   - Hostname: server.host.com
C. Services:
   1. MySQL: MariaDB-server-10.0.38-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php71w-cli-7.1.33-1.w6.x86_64
        - Multiple:
          * php54m - 5.4.45-1.ius.centos6
          * php55m - 5.5.38-1.ius.centos6
          * php56m - 5.6.30-2.ius.centos6
          * php70m - 7.0.19-1.ius.centos6
          * php71m - 7.1.5-1.ius.centos6
      - Used: php71m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.9.0-f.2.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.47-2.el6.x86_64
     - Nginx: nginx-1.17.7-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.41-1.el6.ius.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: off
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.2.2-1.el6.x86_64
     - PowerDNS: pdns-4.1.8-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.5-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - pop3/imap4: dovecot-toaster-2.2.24-1.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.49-1.mr.el6.x86_64
   8. Stats: webalizer
      - webalizer: webalizer-2.23_08-1.mr.el6.x86_64

Thanks.

Offline rainwolf

  • Junior Member
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #1 on: 2020-01-06, 17:52:58 »
i have the same problem and i searched about it before,as I realized, you can only install  php 7.1+ on Cent OS V7 or higher :'(.So you have to Change your Os to 7... and remember that kloxo is not compatible with Cent OS 8 Version.
« Last Edit: 2020-01-06, 18:00:59 by rainwolf »

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,042
  • Karma: +1/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #2 on: 2020-01-12, 00:10:16 »
That's not true. I use CentOS 6.10 with PHP 7.3.13 from remi repo. Only PHP 7.4 is not possible.

PHP 7.3.13 (cli) (built: Dec 17 2019 16:10:55) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.13, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.13, Copyright (c) 1999-2018, by Zend Technologies

CentOS release 6.10 (Final)

Offline azzureal

  • Master
  • **
  • Posts: 410
  • Karma: +1/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #3 on: 2020-01-13, 04:23:40 »
Dear, Spacedust

Is it possible to get it on the list of kloxo php?

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,042
  • Karma: +1/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #4 on: 2020-01-13, 23:54:55 »
I simply used php branch. It sets default php version to 7.3.13.

PHP 7.4 is not possible on CentOS 6.10. Remi refused to compile it. Too much hassle.

Offline zokkie

  • Junior Member
  • *
  • Posts: 34
  • Karma: +0/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #5 on: 2020-01-16, 22:31:48 »
Spacedust,

How do you do that, via sh / script or other means.

Thanks in advance.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,042
  • Karma: +1/-0
    • View Profile
Re: Install PHP 7.2 and PHP 7.3
« Reply #6 on: 2020-01-21, 00:30:24 »
I've enabled remi PHP 7.3 repo and it replaced default php with the latest one.

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.042 seconds with 22 queries.

web stats analysis