Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-09-21, 16:07:42

Author Topic: Kloxo MR control Panel and Hosted Websites Down-Urgent Help Please  (Read 1868 times)

0 Members and 1 Guest are viewing this topic.

Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Hi,

I am facing problem of accessing my kloxo panel as well as hosted websites. Both the servers are not starting due to some error. I know that I deleted a ns1.domain.tld record and since then server could not restarted .Posting some results here.
 sh /script/restart-all

Shutting down system logger:                               [  OK  ]
Starting system logger:                                    [  OK  ]
-------------------------------------------------------------------

Stopping httpry:                                           [  OK  ]
Starting httpry:                                           [  OK  ]
-------------------------------------------------------------------

*** Process for MYSQL/MARIADB service ***
  - Process: restart
Shutting down MariaDB..                                    [  OK  ]
Starting MariaDB.180327 00:50:26 mysqld_safe Logging to '/var/lib/mysql/panel.fu                                                                              ndabazar.com.err'.
180327 00:50:26 mysqld_safe Starting mysqld daemon with databases from /var/lib/                                                                              mysql
                                                           [  OK  ]
-------------------------------------------------------------------

*** Process for BIND service ***
  - Process: restart
Stopping named:                                            [  OK  ]
Starting named:
Error in named configuration:
zone domain1.tld/IN: NS 'ns1.doamin1.tld' has no address records (A or AAAA)
zone domain1.tld/IN: not loaded due to errors.
_default/domain1.tld/in: bad zone
zone domain2.tld/IN: loaded serial 2018032505
zone domain1.tld/IN: loaded serial 2018032507
zone domain3.tld/IN: loaded serial 2018032503
zone domain4.tld/IN: loaded serial 2018032508
zone domain5.tld/IN: loaded serial 2018032509

                                                           [FAILED]
-------------------------------------------------------------------

Stopping php-fpm (PHP Used):                               [  OK  ]
Starting php-fpm (PHP Used):                               [  OK  ]
-------------------------------------------------------------------

*** Process for HTTPD service ***
  - Process: restart
Stopping httpd:                                            [FAILED]
Starting httpd:                                            [FAILED]
-------------------------------------------------------------------

*** Process for QMAIL service ***
Stopping qmail-toaster: svscan qmail logging.
qmail-send: no process killed
Starting qmail-toaster: svscan.
-------------------------------------------------------------------

Stopping pure-ftpd:                                        [  OK  ]
Starting pure-ftpd:                                        [  OK  ]
-------------------------------------------------------------------

Starting kloxo-hiawatha: Error loading X.509 certificates from /usr/local/lxlabs                                                                              /kloxo/etc/program.pem: UNKNOWN ERROR CODE (0001) (-0xFFFFFFFF)
                                                           [FAILED]
-------------------------------------------------------------------

Stopping kloxo-phpcgi:                                     [  OK  ]
Starting kloxo-phpcgi ('php56s' in 'fpm' mode):            [  OK  ]
-------------------------------------------------------------------

Kloxo Wrapper -> STOP
Kloxo Wrapper -> START

Please Help=> Thanks in Advance
« Last Edit: 2018-03-26, 21:27:53 by ebizfreak »

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
You should be able to regain access to the Control Panel using your server IP address.

In browser type: your-server-ip:7777 (or 7778)

(unless you have changed those ports)

Then fix your dns records

Best regards

AJ

Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Kloxo server is not running, No access either via ip or domain or ports 7777/7778. I know this problem is due to ns1 nameservers . Is there any way I can add A record through command line

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
On my server I have also installed Webmin, which work well alongside Kloxo-MR. In Webmin you can select Server - Bind DNS Server and it will list all your existing DNS Zones where you can select your domains and add or edit NS records. If you need I can send you the procedure to install Webmin.

AJ

Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Please send the link as soon as possible. I tried to install webmin by normal procedure but it says
0 packages excluded due to repository protections
No package webmin available.

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
Webmin is a free and good tool to supplement Kloxo-MR, and it will minimize your need for time on the command line.

Install Webmin using following procedure:

You must first create a txt-file and upload it to your server. I use Filezilla as SSH client and Sublime as text editor on my windows client. They work well together. You may have other tools, but it is necessary to uload the following text file to your server into the directory as stated below.

Paste the following text in your editor (including everything):

[Webmin]
name=Webmin Distribution Neutral
#baseurl=http://download.webmin.com/download/yum
mirrorlist=http://download.webmin.com/download/yum/mirrorlist
enabled=1

Save the file as webmin.repo to your computer, then use Filezilla or another FTP client to move it over to your server to folder: /etc/yum.repos.d folder.

From your SSH client (I use Putty) install the GPG key with which the packages are signed, with the following commands (do not include the #):

# cd /tmp
# wget http://www.webmin.com/jcameron-key.asc
# rpm --import jcameron-key.asc
# yum install webmin
# cd /

Start webmin and also auto start webmin at system startup

# /etc/init.d/webmin start
# chkconfig webmin on

With webmin installed, go to your server IP address at port 10000 http://youripaddress:10000. So if your IP address is 123.123.123.123 then your webmin address is:  http://123.123.123.123:10000

Login to webmin as root using and your server root password.

Things are arranged somewhat differently with the various Webmin themes. You can select any theme that you wish but for a start I suggest the following. Change themes, by clicking on “Webmin Configuration” in the upper left, then open the Webmin Themes icon. On the Change Themes tab, change it to Old Webmin Theme, then click the Make Changes button.

Now reload the webmin page.
Then select the Servers tab in Webmin, and then Bind DNS Server and you will get acces to your domains zonesand can change DNS records.

Hope this helps

AJ




Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
I have done this and added the the DNS record but still both apache and hiawatha not starting. I can see all my domains and configuration in Webmin but how do I make them to be served from webmin instead kloxo mr. Now kloxo mr says when starting servers

Starting kloxo-hiawatha: Error loading X.509 certificates from /usr/local/lxlabs/kloxo/etc/program.pem: UNKNOWN ERROR CODE (0001) (-0xFFFFFFFF)

*** Process for HTTPD service ***
  - Process: restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 90 of /etc/httpd/conf.d/~lxcenter.conf: Syntax error on line 12 of /opt/configs/apache/conf/domains/standardcleaning.ebizfreak.com.conf: </IfVersion> without matching <IfVersion> section

Error for Mariadb- ERROR! MariaDB server PID file could not be found!
 
Any how I want my website live, doesn't matter from kloxo or Webmin

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
Hmmmm. I am not an expert in this myself, and running out of ideas. Understand that you still do not have connect with Kloxo-MR panel. If you do have, then select switch program (in Kloxo-MR Server Box). Select for example nginxproxy in Web and click update. Then in SSH client enter sh /script/restart-all.

Using SSH client run:

yum clean all; yum update -y; sh /script/cleanup

Then in Kloxo-Mr go to Switch Program and change back to Apache under Web.

(If you dont have Kloxo-MR access, still do the yum clean all; yum update -y; sh /script/cleanup)

Finally, in SSH Client run sh /script/restart-all and see if you still have the errors.

AJ




 

Offline ebizfreak

  • Junior Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
I got everything fixed.

yum clean all; yum update -y; sh /script/cleanup did hiawatha and commenting skip-innodb with #skip-innodb in server.cnf file fixed mariadb for me and finally deleting all ssl certificates and restarting httpd worked. Problem was with wrong configuration of SSL in Apache files.

Thanks for help

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 43
  • Karma: +2/-0
    • View Profile
I am glad you got it working.

If you like Webmin you can also install same SSL certificate for Webmin. Simply access Webmin, click the Webmin icon and then select Webmin Configuration/SSL Encryption and paste the following path into the Private Key File window:

/home/kloxo/ssl/yourmaindomain.com.pem

You may have to reboot the server to make it working.

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.389 seconds with 19 queries.

web stats analysis