Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-07-14, 15:44:58

Author Topic: How to install GD Library?  (Read 6444 times)

0 Members and 1 Guest are viewing this topic.

Offline lewisngai

  • Junior Member
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
How to install GD Library?
« on: 2013-04-08, 08:55:45 »
Hi,

I have fresh installed the kloxoMR 6.5.0f on Centos 5.9 64bit, and some of my applications told me that the GD library is not exist.  I have tried 'yum install php-gd -y' but it prompts some transaction errors, so please give me some idea on how to install the gd library, thank you very much.

My webconfig:
nginxproxy
php53u
php-fpm_event
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline lewisngai

  • Junior Member
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: How to install GD Library?
« Reply #1 on: 2013-04-08, 09:06:12 »
Fine, work now.

yum install php53u-gd -y

thank you.
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline lupetalo

  • Senior Member
  • *
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: How to install GD Library?
« Reply #2 on: 2013-06-25, 17:51:11 »
Code: [Select]
yum install php53u-gd -y
Loaded plugins: fastestmirror, priorities, protectbase, replace
Loading mirror speeds from cached hostfile
 * base: mirror.ate.info
 * extras: mirror.ate.info
 * kloxo-mr-epel: mirror.de.leaseweb.net
 * kloxo-mr-ius: mirror.rackspace.co.uk
 * kloxo-mr-ius-c5: mirror.rackspace.co.uk
 * updates: mirror.ovh.net
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53u-gd.x86_64 0:5.3.26-1.ius.el6 will be installed
--> Processing Dependency: php53u-common = 5.3.26-1.ius.el6 for package: php53u-gd-5.                       3.26-1.ius.el6.x86_64
--> Processing Dependency: libt1.so.5()(64bit) for package: php53u-gd-5.3.26-1.ius.el                       6.x86_64
--> Running transaction check
---> Package php53u-common.x86_64 0:5.3.26-1.ius.el6 will be installed
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================
 Package             Arch         Version                   Repository          Size
=====================================================================================
Installing:
 php53u-gd           x86_64       5.3.26-1.ius.el6          kloxo-mr-ius       111 k
Installing for dependencies:
 php53u-common       x86_64       5.3.26-1.ius.el6          kloxo-mr-ius       557 k
 t1lib               x86_64       5.1.2-6.el6_2.1           base               160 k

Transaction Summary
=====================================================================================
Install       3 Package(s)

Total size: 828 k
Total download size: 111 k
Installed size: 4.1 M
Downloading Packages:
php53u-gd-5.3.26-1.ius.el6.x86_64.rpm                         | 111 kB     00:00
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /etc/php.ini from install of php53u-common-5.3.26-1.ius.el6.x86_64 conflicts w                       ith file from package php-common-5.3.26-1.el6.x86_64
  file /usr/lib64/php/modules/fileinfo.so from install of php53u-common-5.3.26-1.ius.                       el6.x86_64 conflicts with file from package php-common-5.3.26-1.el6.x86_64
  file /usr/lib64/php/modules/phar.so from install of php53u-common-5.3.26-1.ius.el6.                       x86_64 conflicts with file from package php-common-5.3.26-1.el6.x86_64
  file /usr/lib64/php/modules/zip.so from install of php53u-common-5.3.26-1.ius.el6.x                       86_64 conflicts with file from package php-common-5.3.26-1.el6.x86_64

Error Summary
-------------
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: How to install GD Library?
« Reply #3 on: 2013-06-25, 18:06:10 »
You using 'php' sd php-branch instead 'php53u'.

Try 'yum install php-gd'.
« Last Edit: 1970-01-01, 01:00:00 by Guest »
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline lupetalo

  • Senior Member
  • *
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: How to install GD Library?
« Reply #4 on: 2013-06-26, 19:18:53 »
What is difference? both are 5.3.26?
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline prandah

  • Senior Member
  • *
  • Posts: 344
  • Karma: +0/-0
    • View Profile
    • https://www.bowo.name
Re: How to install GD Library?
« Reply #5 on: 2013-06-26, 19:41:22 »
yes i saw your error is same version  5.3.26
maybe you need to remove first

yum remove php-gd php53u-gd

then re install again for "yum install php53u-gd -y"
« Last Edit: 1970-01-01, 01:00:00 by Guest »

Offline lupetalo

  • Senior Member
  • *
  • Posts: 182
  • Karma: +0/-0
    • View Profile
Re: How to install GD Library?
« Reply #6 on: 2013-06-26, 20:07:04 »
yum install php-gd worked, yum remove php-gd php53u-gd is removing a lot dependencies, not ok
« Last Edit: 1970-01-01, 01:00:00 by Guest »

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.024 seconds with 17 queries.

web stats analysis