Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-11-18, 13:35:34

Author Topic: Fresh install of Kloxo MR7 but can't start Apache!  (Read 726 times)

0 Members and 1 Guest are viewing this topic.

Offline lenawaii

  • Valuable Member
  • *
  • Posts: 97
  • Karma: +0/-0
    • View Profile
Hey there,

After install of kloxo mr7, i could not access kloxo panel and i found that because apache wasn't working, here is the bug:

Sep 10 01:05:07 serverx.domain.com systemd[1]: Starting The Apache HTTP Server...
Sep 10 01:05:07 serverx.domain.com httpd[17635]: AH00526: Syntax error on line 21 of /opt/configs/apache/conf/defaults/init.conf:
Sep 10 01:05:07 serverx.domain.com httpd[17635]: Cannot define multiple Listeners on the same IP:port
Sep 10 01:05:07 serverx.domain.com systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Sep 10 01:05:07 serverx.domain.com systemd[1]: Failed to start The Apache HTTP Server.
Sep 10 01:05:07 serverx.domain.com systemd[1]: Unit httpd.service entered failed state.
Sep 10 01:05:07 serverx.domain.com systemd[1]: httpd.service failed.

After commented line 21 in the init.conf, I have a bug with Bind:

Sep 10 01:29:38 serverx.domain.com named[19358]: the working directory is not writable
Sep 10 01:29:38 serverx.domain.com named[19358]: isc_stdio_open '/var/log/named/database.log' failed: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: configuring logging: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: loading configuration: permission denied
Sep 10 01:29:38 serverx.domain.com named[19358]: exiting (due to fatal error)
Sep 10 01:29:38 serverx.domain.com named[19347]: Starting named: [FAILED]
Sep 10 01:29:38 serverx.domain.com systemd[1]: named.service: control process exited, code=exited status=7
Sep 10 01:29:38 serverx.domain.com systemd[1]: Failed to start LSB: start|stop|status|restart|try-restart|reload|force-reload DNS server.
Sep 10 01:29:38 serverx.domain.com systemd[1]: Unit named.service entered failed state.
Sep 10 01:29:38 serverx.domain.com systemd[1]: named.service failed

Can you please help, thanks.


Offline azzureal

  • Senior Member
  • *
  • Posts: 334
  • Karma: +0/-0
    • View Profile
Re: Fresh install of Kloxo MR7 but can't start Apache!
« Reply #1 on: 2018-09-10, 08:50:06 »
Please run sh /script/cleanup and sh /script/fixweb

Offline lenawaii

  • Valuable Member
  • *
  • Posts: 97
  • Karma: +0/-0
    • View Profile
Re: Fresh install of Kloxo MR7 but can't start Apache!
« Reply #2 on: 2018-09-10, 13:15:10 »
thanks for the reply, i did what you suggested but no way. So I reinstall Centos 7 on the VPS and reinstalled Kloxo MR7 but i still have the same problem.

Any idea? Thank for helping

Offline lenawaii

  • Valuable Member
  • *
  • Posts: 97
  • Karma: +0/-0
    • View Profile
Re: Fresh install of Kloxo MR7 but can't start Apache!
« Reply #3 on: 2018-09-11, 21:56:44 »
Hey,

I found the solution, i changed of VPS provider and I could do the install with no trouble :-)

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.036 seconds with 23 queries.

web stats analysis