Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-09-23, 23:56:51

Author Topic: Facing error to create new db Could not connect to DB [Access denied for user  (Read 1257 times)

0 Members and 1 Guest are viewing this topic.

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
hi
[root@server ~]# sh /script/reset-mysql-root-password XXXXXXXXxx
Stop MySQL service...
MySQL ROOT password reset...
Start MySQL service...
[1]-  Done                    mysqld_safe --skip-grant-tables

but still i am facing error while creating New DB  Could not connect to DB [Access denied for user 'root'@'localhost' (using password: YES)]...



[root@server ~]# sh /script/sysinfo
A. Control Panel:
   - Kloxo-MR: 7.0.0.c-2017091202
   - Web: hiawatha-10.6.0-f.1.mr.el7.x86_64
   - PHP: php56s - 5.6.30-2.ius.centos7 (fpm mode)
B. Plateform:
   - OS: CentOS Linux release 7.4.1708 (Core) x86_64
   - Hostname: server.xxxx.com
C. Services:
   1. MySQL: --uninstalled--
   2. PHP:
      - Installed:
        - Branch: --uninstalled--
        - Multiple:
          * php54m - 5.4.45-14.mr.el7
          * php55m - 5.5.38-1.ius.centos7
          * php56m - 5.6.30-2.ius.centos7
          * php70m - 7.0.25-1.ius.centos7
          * php71m - 7.1.11-1.ius.centos7
      - Used: php56m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el7.x86_64
     - Lighttpd: lighttpd-1.4.47-1.el7.x86_64
     - Nginx: nginx-1.13.6-1.el7_4.ngx.x86_64
     - Apache: httpd24u-2.4.29-1.ius.centos7.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: nsd
     - Bind: bind-9.9.9-1.mr.el7.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el7.x86_64
     - NSD: nsd-4.1.16-1.el7.x86_64
     - PowerDNS: pdns-4.0.3-1.el7.MIND.x86_64
     - Yadifa: yadifa-2.2.6-1.el7.x86_64
   6. Mail: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el7.x86_64
      - smtp: qmail-toaster-1.03-1.3.57.mr.el7.x86_64
      - spam: bogofilter-1.2.3-6.el7.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.42-3.el7.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
              total        used        free      shared  buff/cache   available
Mem:           7877         740        5222          42        1914        7021
Swap:          1021           0        1021
E. Disk Space:
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        39G  5.2G   32G  15% /


Offline fossxplorer

  • Master
  • **
  • Posts: 640
  • Karma: +1/-0
    • View Profile
I think this is something i discussed with MR to be included, since AFAIK and IIRC, you need to specify the user (root in this case, otherwise user mysql will be used) when running that mysqld_safe command.

I had the same issue on CentOS 7.
Kloxo-MR!

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.049 seconds with 19 queries.

web stats analysis