Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-05-21, 22:42:36

Author Topic: Enabling Apache Deflate and PageSpeed module the right way  (Read 2632 times)

0 Members and 1 Guest are viewing this topic.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Enabling Apache Deflate and PageSpeed module the right way
« Reply #15 on: 2017-05-04, 14:22:49 »
Cache are enable in nginx and hiawatha by default. It's because implementing microcache for them. Micro-cache doesn't work under apache and lighttpd (or no effect for micro-cache setting).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline rsakhale

  • Valuable Member
  • *
  • Posts: 91
  • Karma: +0/-0
  • Gender: Male
  • Rohan Sakhale
    • View Profile
    • Rohan Rajan Sangita Sakhale
Re: Enabling Apache Deflate and PageSpeed module the right way
« Reply #16 on: 2017-05-04, 16:25:11 »
Thanks, @mustafa, and @fossxplorer for your support, gzip was already enabled after adding page speed, the problem was with WordPress minification plugin that caused the main trouble.

The speed of website has greatly improved, thanks a lot, guys.

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 117
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Enabling Apache Deflate and PageSpeed module the right way
« Reply #17 on: 2018-02-08, 12:30:35 »
Reason is this line:
[root@mail ]# cat -n /opt/configs/apache/tpl/defaults.conf.tpl| grep deflate
    61         exec("sed -i 's/^LoadModule deflate_module/#LoadModule deflate_module/' {$trgtcmdpath}/00-base.conf");

@mustafa, i think he should create  /opt/configs/apache/tpl/custom.defaults.conf.tpl where that line is commented out, then remove the uncomment it from:
[root@mail ]# cat -n /etc/httpd/conf.modules.d/00-base.conf| grep deflate
    30   #LoadModule deflate_module modules/mod_deflate.so

Finally run  sh /scripts//restart-web  ;)


@mustafa, i think i make sense to disable deflate_module when Apache is behind a proxy(Nginx or Hiawatha proxy) since at least Nginx proxy does it:
[root@mail linuxwonders]# grep -ri 'gzip on' /opt/configs/nginx/conf/*
/opt/configs/nginx/conf/globals/gzip.conf:   gzip on;  ;)


Worked for me

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.032 seconds with 18 queries.

web stats analysis