Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-27, 00:33:38

Author Topic: Another Letsencrypt problem  (Read 71 times)

0 Members and 1 Guest are viewing this topic.

Offline dfreddie

  • Valuable Member
  • *
  • Posts: 74
  • Karma: +0/-0
    • View Profile
Another Letsencrypt problem
« on: 2017-05-17, 08:11:43 »
sh /script/sysinfo -y
A. Control Panel:               
   - Kloxo-MR: 7.0.0.c-2017051601
   - Web: hiawatha-10.6.0-f.1.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname:
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.30-2.ius.centos6.x86_64
        - Multiple:
          * php52m-5.2.17-102.mr.el6
          * php53m-5.3.29-1.ius.el6
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.30-2.ius.centos6
          * php70m-7.0.18-1.ius.centos6
          * php71m-7.1.4-1.ius.centos6
      - Used: php71m-fpm
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.6.0-f.1.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.13.0-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.25-3.ius.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.16-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.56.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.56.mr.el6.x86_64
      - spam: --uninstalled--
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.37-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.6-1.mr.noarch
D. Memory:
             total       used       free     shared    buffers     cached
Mem:          5980       5113        867         21        508       2583
-/+ buffers/cache:       2020       3960
Swap:         3967        271       3696
E. Disk Space:
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_web-lv_root
                       50G  6.5G   41G  14% /


I had installed letsencrypt and is enabled only for admin's and onother user's domains.An is working for this domains.
But how can I enable letsencrypt for all clients domains?

Thank you!

P.S. Why in sysinfo is showing PHP 5.4 for panel? How can I change PHP for panel?

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,487
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Another Letsencrypt problem
« Reply #1 on: 2017-05-17, 08:18:29 »
1. Letsencrypt design for domain-based. Not work for wildcard (*) domain
2. Did you run 'sh /script/cleanup' after update?.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline dfreddie

  • Valuable Member
  • *
  • Posts: 74
  • Karma: +0/-0
    • View Profile
Re: Another Letsencrypt problem
« Reply #2 on: 2017-05-17, 08:22:22 »
1. I know is domain-based. But for others domains exept those mentioned, there is no letsencrypt menu.

2. every time I runed "yum clean all; yum update -y; sh /script/cleanup"

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,487
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Another Letsencrypt problem
« Reply #3 on: 2017-05-17, 08:26:38 »
1. Give screenshot where 'there is no letsencrypt menu'.

2. For change php for panel, try:
Code: [Select]
sh /script/phpm-installer php56s
sh /script/fixlxphpexe php56s
sh /script/restart
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline dfreddie

  • Valuable Member
  • *
  • Posts: 74
  • Karma: +0/-0
    • View Profile
Re: Another Letsencrypt problem
« Reply #4 on: 2017-05-17, 08:50:55 »
I uploaded 2 screenprints, one for an admin.s domain where letsencrypt is enebled and onother one for a client domain.
But ... what I remarked is that at client domain making click on Resource/ SSL/ SSL Certificates it takes me on client SSL Certificates ...


Thank you for upgrading panels PHP. It works!!!

Offline dfreddie

  • Valuable Member
  • *
  • Posts: 74
  • Karma: +0/-0
    • View Profile
Re: Another Letsencrypt problem
« Reply #5 on: 2017-05-17, 09:02:26 »
I got it!!!
I have tried to enable SSL for a client domain but logged in as Admin. Logged in as Client .... e voila ... letsencrypt was there :)

Thank you!!!
« Last Edit: 2017-05-17, 09:10:56 by dfreddie »

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.054 seconds with 18 queries.

web stats analysis