Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-12-13, 03:14:53

Author Topic: [fastcgi:error] [pid 2963] [mod_fastcgi.c(2241):] [FastCGI: neither POLLIN nor P  (Read 2904 times)

0 Members and 1 Guest are viewing this topic.

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
help with this

[fastcgi:error] [pid 2963] [mod_fastcgi.c(2241):] [FastCGI: neither POLLIN nor POLLOUT...]

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
I used to have this error before, and I believe it is related to PHP version. In my case the problem went away as I changed PHP version in Web features for my domains, but I guess it also has to do with how you set up Webserver Configure.

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
so how to solve this .

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
It depends on the applications you have installed on your server, and if their requirement are met by the configuration settings you are using.   

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
yes i change php version many time nothing helps

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Only thing I can inform is my settings. I use Apache, and the following settings in Webserver Configure:
PHP Used: ..PHP Branch..
PHP Branch: php56w_(as5-6-33)
Multiple PHP Already Installed: php54m php55m php56m php70m php71m
Multiple PHP Enable (for 'php-fpm'): Checked
PHP Type (for Apache): php-fpm_event
Enable Multiple PHP As Secondary PHP (for Apache): Checked
Apache Memory Optimize: Default

You can try these and see if it helps. (Remenber to run sh /script/restart-all)

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
not working still i have same config too

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile

Offline LotsOfQ

  • Master
  • **
  • Posts: 462
  • Karma: +1/-0
    • View Profile
Try uninstall any PHP version that you don't use.
Try 'sh /script/fixphp; sh /script/fixweb; sh /script/restart-web -y'
Try disable APC

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
nothing helps

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 291
  • Karma: +0/-0
    • View Profile
still not working

Offline atljohnsen

  • Junior Member
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Have you tried to change php-type in Webserver configure? Change to fcgid_event and see if that helps.  If you do that you must also change .htaccess accordingly (as described in Kloxo.MR section of that file). Then run sh /script/fixphp; sh /script/fixweb; sh /script/restart-web -y; sh /script/restart-all
I tried this on my testsite and it worked, but I got some permission issues that needed to be changed for everytning to work fine.



 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.035 seconds with 19 queries.

web stats analysis