Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2020-02-22, 15:35:07

Author Topic: [Critical]MariaDB not work with my kloxo  (Read 224 times)

0 Members and 1 Guest are viewing this topic.

Offline velf

  • Junior Member
  • *
  • Posts: 23
  • Karma: +0/-0
    • View Profile
    • hafana
[Critical]MariaDB not work with my kloxo
« on: 2020-02-11, 10:23:17 »
Hi please i really help to fix my vps. Problem such as

- web server is down
- mysql/mariadb can not work
- mail service

Chronology
1. At first everything run well until i made yum update and reboot server
2. After reboot server http webserver is down, i fix this after reading some forum post it seems problem with apache2 and apache 2.4
3. After webserver is working, but i still saw my website still not running
4. but hiawata is down, and i can not login to kloxo panel
5. I try to run 'sh cleanup' and 'sh upcp -y'
5. and everything start from here.
6. after all my MariaDb database always crash, and some critical application can not installed


Here is my sysinfo

Code: [Select]

A. Control Panel:               
   - Kloxo-MR: 7.0.0.c-2019070501
   - Web: hiawatha-10.9.0-f.2.mr.el6.x86_64
   - PHP: php56s - 5.6.40-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.10 (Final) x86_64
   - Hostname: xxxx.com
C. Services:
   1. MySQL: MariaDB-server-10.2.31-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php71u-cli-7.1.33-1.el6.ius.x86_64
        - Multiple:
          * php52m - 5.2.17-102.mr.el6
          * php53m - 5.3.29-1.ius.centos6
          * php54m - 5.4.45-1.ius.centos6
          * php55m - 5.5.38-1.ius.centos6
          * php56m - 5.6.30-1.ius.el6
          * php70m - 7.0.30-1.ius.centos6
          * php71m - 7.1.17-1.ius.centos6
      - Used: --PHP Branch--
      - Multiple: enable
   3. Web Used: apache
     - Hiawatha: hiawatha-10.9.0-f.2.mr.el6.x86_64
     - Lighttpd: --uninstalled--
     - Nginx: --uninstalled--
     - Apache: --uninstalled--
       - PHP Type: php-fpm_event (default)
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: --uninstalled--
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: --uninstalled--
      - pop3/imap4: none
      - smtp: none
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. FTP: pure-ftpd
      - pure-ftpd: pure-ftpd-1.0.49-1.mr.el6.x86_64
   8. Stats: awstats
      - awstats: kloxomr-stats-awstats-7.7-1.mr.noarch
D. Memory:
             total       used       free     shared    buffers     cached
Mem:         18432       2888      15543          5          0       2504
-/+ buffers/cache:        383      18048
Swap:            0          0          0
E. Disk Space:
Filesystem      Size  Used Avail Use% Mounted on
/dev/simfs       90G   68G   23G  76% /


*** Process Time: 00:00:00:45.45100 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)



If i ran 'sh upcp -y' i still got some problems, and here is log from terminal

Code: [Select]

Fix services
- Fix dns services
- Fix webcache services
- Fix ssl services
- Fix php services
- Fix web services
- Fix mail-all services
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
Enter password: /script/setup-roundcube: line 30: 21674 Terminated              mysql -f -u root -p"${rootpass}" < ${path}/SQL/mysql.initial.sql > /dev/null 2>&1
Enter password: /script/setup-roundcube: line 68: 21705 Terminated              mysql -u root -p"${rootpass}" -e "${SQL}" > /dev/null 2>&1
Enter password: /script/setup-roundcube: line 72: 22302 Terminated              mysql -f -u root -p"${rootpass}" < ${x} > /dev/null 2>&1


Please check complete log about 'sh upcp -y' at https://pastebin.com/pyDYtnLy

It seems problem with MariaDb in kloxo, and if i run service mysql restart it wont start.
Error in terminal

Code: [Select]

[root@yubster ~]# service mysql restart
MariaDB server PID file could not be found!                [FAILED]
Starting MariaDB.200211 03:04:32 mysqld_safe Logging to '/var/lib/mysql/yubster.com.err'.
200211 03:04:32 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
/etc/init.d/mysql: line 264: kill: (23091) - No such process
                                                           [FAILED]
Failed to restart server.                                  [FAILED]


and here is log from mysql

Code: [Select]
2020-02-11  3:04:32 140470652475360 [Note] Plugin 'InnoDB' is disabled.
2020-02-11  3:04:32 140470652475360 [Note] Plugin 'FEEDBACK' is disabled.
2020-02-11  3:04:32 140470652475360 [ERROR] Could not open mysql.plugin table. Some plugins may be not loaded
2020-02-11  3:04:32 140470652475360 [Note] Recovering after a crash using mysql-bin
2020-02-11  3:04:32 140470652475360 [Note] Starting crash recovery...
2020-02-11  3:04:32 140470652475360 [Note] Crash recovery finished.
2020-02-11  3:04:32 140470236649216 [Warning] Failed to load slave replication state from table mysql.gtid_slave_pos: 1286: Unknown storage engine 'InnoDB'
2020-02-11  3:04:32 140470652475360 [ERROR] Can't open and lock privilege tables: Unknown storage engine 'InnoDB'
2020-02-11  3:04:32 140470652475360 [Note] Server socket created on IP: '::'.
2020-02-11  3:04:32 140470652475360 [ERROR] Fatal error: Can't open and lock privilege tables: Unknown storage engine 'InnoDB'
2020-02-11  3:06:30 139896682899424 [Note] Plugin 'InnoDB' is disabled.
2020-02-11  3:06:30 139896682899424 [Note] Plugin 'FEEDBACK' is disabled.
2020-02-11  3:06:30 139896682899424 [ERROR] Could not open mysql.plugin table. Some plugins may be not loaded
2020-02-11  3:06:30 139896682899424 [Note] Recovering after a crash using mysql-bin
2020-02-11  3:06:30 139896682899424 [Note] Starting crash recovery...
2020-02-11  3:06:30 139896682899424 [Note] Crash recovery finished.
2020-02-11  3:06:30 139896265717504 [Warning] Failed to load slave replication state from table mysql.gtid_slave_pos: 1286: Unknown storage engine 'InnoDB'
2020-02-11  3:06:30 139896682899424 [ERROR] Can't open and lock privilege tables: Unknown storage engine 'InnoDB'
2020-02-11  3:06:30 139896682899424 [Note] Server socket created on IP: '::'.
2020-02-11  3:06:30 139896682899424 [ERROR] Fatal error: Can't open and lock privilege tables: Unknown storage engine 'InnoDB'


Please help to solve this problem
la..la.la..la..laa

Offline azzureal

  • Master
  • **
  • Posts: 401
  • Karma: +1/-0
    • View Profile
Re: [Critical]MariaDB not work with my kloxo
« Reply #1 on: 2020-02-19, 03:48:44 »
try

sh /script/mysql-convert

 ------------------------------------------------------------------------------
  format:
    sh /script/mysql-convert --engine=<> --database=[] --table=[] \
        --utf8=[] --config=[]
 ------------------------------------------------------------------------------
  --engine - change to MyISAM/InnoDB
  --database - database name; default: all databases
  --table - table name; default: all tables
  --utf8 - yes/no; default: no
  --config - yes/no; default: yes
      add on '/etc/my.cnf':
         'default-storage-engine=[engine]', and
         'skip-innodb' (for myisam)

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.042 seconds with 21 queries.

web stats analysis