Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2019-08-24, 20:36:50

Author Topic: (2)No such file or directory: FastCGI: neither POLLIN nor POLLOUT...  (Read 4417 times)

0 Members and 1 Guest are viewing this topic.

Offline azzureal

  • Master
  • **
  • Posts: 373
  • Karma: +1/-0
    • View Profile
The account has many domains.
But only one domain got this error '(2)No such file or directory: FastCGI: neither POLLIN nor POLLOUT...'...

I ran fixphp , fixweb and restart-web -y

But the same.

How can i Solve it?

[root@tiger ~]# sh /script/sysinfo

A. Kloxo-MR: 7.0.0.b-2014122501

B. OS: CentOS release 6.6 (Final) x86_64

C. Apps:
   1. MySQL: mysql55-5.5.40-2.ius.el6.x86_64
   2. PHP: php53u-5.3.29-1.ius.el6.x86_64
   3. Httpd: httpd-2.2.29-1.mr.el6.x86_64
   4. Lighttpd: --uninstalled--
   5. Hiawatha: hiawatha-9.9.0-f.3.mr.el6.x86_64
   6. Nginx: --uninstalled--
   7. Cache: --uninstalled--
   8. Dns: --uninstalled--
   9. Qmail: qmail-toaster-1.03-1.3.45.mr.el6.x86_64
      - with: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
« Last Edit: 2015-07-08, 01:25:06 by azzureal »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,657
  • Karma: +118/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Update your Kloxo-MR with 'yum clean all; yum update -y; sh /script/cleanup'. Your Kloxo-MR is very old.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 302
  • Karma: +0/-0
  • Gender: Male
  • I love this website
    • View Profile
    • VPN
i have still the same problum no one helps here some are trying
https://go.nordvpn.net/SH1ip
Best Vpn Till Date Try It

Offline atljohnsen

  • Valuable Member
  • *
  • Posts: 60
  • Karma: +2/-0
    • View Profile
I had a similar FastCGI error. In Kloxo-MR panel - Webservice configure I selected fcgid_event for PHP-type in stead of php-fpm_event. Then  'sh /script/fixphp; sh /script/fixweb; sh /script/restart-web -y'. No more error recorded in the error log in my case. You can try that to see if it helps.

Offline atljohnsen

  • Valuable Member
  • *
  • Posts: 60
  • Karma: +2/-0
    • View Profile
Ref my last msg. Maybe not a good idea after all. As a result I got other problems with my websites, so I had to go back to php-fpm_type again, and the fastcgi errors are poping up again in the error log again. Sorry. But I belive the problem must be with mod_fastcgi.

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 302
  • Karma: +0/-0
  • Gender: Male
  • I love this website
    • View Profile
    • VPN
how to fix mod_fastcgi ?
https://go.nordvpn.net/SH1ip
Best Vpn Till Date Try It

Offline atljohnsen

  • Valuable Member
  • *
  • Posts: 60
  • Karma: +2/-0
    • View Profile
Mod_fastCGI is just not somthing that can be fixed. It is old/depeciated, but have made life easier for many small sites for several years. Kloxo-MR use mod_fastcgi if you select php-fpm as php type in webserver configure. I have found it to be the best choise for my sites, and have to live with the error reports mentioned in the header. You can try out the other options like for example  proxy_fcgi_event, and the error reports will stop. It requires sethandlers to work, and I got several permission issues with it so i switched back to php-fpm. I am not at all an expert on these matters, but if anybody have experience with proxy_fcgi_event I would be glad to read how to configure this in Kloxo-MR.

Offline azzureal

  • Master
  • **
  • Posts: 373
  • Karma: +1/-0
    • View Profile
In my case, some outside banners had problems.

So I changed dns of resolved.conf.

Pleae try.

Offline atljohnsen

  • Valuable Member
  • *
  • Posts: 60
  • Karma: +2/-0
    • View Profile
@azzureal
I tried your suggestion to edit /etc/resolv.conf with other nameserver IPs like my static VPS IP, 127.0.0.1 and 8.8.8.8 but observed no change to my domain error log, where the following error is recorded exactly every 5 minutes:
[Tue Sep 04 04:45:06 2018] [fastcgi:error] [pid 1135] [mod_fastcgi.c(2241):] [FastCGI: neither POLLIN nor POLLOUT...] [mydomain.com]

Offline azzureal

  • Master
  • **
  • Posts: 373
  • Karma: +1/-0
    • View Profile
I changed  to 1.1.1.1 because it was blocked by adz of  my site.

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 302
  • Karma: +0/-0
  • Gender: Male
  • I love this website
    • View Profile
    • VPN
mine still not working
https://go.nordvpn.net/SH1ip
Best Vpn Till Date Try It

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 302
  • Karma: +0/-0
  • Gender: Male
  • I love this website
    • View Profile
    • VPN
any help
https://go.nordvpn.net/SH1ip
Best Vpn Till Date Try It

Offline nikobellicgamerin

  • Senior Member
  • *
  • Posts: 302
  • Karma: +0/-0
  • Gender: Male
  • I love this website
    • View Profile
    • VPN
help me
https://go.nordvpn.net/SH1ip
Best Vpn Till Date Try It

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,657
  • Karma: +118/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Try change httpd (apache) from 2.2 to 2.4 version.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline atljohnsen

  • Valuable Member
  • *
  • Posts: 60
  • Karma: +2/-0
    • View Profile
I use apache 2.4 and have similar error logged on all domains when using php-fpm_event in webserver configure

Error comes at regular intervals and looks like this:
[Mon Apr 22 10:39:49 2019] [fastcgi:error] [pid 15499] [mod_fastcgi.c(2241):] [FastCGI: neither POLLIN nor POLLOUT...] [mydomain.com]

If I switch to proxy_fcgi_event in webserver configure then error goes away.
So I believe the problem is caused by mod_fastcgi which is in use when using php-fpm mode.

AJ

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.037 seconds with 23 queries.

web stats analysis