Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-28, 03:03:49

Author Topic: Broken PHP!  (Read 427 times)

0 Members and 1 Guest are viewing this topic.

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Broken PHP!
« on: 2017-03-29, 19:57:20 »
I was testing PHP7  (mistakenly on the master, instead of on the slave!!) and everything is broken.
I've now chosen PHP 56w and it doesn't work.
What do i need to get back to php 5.6?
@mustafa
Kloxo-MR!

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Broken PHP!
« Reply #1 on: 2017-03-29, 20:17:50 »
Try 'sh /script/phpm-updater -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Re: Broken PHP!
« Reply #2 on: 2017-03-29, 20:28:34 »
Thanks a lot for replying so late Mustafa!

I fixed the original issue by going back to php 56 , updating to latest and running /scripts/cleanup.
Now the web pages work, but the clean process is still giving many errors;

ctivate Web servers
- Activate 'nginx' as Web server
- Activate 'apache' as Web server
Update All Php (branch and multiple)
- Update process
No Match for argument: phpstats
 error: not an rpm package
argument is not an RPM package
error: not an rpm package
argument is not an RPM package
error: not an rpm package
error: not an rpm package
argument is not an RPM package
error: not an rpm package
argument is not an RPM package
error: not an rpm package
argument is not an RPM package
error: not an rpm package
argument is not an RPM package
error: not an rpm package
argument is not an RPM package
error: not an rpm package

Is this known issue?

Please sleep, we can take it tomorrow :) It's not urgent issue the latter errors :)
Kloxo-MR!

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Broken PHP!
« Reply #3 on: 2017-03-29, 20:38:15 »
Look like something wrong with webtatic and or ius repo (declare inside /etc/yum.repos.d/mratwork.repo).
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Re: Broken PHP!
« Reply #4 on: 2017-03-29, 20:50:32 »
Ok, that's could be the reason.

Now i get
topping php70m-fpm (Multiple Php):                        [  OK  ]
Starting php70m-fpm (Multiple Php):                        [  OK  ]
-------------------------------------------------------------------

Stopping spawn-fcgi:                                       [FAILED]
Starting spawn-fcgi:                                       [FAILED]
-------------------------------------------------------------------

nginx: [emerg] duplicate location "/" in /opt/configs/nginx/conf/globals/switch_standard.conf:23
nginx: configuration file /etc/nginx/nginx.conf test failed
-------------------------------------------------------------------

Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
-------------------------------------------------------------------


*** Process for QMAIL service ***
Stopping qmail-toaster: svscan qmail logging.
qmail-send: no process killed
Starting qmail-toaster: svscan.
Kloxo-MR!

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Broken PHP!
« Reply #5 on: 2017-03-29, 21:33:46 »
Did you used latest Kloxo-MR 7.0?.

Inform here 'sh /script/sysinfo'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Re: Broken PHP!
« Reply #6 on: 2017-03-29, 22:15:27 »
Yes, latest KloxoMR 7c

[root@mail ~]# sh /script/sysinfo
A. Control Panel:               
   - Kloxo-MR: 7.0.0.c-2017032701
   - Web: hiawatha-10.5.0-f.2.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: mail.hostname.com
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56w-cli-5.6.30-1.w6.x86_64
        - Multiple:
          * php54m-5.4.45-1.ius.el6
          * php55m-5.5.38-1.ius.el6
          * php56m-5.6.30-1.ius.el6
          * php70m-7.0.16-1.ius.el6
      - Used: php56m-fpm
      - Multiple: enable
   3. Web Used: nginxproxy
     - Hiawatha: hiawatha-10.5.0-f.2.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.11.12-1.el6.ngx.x86_64
     - Apache: httpd24u-2.4.25-3.ius.el6.x86_64
       - PHP Type: php-fpm_event (default)
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.14-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: bogofilter-1.2.4-1.el6.x86_64
   7. Stats: awstats
D. Memory:
             total       used       free     shared    buffers     cached
Mem:          3774       3204        569         32        211        937
-/+ buffers/cache:       2055       1718
Swap:            0          0          0
E. Disk Space:
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_kloxomaster-lv_root
                      295G  258G   22G  93% /


*** Process Time: 00:00:00:47.47433 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

[root@mail ~]#
Kloxo-MR!

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Broken PHP!
« Reply #7 on: 2017-03-30, 02:46:49 »
Inform here '/opt/configs/nginx/conf/globals/switch_standard.conf'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Re: Broken PHP!
« Reply #8 on: 2017-03-30, 09:13:02 »
keepalive_timeout 15;

        ### MR -- just enough remove # below for enable nginx cache
        fastcgi_cache fcache;
        #fastcgi_cache_valid 200 1h;
        #fastcgi_cache_valid 301 1h;
        #fastcgi_cache_valid 302 1h;
        #fastcgi_cache_valid any 1m;

        fastcgi_cache_key "$scheme$request_method$host$request_uri";
        add_header X-Micro-Cache $upstream_cache_status;

        ## MR - increasing upload size to 64M (declare inside 'location /' not work
        client_max_body_size 64M;
        client_body_buffer_size 128k;

        fastcgi_buffer_size 128k;
        fastcgi_buffers 8 128k;

        fastcgi_request_buffering off;

        ### MR -- must be using nginx with including ngx_purge_cache
        ### must be using special nginx (nginx with ngx_purge_cache include
        location ~ /purge(/.*) {
                ### MR -- just enough remove # below for enable purge_cache
                #proxy_cache_purge pcache "$scheme://$host$1$request_method";
                allow 127.0.0.1;
                deny all;
        }

        ### MR -- for userdir (access with http://ip/~user)
        location ~ ^/~(.+?)(/.*)?$ {
                if (!-f /home/$1/public_html/$2) {
                        rewrite ^ 404;
                }

                alias '/home/$1/public_html$2';
                #autoindex on;
        }

        location ~ \.php$ {
                try_files $uri =404;

                include /etc/nginx/fastcgi_params;

                #fastcgi_pass 127.0.0.1:$var_fpmport;
                fastcgi_pass unix:/opt/configs/php-fpm/sock/$var_phpselected-$var_user.sock;
                fastcgi_index index.php;

                fastcgi_split_path_info ^(.+\.php)(/.+)$;

                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_param PATH_INFO $fastcgi_path_info;
                fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info;
        }

        location / {
                limit_conn conn_limit_per_ip 50;
                limit_req zone=req_limit_per_ip burst=250 nodelay;
       try_files $uri $uri/ /index.php;
        }

Kloxo-MR!

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,490
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Broken PHP!
« Reply #9 on: 2017-03-30, 10:22:17 »
Did you used customize configs?. I didn't found this issue in my test servers with using nginx or nginx-proxy.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline fossxplorer

  • Master
  • **
  • Posts: 602
  • Karma: +0/-0
    • View Profile
Re: Broken PHP!
« Reply #10 on: 2017-03-30, 12:44:37 »
yes, i had custom Nginx config when i updated, but i removed it now and ran cleanup.

Ok, then i will try to run a new cleanup this weekend and see how it goes.
Thanks alot!
Kloxo-MR!

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine

Page created in 0.034 seconds with 18 queries.

web stats analysis