Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2017-05-29, 05:42:42

Author Topic: Use Apache 2.4  (Read 402 times)

0 Members and 1 Guest are viewing this topic.

Offline tochits

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Use Apache 2.4
« on: 2017-04-07, 09:39:34 »
Checkbox is always ON even after attempting to check it off. Bug?
Code: [Select]
[root@kloxomr7-build-nginx flag]# sh /script/sysinfo
A. Control Panel:               
   - Kloxo-MR: 7.0.0.c-2017040602
   - Web: hiawatha-10.5.0-f.2.mr.el6.x86_64
   - PHP: php54s-5.4.45-2.w6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.9 (Final) x86_64
   - Hostname: kloxomr7-build-nginx.emc.ph
C. Services:
   1. MySQL: MariaDB-server-10.0.30-1.el6.x86_64
   2. PHP:
      - Installed:
        - Branch: php56u-cli-5.6.30-2.ius.el6.x86_64
      - Used: --PHP Branch--
      - Multiple: disable
   3. Web Used: nginx
     - Hiawatha: hiawatha-10.5.0-f.2.mr.el6.x86_64
     - Lighttpd: lighttpd-1.4.45-1.el6.x86_64
     - Nginx: nginx-1.11.13-1.el6.ngx.x86_64
     - Apache: httpd-2.2.31-1.mr.el6.x86_64
       - PHP Type: php-fpm_event
       - Secondary PHP: on
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: none
     - Bind: bind-9.9.9-1.mr.el6.x86_64
     - DJBDns: djbdns-1.05-17.4.mr.el6.x86_64
     - NSD: nsd-4.1.14-1.el6.x86_64
     - PowerDNS: pdns-4.0.3-1.el6.MIND.x86_64
     - Yadifa: yadifa-2.2.3-1.mr.el6.x86_64
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.20.mr.el6.x86_64
      - smtp: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - spam: --uninstalled--
   7. Stats: awstats
D. Memory:
             total       used       free     shared    buffers     cached
Mem:         31866        699      31167         46          0        549
-/+ buffers/cache:        150      31716
Swap:            0          0          0
E. Disk Space:
Filesystem      Size  Used Avail Use% Mounted on
/dev/simfs      1.1T  223G  865G  21% /


*** Process Time: 00:00:00:14.14329 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,888
  • Karma: +1/-0
    • View Profile
Re: Use Apache 2.4
« Reply #1 on: 2017-04-07, 23:17:54 »
Last time it was always OFF ;)

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,498
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Use Apache 2.4
« Reply #2 on: 2017-04-08, 16:24:56 »
In most situation, run 'sh /script/cleanup' will be fixed this issue.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline BigWeb.EU

  • Valuable Member
  • *
  • Posts: 83
  • Karma: +0/-0
    • View Profile
Re: Use Apache 2.4
« Reply #3 on: 2017-04-13, 19:44:26 »
I can confirm - error is still there on latest update today. cleanup/reboot does not help. Checkbox always stays ON :(

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,498
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Use Apache 2.4
« Reply #4 on: 2017-04-13, 19:49:55 »
Inform here 'yum list installed httpd* mod*; sh /script/sysinfo'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline tochits

  • Junior Member
  • *
  • Posts: 30
  • Karma: +0/-0
    • View Profile
Re: Use Apache 2.4
« Reply #5 on: 2017-04-27, 05:41:28 »
I would like to add some new, related info -  everytime I visit the page Servers -> localhost -> Switch program, I noticed that this file always get re-created in the server:

/usr/local/lxlabs/kloxo/etc/flag/use_apache24.flg

even if I know I don't have httpd24 installed. I have some machines that still use httpd, and I notice Kloxo replaces httpd with httpd24 when I run certain 'fix' scripts from /script. I'm thinking this flag file is causing the switch to httpd24.

This happens on httpd servers and nginx servers. Running the 'cleanup' script does not fix this problem.

Online MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 14,498
  • Karma: +105/-8
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Use Apache 2.4
« Reply #6 on: 2017-04-27, 05:45:55 »
Make sure using latest Kloxo-MR 7.0. If you delete use_apache24.flg and then run cleanup, it's will be switch to apache 2.2, except for CentOS 7.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.035 seconds with 18 queries.

web stats analysis