Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-11-15, 19:21:54

Author Topic: Some troubles with switch-apache script  (Read 9003 times)

0 Members and 1 Guest are viewing this topic.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #15 on: 2015-06-27, 20:16:01 »
Now got this one:

[root@backup /]# service httpd restart
Zatrzymywanie httpd:                                       [NIEUDANE]
Uruchamianie httpd: httpd: Syntax error on line 13 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_authn_alias.so into server: /etc/httpd/modules/mod_authn_alias.so: cannot open shared object file: No such file or directory
                                                           [NIEUDANE]

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #16 on: 2015-06-27, 20:18:40 »
It seems it copied the /etc/httpd/httpd.conf from previous version again :(

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #17 on: 2015-06-27, 20:29:16 »
I've copied proper httpd.conf and your new init.conf and now getting this one:

[root@backup defaults]# service httpd restart
Zatrzymywanie httpd:                                       [NIEUDANE]
Uruchamianie httpd: httpd: Syntax error on line 126 of /etc/httpd/conf/httpd.conf: Syntax error on line 82 of /etc/httpd/conf.d/~lxcenter.conf: Syntax error on line 15 of /opt/configs/apache/conf/defaults/init.conf: Could not open configuration file /opt/configs/apache/conf/globals/portnip.conf: No such file or directory
                                                           [NIEUDANE]

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some troubles with switch-apache script
« Reply #18 on: 2015-06-27, 20:30:35 »
Make sure enable 'use apache 2.4' in 'admin > switch programs'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some troubles with switch-apache script
« Reply #19 on: 2015-06-27, 20:32:00 »
Or use old trick. Set 'none' for web and then back to set 'apache' or proxy in 'admin > switch programs'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #20 on: 2015-06-27, 20:32:50 »
Or use old trick. Set 'none' for web and then back to set 'apache' or proxy in 'admin > switch programs'.

Already did that and no luck :( Did you upload these files correctly ?

Please note it's a slave.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some troubles with switch-apache script
« Reply #21 on: 2015-06-27, 20:42:26 »
From master, try 'sh /script/fixweb --server=all'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #22 on: 2015-06-28, 17:47:35 »
From master, try 'sh /script/fixweb --server=all'

Does not help - it happens on master as well.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some troubles with switch-apache script
« Reply #23 on: 2015-06-28, 18:15:37 »
Try copy from '/usr/local/lxlabs/kloxo/file/apache' to '/opt/configs/apache' in slave.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #24 on: 2015-06-28, 19:36:48 »
Try copy from '/usr/local/lxlabs/kloxo/file/apache' to '/opt/configs/apache' in slave.

It does not make sense - these files are not uploaded to github:

Quote
[root@backup ~]# cat /usr/local/lxlabs/kloxo/file/apache/conf/defaults/init.conf
### begin - web of initial - do not remove/modify this line

Define global::port 80
Define global::portssl 443
Define global::ip *

Listen ${global::ip}:${global::port}
Listen ${global::ip}:${global::portssl}

### end - web of initial - do not remove/modify this line

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #27 on: 2015-06-28, 20:56:19 »
Also please see: https://github.com/mustafaramadhan/kloxo/blob/dev/kloxo/file/apache/conf/defaults/init.conf
Only importance if no domain (fresh install before login).

I don't have any domain on this slave as it's a backup server. I'm using Apache for my stats only.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Some troubles with switch-apache script
« Reply #28 on: 2015-06-28, 23:08:19 »
Just create 'dummy' domain or create with name as the same as slave's hostname.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Some troubles with switch-apache script
« Reply #29 on: 2015-06-28, 23:24:44 »
Got it running on my Virtualbox ;D

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo
Click Here

Page created in 0.05 seconds with 23 queries.

web stats analysis