Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2019-06-26, 17:53:03

Author Topic: Nginx not listening via IPv6  (Read 196 times)

0 Members and 1 Guest are viewing this topic.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Nginx not listening via IPv6
« on: 2019-05-21, 19:30:13 »
I use this one for nginxproxy:

Quote
nginx -V
nginx version: nginx/1.16.0 (packages.exove.com: SSE2, openssl-1.1.1b, PCRE JIT, TCP Fast Open)
built by gcc 7.3.1 20180303 (Red Hat 7.3.1-5) (GCC)
built with OpenSSL 1.1.1b  26 Feb 2019
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-pcre=../pcre-8.43 --with-pcre-jit --with-pcre-opt=-fPIC --with-openssl=../openssl-1.1.1b --with-libatomic --add-dynamic-module=../incubator-pagespeed-ngx-1.13.35.2-stable --build='packages.exove.com: SSE2, openssl-1.1.1b, PCRE JIT, TCP Fast Open' --with-openssl-opt=no-dtls --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC -mmmx -msse -msse2 -DTCP_FASTOPEN=23' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -pie'

Maybe you can release latest version 1.17.0?

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,522
  • Karma: +116/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx not listening via IPv6
« Reply #1 on: 2019-05-21, 22:44:59 »
Try update with 'yum clean all; yum update -y'.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #2 on: 2019-05-22, 10:11:19 »
I don't see with-ipv6 in this configure so maybe I need to use different package or compile myself.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #3 on: 2019-05-24, 23:09:36 »
Worked with package from your repo.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #4 on: 2019-05-26, 22:53:21 »
Still doesn't work with https. Only works with http (with nginxproxy).

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,522
  • Karma: +116/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx not listening via IPv6
« Reply #5 on: 2019-05-26, 23:02:19 »
Did 'general header' in 'web features' still?:

X-Content-Type-Options "nosniff"
X-XSS-Protection "1;mode=block"
X-Frame-Options "SAMEORIGIN"
Access-Control-Allow-Origin "*"
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #6 on: 2019-05-26, 23:11:43 »
Yes:

X-Content-Type-Options "nosniff"
X-XSS-Protection "1;mode=block"
X-Frame-Options "SAMEORIGIN"
Access-Control-Allow-Origin "*"

HTTPS header:

Strict-Transport-Security "max-age=2592000; preload"

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,522
  • Karma: +116/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx not listening via IPv6
« Reply #7 on: 2019-05-27, 04:15:11 »
I didn't found this issue for subdomain under nginx-proxy (tried for 'frond-end'/nginx or 'back-end'/nginx-proxy)
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,522
  • Karma: +116/-10
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Nginx not listening via IPv6
« Reply #9 on: 2019-05-28, 13:34:56 »
My server didn't set IPv6.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #10 on: 2019-05-28, 13:41:45 »
Please check PM.

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #11 on: 2019-05-28, 14:38:56 »
Again - many bugs in these listen_ssl files:

cat listen_ssl.conf
listen 443 ssl http2;
listen [::]:433 ssl http2; - should be 443

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 4,012
  • Karma: +1/-0
    • View Profile
Re: Nginx not listening via IPv6
« Reply #12 on: 2019-05-28, 14:40:44 »
And all works right away - https via iPV6 with nginxproxy now works! Must be everywhere 443 or 8443.

 


Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo

Page created in 0.083 seconds with 22 queries.

web stats analysis