Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2024-07-15, 10:03:44

Author Topic: Hiawathaproxy and Apache  (Read 4805 times)

0 Members and 1 Guest are viewing this topic.

Offline kloxo-fan

  • Junior Member
  • *
  • Posts: 31
  • Karma: +2/-0
    • View Profile
Hiawathaproxy and Apache
« on: 2014-10-22, 09:52:02 »
For several days I have a problem with hiawathaproxy or apache as a web server.

Hiawathaproxy error:

after cleanup - started but not works
Code: [Select]
Stopping Hiawatha web server:                              [FAILED]
Starting Hiawatha web server:                              [  OK  ]

after restart-all or restart-web - there is an error somewhere
Code: [Select]
*** Process for HIAWATHA service ***
  - No need started
  - Process: reload
Reloading configuration:                                   [FAILED]
-------------------------------------------------------------------
*** Process for HTTPD service ***
  - No need started
  - Process with 'apachectl': graceful
No message for graceful


Apache error:

after cleanup - looks OK but websites not work:
Code: [Select]
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

after restart-all or restart-web
Code: [Select]
*** Process for HTTPD service ***
  - No need started
  - Process with 'apachectl': graceful
No message for graceful

With apache as webserver domains not works.
for example: http://some.domain shows
Webmail List
1   -   Afterlogic
2   -   Egroupware
3   -   Horde
4   -   Roundcub
5   -   Squirrelmail
6   -   T-dah
7   -   Telaen

but not web content  of the domain

Only with Nginxproxy everything works fine.

How to fix Hiawathaproxy and Apache web servers?

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Hiawathaproxy and Apache
« Reply #1 on: 2014-10-22, 11:10:04 »
Server for this forum using hiawatha-proxy. No issue related to your report.

Yes, server for this forum always using latest update for Kloxo-MR 7.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline kloxo-fan

  • Junior Member
  • *
  • Posts: 31
  • Karma: +2/-0
    • View Profile
Re: Hiawathaproxy and Apache
« Reply #2 on: 2014-10-22, 11:41:05 »
With Hiawathaproxy I got Error 521 every time.
With Apache all domains shows Webmail page instead of websites contents.
I know it's weird  :o
It happens on VPS with OpenVZ with kernel version 2.6.32-042stab093.4.

The other VPS is Cloud Linux VPS with kernel version 2.6.32-431.23.3.el6.x86_64 and I have no this problems.

Is it possible the problem is caused by OpenVZ technology or kernel?

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,807
  • Karma: +119/-11
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Hiawathaproxy and Apache
« Reply #3 on: 2014-10-22, 11:56:20 »
OpenVZ more trouble than other Virtualization.

An example, no success for install if using Burst with guarantee RAM less than 1GB. In fact, nothing problem with Xen/KVM with 256MB RAM. It's related to yum issue.

Another issue, also related to yum, something wrong detect for CentOS version for repo.

Try using other CentOS version.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

 


Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine

Page created in 0.041 seconds with 18 queries.

web stats analysis