Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-07-21, 05:31:32

Author Topic: Confirm bug php code not working on webmail ns1 ns2 pages  (Read 7751 times)

0 Members and 1 Guest are viewing this topic.

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #15 on: 2016-05-26, 20:24:55 »
I found couldn't login to webmail. But, need reset email password.
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #16 on: 2016-05-26, 20:33:44 »
@ Wibowo

php7 doesnt support many webmail iteam so try to use php 5.4 etc

Offline Wibowo

  • Master
  • **
  • Posts: 391
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #17 on: 2016-05-26, 20:43:42 »
@ Wibowo

php7 doesnt support many webmail iteam so try to use php 5.4 etc

php7 used inside root domain folder with .htaccess
using php56u as my php branch because my php script can't run with version less than php55

======================edit===================

problem with php xml module
solved by reinstalling my php56u-xml module
« Last Edit: 2016-05-26, 20:50:44 by Wibowo »

Offline Spacedust

  • Super Grand Master
  • ****
  • Posts: 3,962
  • Karma: +1/-0
    • View Profile
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #18 on: 2016-05-26, 23:29:02 »
I use PHP7 for afterlogic and it works perfectly ;)

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #19 on: 2016-05-27, 08:17:11 »
while installation new kloxomr7

Please solve the include file location fresh install also have this issue

[global]
pid=/var/run/php-fpm/php-fpm.pid
error_log=/var/log/php-fpm/error.log
log_level=error

;emergency_restart_threshold=0
;emergency_restart_interval=0
;process_control_timeout=0

emergency_restart_threshold=10
emergency_restart_interval=1m
process_control_timeout=10s

events.mechanism=epoll

daemonize=yes

include=/opt/configs/php-fpm/conf/php/*.conf


Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #20 on: 2016-05-27, 08:37:56 »
Here is fresh install server sysinfo webmail is not working

sh /script/sysinfo -y
A. Control Panel:
   - Kloxo-MR: 7.0.0.b-2016052507
   - Web: hiawatha-10.2.0-f.6.mr.el6.x86_64
   - PHP: php54s-5.4.45-1.ius.el6 (fpm mode)
B. Plateform:
   - OS: CentOS release 6.8 (Final) x86_64
   - Hostname: vps
C. Services:
   1. MySQL: MariaDB-server-10.0.25-1.el6.x86_64
   2. PHP:
      - Branch: php54-cli-5.4.45-1.ius.el6.x86_64
      - Used: --Use PHP Branch--
   3. Web Used: apache
     - Hiawatha: --unused--
     - Lighttpd: --uninstalled--
     - Nginx: --uninstalled--
     - Httpd: httpd-2.2.31-1.mr.el6.x86_64
       - PHP Type: [unknown]
   4. WebCache: none
     - ATS: --uninstalled--
     - Squid: --uninstalled--
     - Varnish: --uninstalled--
   5. Dns: bind
     - Bind: bind-9.9.7-1.mr.el6.x86_64
     - DJBDns: --uninstalled--
     - NSD: --uninstalled--
     - PowerDNS: --uninstalled--
     - Yadifa: --uninstalled--
   6. Mail: qmail-toaster-1.03-1.3.55.mr.el6.x86_64
      - pop3/imap4: courier-imap-toaster-4.1.2-1.3.18.mr.el6.x86_64
      - spam: bogofilter
D. Memory:
                total       used       free     shared    buffers     cached
   Mem:          1829        619       1210          0         30        324
   -/+ buffers/cache:        264       1564
   Swap:            0          0          0
E. Disk Space:
   Filesystem      Size  Used Avail Use% Mounted on
   /dev/vda1       9.8G  2.4G  6.9G  26% /


*** Process Time: 00:00:00:43.43249 (dd:hh:mm:ss:xxxxxx) ***

* Note: run 'sh /script/sysinfo -y' if you want run 'fix-service-list' also
        (importance after Kloxo-MR update)


------------------------

this to have php fpm include location error . as well as on webmail page php executing is not working .

------------ Now i can see webmail after , roundcube etc.. same issue when i click on it, showing 500 error and on firefox it showing blank page.
MR sir if you want i can provide you root details.
« Last Edit: 2016-05-27, 08:52:06 by amitkumar »

Offline MRatWork

  • Administrator
  • The Elite
  • *****
  • Posts: 15,382
  • Karma: +115/-9
  • Gender: Male
    • View Profile
    • MRatWork Forum
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #21 on: 2016-05-27, 10:34:15 »
1. Set hostname 'vps.yourrealdomain.com' instead 'vps'
2. Set 'php type' as 'php-fpm_event' in 'webserver configure' and enable 'enable secondary php'
..:: MRatWork (Mustafa Ramadhan Projects) ::..
-- Server/Web-integrator - Web Hosting (Kloxo-MR READY!) --

Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #22 on: 2016-05-27, 15:05:06 »
my i have edited that hostname line
server.domain.xyz

and i didn't try the secondary php.

Sir, Can use also fix that include error in next update. I am really pissed of because of that error. Usually i get 500 error after fixing of include of /etc/php-fpm all things work fine expect webmail .

Offline Wibowo

  • Master
  • **
  • Posts: 391
  • Karma: +0/-0
  • Gender: Male
    • View Profile
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #23 on: 2016-05-28, 18:50:54 »
reinstalling php56u-xml didn't solve the problem permanently
it happened again few hours ago and i need to reinstall php56u-xml again


Offline amitkumar

  • Valuable Member
  • *
  • Posts: 119
  • Karma: +1/-1
  • Gender: Male
    • View Profile
    • webquicksolution
Re: Confirm bug php code not working on webmail ns1 ns2 pages
« Reply #24 on: 2016-05-28, 19:23:01 »
Finally everything is fine.

Thank you MR sir..

---

Enabling secondary php and also use the sh /script/fix-all command

after installation we have to change etc/php-fpm

include location ...

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix
Click Here

Page created in 0.064 seconds with 23 queries.

web stats analysis