Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-11-21, 17:31:04

Author Topic: "^ M" in /opt/configs/apache/conf/domains/*  (Read 954 times)

0 Members and 1 Guest are viewing this topic.

Offline KloxoLittleFish

  • Valuable Member
  • *
  • Posts: 147
  • Karma: +0/-0
    • View Profile
"^ M" in /opt/configs/apache/conf/domains/*
« on: 2017-09-22, 19:15:24 »
When I open the domain files with the vi editor I have seen an "^ M" appear in the code:

Code: [Select]
<IfModule mod_headers.c>
                Header always set X-Content-Type-Options "nosniff"^M
                Header always set X-XSS-Protection "1;mode=block"^M
                Header always set X-Frame-Options "SAMEORIGIN"^M
                Header always set Access-Control-Allow-Origin "*"
                Header always set X-Supported-By "Kloxo-MR 7.0"
                RequestHeader unset Proxy early
  </IfModule>

I mention it in case it is due to an error when converting/saving the text of the Kloxo forms.

Quote
Clients —  "Username" — Domains — "Userdomain.com" — {Web Features} => General Header (in Apache Format; Blank To Reset)


I have provisionally cleaned the files with a:

Code: [Select]
perl -p -i -e "s/\r//g" /opt/configs/apache/conf/domains/*

 


MRatWork Affiliates:    BIGRAF(R) Inc.    House of LMAR    EFARgrafix

Page created in 0.031 seconds with 19 queries.

web stats analysis