Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-02-25, 14:21:06

Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Kloxo-MR Technical Helps / [URGENT] Please help [URGENT]
« Last post by LotsOfQ on 2018-02-12, 08:24:01 »
Kloxo-MR 7.0.0.c-2017091202 updated earlier today

I was trying to backup /usr/bin and make copies and all of a sudden all of the folders show up at 0kb. Every folders when I am inside Kloxo are all at 0kb.

I then tried:
sh /script/fix-all (didn't work, got a lot of command not find)
sh /script/restart-all (same thing)
yum update -y (-bash: yum: command not found)

Then finally tried 'sh /script/upcp -y' and got this:
Code: [Select]
/script/fixrepo: line 3: yum: command not found
/script/fixrepo: line 6: yum: command not found
/script/fix-urgent: line 60: tr: command not found
/script/fix-urgent: line 68: head: command not found
Already use MariaDB. No replace
Already stopped.
/etc/init.d/qmail: line 62: killall: command not found
/script/upcp: line 100: tee: command not found
/usr/local/lxlabs/kloxo/install/setup.sh: line 27: yum: command not found

I rebooted. Now I can't log into Kloxo-MR anymore.

All websites are up but are all mess up all looking weird and can't connect to basebase.


22
Kloxo-MR Bugs and Requests / Re: Redirect not working
« Last post by amitkumar on 2018-02-08, 13:03:42 »
go to all domain and select your domain and go to web features , you will get it what to do .
23
Reason is this line:
[root@mail ]# cat -n /opt/configs/apache/tpl/defaults.conf.tpl| grep deflate
    61         exec("sed -i 's/^LoadModule deflate_module/#LoadModule deflate_module/' {$trgtcmdpath}/00-base.conf");

@mustafa, i think he should create  /opt/configs/apache/tpl/custom.defaults.conf.tpl where that line is commented out, then remove the uncomment it from:
[root@mail ]# cat -n /etc/httpd/conf.modules.d/00-base.conf| grep deflate
    30   #LoadModule deflate_module modules/mod_deflate.so

Finally run  sh /scripts//restart-web  ;)


@mustafa, i think i make sense to disable deflate_module when Apache is behind a proxy(Nginx or Hiawatha proxy) since at least Nginx proxy does it:
[root@mail linuxwonders]# grep -ri 'gzip on' /opt/configs/nginx/conf/*
/opt/configs/nginx/conf/globals/gzip.conf:   gzip on;  ;)


Worked for me
24
Kloxo-MR Bugs and Requests / Redirect not working
« Last post by quacos on 2018-02-07, 10:47:02 »
When I add a redirect I am forced to reload Apache to make it work. Is it possible to reload Apache automatically?
25
Kloxo-MR Technical Helps / Re: How to disable open_basedir
« Last post by mehawk on 2018-02-06, 10:58:37 »
Hello,

First of all you must know the risk. Disabling open_basedir is highly discouraged because its implement to stop scripts from accessing directories out side execution location. In simple words it makes your server highly vulnerable.

This post is made to disable for a client / user when server is using php-fpm:

Go to  /opt/configs/php-fpm/tpl

Copy the contents of " php53-fpm-pool.conf.tpl ".

Create a new file with the name of " custom.php53-fpm-pool.conf.tpl ".


Paste the contents of " php53-fpm-pool.conf.tpl " in " custom.php53-fpm-pool.conf.tpl " and save the file.

Now we have created custom template of php53-fpm we need to modify custom.php53-fpm53-fpm-pool.conf.tpl.

Open in edit mode "custom.php53-fpm53-fpm-pool.conf.tpl".

Find following code:

Code: [Select]
if ($user === 'apache') {
// MR -- for future purpose, apache user have uid 50000
$fpmport = 50000;
$openbasedir = "/home/:/tmp/:/usr/share/pear/:/var/lib/php/session/";
} else {
$userinfo = posix_getpwnam($user);
$fpmport = (50000 + $userinfo['uid']);
$openbasedir = "/home/$user/:/tmp/:/usr/share/pear/:/var/lib/php/session/:".
"/home/kloxo/httpd/script/:/home/kloxo/httpd/disable/:{$extrabasedir}";
}

Replace above mentioned code with:
Code: [Select]
if ($user === 'apache') {
// MR -- for future purpose, apache user have uid 50000
$fpmport = 50000;
$openbasedir = "/home/:/tmp/:/usr/share/pear/:/var/lib/php/session/";
} else {
$userinfo = posix_getpwnam($user);
$fpmport = (50000 + $userinfo['uid']);
                if ($user === 'username_which_wants_basedir_disabled'){ $openbasedir = "none"; }
                else{
$openbasedir = "/home/$user/:/tmp/:/usr/share/pear/:/var/lib/php/session/:".
"/home/kloxo/httpd/script/:/home/kloxo/httpd/disable/:{$extrabasedir}";}
}

you will replace "username_which_wants_basedir_disabled" with the username for which open_basedir is being disabled.

Now in SSH console run following commands:

Code: [Select]
sh /script/fixphp
sh /script/restart-web -y'

Now you can check phpini of that user base dir will be disabled.

Best Regards,
Mehroz Anjum
26
Kloxo-MR Technical Helps / Re: How to disable open_basedir
« Last post by mehawk on 2018-02-06, 10:28:19 »
Please check

https://forum.mratwork.com/kloxo-mr-technical-helps/how-to-disable-open_basedir/
Actually that thread is not clear for a new user thats why i am writing the method.
27
Kloxo-MR Technical Helps / Re: How to disable open_basedir
« Last post by mehawk on 2018-02-06, 10:27:11 »
A few hours?

Sorry I forgot to write the method. I am writing it now
28
Kloxo-MR Technical Helps / Re: Lxguard
« Last post by atljohnsen on 2018-02-04, 11:17:58 »
Many tnx for advice. I have read everything in the forum about lxguard, but without success. I have 2 servers, both using Centos-7 and Kloxo-MR. On one lxguard is showing many entries in the Connections and Raw Connections tabs in lxguard, on the other there are none. But I can add and remove whitelis IPs with no problem. The only thing I can think of that may have caused the problem is that I used Webmin to remove a lot of files from the /tmp directory. This may have damages some socks ????
In both my servers I notice that there are several thousand tmp-files. Is this normal ?
One question: In order to try to get lxguard running again, do you think I can yum remove kloxo and then yum install kloxo. Will I then loose the configuration settings ??? 
29
Kloxo-MR Technical Helps / Re: Named status, some notices/errors?
« Last post by priyadi on 2018-02-03, 10:13:52 »
you can try chown -R named.named /opt/configs/nsd/conf

look working directory from this config /opt/configs/bind/conf/defaults/named.options.conf
30
Kloxo-MR Technical Helps / Re: Help in restoring from old version kloxo
« Last post by azzureal on 2018-02-03, 03:32:30 »
1. Need running 'sh /script/backup-patch' in Kloxo Official (6.1.12) before backup data.

    - In Kloxo offical run:

        cd /script
        wget https://github.com/mustafaramadhan/kloxo/raw/dev/kloxo/pscript/backup-patch  --no-check-certificate
        sh ./backup-patch

2. Need remove certain rpms in Kloxo Official after 6.1.12 (testing in 6.1.19)

    # remove packages from Kloxo Official
    yum remove kloxo* -y
   
3. Since 6.5.0.f-20130701, Kloxo-MR using MySQLi API instead MySQL API. Need update mysql 5.0.x to 5.1.x or above for Centos 5.

    Check mysql version with:

        mysql -V|awk '{print $5}'

    Update with:

        yum replace mysql --replace-with=mysql55' (ask to forum for update to MariaDB)

4. Make sure all MySQL databases in MyISAM storage-engine (especially upgrade to version 6.5.0) with execute:

    ## convert to MyISAM storage-engine
    sh /script/mysql-convert --engine=myisam

5. Trouble with 'rpm -Uvh':

    In CentOS 32bit may trouble with:

        # install rpm (read Warning)
        rpm -Uvh https://github.com/mustafaramadhan/rpms/raw/master/mratwork/release/neutral/noarch/mratwork-release-0.0.1-1.noarch.rpm

    and then use:

        cd /tmp
        # remove old rpm
        rm -f mratwork*

        # get rpm file
        wget https://github.com/mustafaramadhan/rpms/raw/master/mratwork/release/neutral/noarch/mratwork-release-0.0.1-1.noarch.rpm

rpm -ivh mratwork-release-0.0.1-1.noarch.rpm
Pages: 1 2 [3] 4 5 ... 10

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.048 seconds with 13 queries.

web stats analysis