Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2018-12-18, 15:30:28

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Richa

Pages: [1]
1
Kloxo-MR Development / Some suggestions for Kloxo-MR
« on: 2016-11-13, 11:44:39 »
1. A front-end multiple php versions switcher on the display page instead .htaccess for each clients.

2. Smarty is a free and opensource php template engine. I think it is very flexible. *.tpl is the extension for smarty files. However it is hard to create skins of Kloxo-MR. So I think you can use it: http://www.smarty.net/.

Thanks for your great work  ;)

2
I created a "Login to Kloxo-MR" button on the client area of WHMCS to auto login Kloxo-MR.

The following is my code:
Code: [Select]
<form method="post" action="http://127.0.0.1:7778/lib/php/" target="_blank">
<input type="hidden" name="frm_clientname" value="admin">
<input type="hidden" name="frm_password" value="12345">
<input type="submit" value="Login to Kloxo-MR">
</form>

However when I click it, it returns:
Code: [Select]
*** Token not match. No permit for remote login. Go back to login page ***
I noticed there is a input named 'frm_token'.
Then I viewed the topic: https://forum.mratwork.com/kloxo-mr-technical-helps/login-fail-attemps/msg54368/#msg54368
So I ran the commands on my server:
Code: [Select]
touch /usr/local/lxlabs/kloxo/httpdocs/lib/php/no_need_token
sh /script/restart -y

But still the problem.

What should I do? Thank you.  :)


3
Hello.

I try to configure let's encrypt on the server via kloxo-mr7, but when I run letsencrypt-auto, it returns the following error:
Code: [Select]
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Error while running apachectl configtest.
httpd: Syntax error on line 8 of /etc/httpd/conf/httpd.conf: 
Include directory '/etc/httpd/conf.modules.d' not found   

Then I try mkdir /etc/httpd/conf.modules.d and run letsencript-auto again, it returns the following error:
Code: [Select]
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Error while running apachectl configtest.                 
Syntax error on line 43 of /etc/httpd/conf/httpd.conf:         
Invalid command 'ErrorLogFormat', perhaps misspelled or defined by 
a module not included in the server configuration

That's why? Thank you.

The following is letsencrypt.log:
Code: [Select]
2016-11-13 04:53:39,374:DEBUG:certbot.main:Root logging level set at 20
2016-11-13 04:53:39,380:DEBUG:certbot.main:certbot version: 0.9.3
2016-11-13 04:53:39,374:DEBUG:certbot.main:Root logging level set at 20
2016-11-13 04:53:39,380:DEBUG:certbot.main:certbot version: 0.9.3
2016-11-13 04:53:39,380:DEBUG:certbot.main:Arguments: []
2016-11-13 04:53:39,415:ERROR:certbot.util:Error while running apachectl configtest.


Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Traceback (most recent call last):
    self._initialized.prepare()
    self.config_test()
  File "/root/.local/share/letsencrypt/lib/python2.7/site-packages/certbot_apache/configurator.py", line 1687, in config_test
    raise errors.MisconfigurationError(str(err))
MisconfigurationError: Error while running apachectl configtest.

Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Invalid command 'ErrorLogFormat', perhaps misspelled or defined by a module not included in the server configuration

2016-11-13 04:53:39,420:DEBUG:certbot.plugins.selection:Single candidate plugin: * apache
Description: Apache Web Server plugin - Beta
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = certbot_apache.configurator:ApacheConfigurator
Initialized: <certbot_apache.configurator.ApacheConfigurator object at 0x7f338b98b310>
Prep: Error while running apachectl configtest.

Syntax error on line 43 of /etc/httpd/conf/httpd.conf:
Invalid command 'ErrorLogFormat', perhaps misspelled or defined by a module not included in the server configuration

2016-11-13 04:53:39,422:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

The following is httpd.conf:
Code: [Select]
ServerTokens OS

ServerRoot "/etc/httpd"

# MR -- must be disable here because can not overrite! -- importance for proxy-to-apache
# Listen 80

Include conf.modules.d/*.conf

User apache
Group apache

ServerAdmin root@localhost

<Directory />
    AllowOverride none
    Require all denied
</Directory>

DocumentRoot "/var/www/html"

<Directory "/var/www">
    AllowOverride None
    # Allow open access:
    Require all granted
</Directory>

# Further relax access to the default document root:
<Directory "/var/www/html">
    Require all granted
</Directory>

<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>

<Files ".ht*">
    Require all denied
</Files>

ErrorLogFormat "[%t] [%-m:%l] [pid %P] [%F:] [%M] [%v]"
ErrorLog "logs/error_log"

LogLevel error

<IfModule log_config_module>
        ## MR -- change %h to %a to fix mod_remoteip issue
    LogFormat "%a %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%a %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
    </IfModule>

    CustomLog "logs/access_log" combined
</IfModule>

<IfModule alias_module>
    # Alias /webpath /full/filesystem/path
    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
</IfModule>

<Directory "/var/www/cgi-bin">
    AllowOverride None
    Options None
    Require all granted
</Directory>

<IfModule mime_module>
    TypesConfig /etc/mime.types

    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    #AddHandler cgi-script .cgi
    #AddHandler type-map var

    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>

#AddDefaultCharset UTF-8

<IfModule mime_magic_module>
    MIMEMagicFile conf/magic
</IfModule>

Alias /error/ "/home/kloxo/httpd/error/"

<IfModule mod_negotiation.c>
    <IfModule mod_include.c>
        <Directory "/home/kloxo/httpd/error/">
            AllowOverride None
            Options IncludesNoExec
            AddOutputFilter Includes html
            AddHandler type-map var
            <IfVersion < 2.4>
                Order allow,deny
                Allow from all
            </IfVersion>
            <IfVersion >= 2.4>
                Require all granted
            </IfVersion>
                LanguagePriority en es de fr
            ForceLanguagePriority Prefer Fallback
        </Directory>

        #ErrorDocument 500 "The server made a boo boo."
        #ErrorDocument 404 /missing.html
        #ErrorDocument 404 "/cgi-bin/missing_handler.pl"
        #ErrorDocument 402 http://www.example.com/subscription_info.html

        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 501 /error/501.html
        ErrorDocument 502 /error/502.html
        ErrorDocument 503 /error/503.html
        ErrorDocument 504 /error/504.html
    </IfModule>
</IfModule>

EnableSendfile on

HostnameLookups Off

IncludeOptional conf.d/*.conf

4
Hello.

I am using the latest version of Kloxo-MR 7 and WHMCS 7.0.1.

When I use the Lxadmin module of WHMCS to create a hosting account on Kloxo-MR, it returns an error: Module Create Failed - Service ID: 4 - Error: __error_need

 I have tried on different servers, and checked almost all settings, but still cannot be solved.

Could you please help me? Thanks a lot.

Pages: [1]

Top 10 Social Networking:    Facebook    Twitter    LinkedIn    Pinterest    Google Plus    Tumblr    Instagram    VK    Flickr    Vine
Click Here

Page created in 0.039 seconds with 21 queries.

web stats analysis