Sponsor:

Server and Web Integrator
Link:
Kloxo-MR logo
6.5.0 or 7.0.0
Click for "How to install"
Donation/Sponsorship:
Kloxo-MR is open-source.
Donate and or Sponsorship always welcome.
Click to:
Click Here
Please login or register. 2019-07-22, 17:50:18

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - atljohnsen

Pages: [1]
1
Kloxo-MR Tips and Tricks / FFMPEG in Centos 7
« on: 2019-07-21, 01:27:01 »
I have in earlier posts in this forum seen requests for help on installing FFmpeg. This issue is not so much directed to Kloxo-MR but many have a need for handling multimedia files on their server, and FFmpeg contains a set of useful audio and video libraries such as libavcodec, libavformat, and libavutil. With FFmpeg, you can convert between various video and audio formats, set sample rates, capture streaming audio/video and resize videos. Especially social community websites benefit from FFmpeg, if for example using JomSocial.
FFmpeg is not available in CentOS 7 core repositories or those distributed with Kloxo-MR. It must therefore be installed using yum from Nux Dextop repository as follows:

The Nux repository depends on the EPEL software repository. If it is not enabled on your system, enable it via SSH (you need SUDO privileges)

#yum install epel-release

Next, import the Repository GPG key and enable the Nux repositories by installing the rpm package:

#rpm -v --import http://li.nux.ro/download/nux/RPM-GPG-KEY-nux.ro

#rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-5.el7.nux.noarch.rpm

Once the repository is enabled, install FFmpeg:

#yum install ffmpeg ffmpeg-devel

Verify the FFmpeg installation by running the ffmpeg -version command:

#ffmpeg -version

That’s it. FFmpeg will be on your CentOS 7. But for third party software like JomSocial to function you would need exec/passthru/shell_exec/system access, so you would need to change that in Kloxo-MR Admin/Advanced PHP settings.

Thanks for an excellent Control Panel - maybe the best. I have donated.

2
1. Is it still recommended to use Centos 7 minimal OS ?
2. Is it still recommended to disable SELINUX

Tnx in advance

3
Kloxo-MR Technical Helps / Opcache
« on: 2019-05-17, 08:50:33 »
I tried to enable opcache for phpXYm by renaming opcache.nonini in /opt/phpXYm/etc/php.d to 10-opcache_used.ini. (XY is the php version where opcache is needed). But when I did sh /script/cleanup I got error:

Failed loading /opt/phpXYm/usr/lib64/php/modules/opcache: Cannot open shared object file: No such file or directory.

So I modified 10-opcache_used.ini line 2 from
zend_extension=/opt/phpXYm/usr/lib64/php/modules/opcache
to
zend_extension=/opt/phpXYm/usr/lib64/php/modules/opcache.so

and this seem to work, - no error when I do sh /script/cleanup and also I see in Kloxo-MR Home - PHP Module Status that 10-Opcache is green.

4
Kloxo-MR Technical Helps / Lxguard
« on: 2018-01-09, 00:39:46 »
On one of my servers, when I select LxGuard in Kloxo-MR (latest version) there are no Connections or Raw Connections listed. That of course lead me to belive that LxGuard is not working here. I use SQL Manager and look in Kloxo DB, see the lxguard related tables, but table lxguardhit is empty. I tried the scripts like sh /script/fixlxguard but that does not change anything. I cannot find other indications in logfiles I have checked that something is wrong. Does anybody have a clue on how I can procede to find out what can be the problem ?

Pages: [1]

Top 4 Global Search Engines:    Google    Bing    Baidu    Yahoo

Page created in 0.092 seconds with 20 queries.

web stats analysis